Nozzles clogging

Hello all,
I’ve had several Budaschnozzle 2.0 clogging issues in the last few weeks. The problem seems to arise from switching from PLA printing to ABS. After successfully printing in PLA, I switch over to ABS at (230°) which starts printing fine, but after a couple prints the nozzle becomes clogged and won’t extrude at all. I would remove the nozzle to clean it out, but I’ve applied the PTFE tape so the PLA won’t leak, which makes the nozzle permanent. Has anyone else had similar problems? Seems like the Budaschnozzle design is flawed to me.

If you’ve switched filament types and experience trouble extruding you may want to use the filament to draw out any of the remaining previously used filament. Bring the hot end up to ~80% -90% of the new filament extrusion temp and with the hinged idler on the extruder open and free push down on the filament into the hot end, then remove. Cut off the first cm and repeat the process. You can use the semi-molten filament to grab onto any plastic material left in the melting chamber, it can also remove foreign objects as well.

I am mentoring a FIRST Robotics highschool team. They recently bought a AO-101 and have it fully assembled but no prints yet. The problem appears to be the nozzle being plugged. The 3mm ABS natural color filament is not able to push in to the hot section, no filament extrudes out the bottom, and the knurled bolt also eats out a low spot and then just spins.

I tried taking the nozzle off when cold to see if I could clean out the plug of ABS, but I was completely unable to loosen the nozzle. It appears that the nozzle is bounded to the PEET insulator and no longer unthreads from it. I finally pulled the bolts hold the hot zone assembly, remove the PTFE(?) tube, copper bell shaped section and had the wide, flat top of the insulator exposed, working very carefully to avoid damaging the now dangling heater wires. Even with vice grips on the outer endge of the insulator and a wrench on the nozzle, I was not able to get any rotation between them to un-screw the nozzle. By the way, the book says to turn counter-cockwise to remove the nozzle. Since the nozzle is pointing downward (unless you have pulled the entire extruder mechanism out) that would mean a left hand thread is being used for the nozzle. Is this correct? Otherwise the change nozzle instructions really should say 'if extruder still mounted and/or nozzle still pointing downward, turn clockwise to loosen. If the whole assembly is detached and the nozzle pointing upward, turn counter-clockwise.

We still have a nozzle that can’t be removed and a jammed hot section. Are there suggestions on how clean the nozzle without removing it? The cost of a whole new heater section is a bit steep to purchase a replacement for just a clogged nozzle. And what can be done to unscrew the nozzle without destroying the insulator?

I am also wondering if the heater block is not heating up the nozzle. I noticed that there is only a tiny set screw to press one side of the nozzle against the aluminum heater block. In other designs I have seen, the heater block is split on the side opposite the heater resistor and temperature probe, and a bolt used to clamp it firmly onto the nozzle. That makes the heater intimately connected thermally to the nozzle, so both will always be at the same temperature. I fear that right now (I am not near the printer right now) the set screw pressing the nozzle against the heater block is only finger tight. Also, the users guide section on swapping nozzles probably out to mention opening that set screw before unscrewing the old nozzle, and tightening it up after screwing the new one in place.


Acetone will eat ABS nicely. Dismount the hot end and dunk the tip of it in a cup of acetone and use a small probe in the tip to try and dislodge the obstructions.

At the same time, with the hot end dismounted, try running filliament through your extruder and verify that the hobbed bolt is able to push filliament through the hole in the bottom of the extruder. It is possible to print one with an obstruction at that point which would also cause the issue you are seeing.

Once you think it is clean give it overnight for the acetone vapors to dissipate, mount it in a fixture so it won’t touch anything that is burnable, power it up and heat it to 230 degrees C and try manually feeding some filliament down the bore. If fillaiment comes out the bottom, you are done. if it is still blocked you’ll need to take the nozzle off the hot end.

Removing the old style Hotend 1.0 nozzles that the A0-101 might have shipped with is a job you should attempt only as a last resort. Chances are even after soaking it will strip the threads. They should be a standard thread pattern. at least loosening the nozzle while the unit is hot (being very careful not to burn yourself from heat transfer) can be easier than trying to remove it cold. You can also try heating it up and then sticking a needle up the bottom to try and dislodge a blockage back up the pipe with it still dismounted.

Also make sure you print all the upgrades for the AO-10x series when you get it working. that will dramatically improve the accuracy!


thanks for the advice. We have a bottle of acetone right there, I assume it came as part of the package. I knew that acetone would soften ABS but I did not realize it would dissolve and wash away the stuff stuck in the nozzle. By dismount the hot end, I assume you mean removing the 3 crews and the triangular plate under the printed extruder plate? And then unplug the heater and thermistor wires from the control box? I did that last weekend to try and get at the blockage, accept that I had not disconnect the wiring. Had to work very carefully to not stress the wires. There was a short section of filament just filling the hot end from when someone else tried to clear the jam. The new filament hit the old and got stuck. The knurled bolt seems to drive fine until the filament runs into the blockage, but there is no way to tell at this point if it is strong enough to push through the hot and and extrude. I will test that again when the nozzle is cleared.

I was able to break a wire off of a wire brush and push that through the nozzle opening. I was hoping that I could push the plug of hardened plastic out, but of course that didn’t work. Hopefully the acetone will remove the plug and I can use the wire again to clear the orifice.

The trouble with this jam makes me wish I had one of my experimental glass nozzles mount up instead. I think there will be much less likely to jam, and easier to pull the plug out of, but I haven’t mounted one in a 3D printer and racked up hours testing it yet. But I hope that eventually they will make home 3D printers more reliable.


I was more just talking removing the entire hotend assembly from the extruder assembly via the two bolts. The only way you get a blockage in the metal extruder is if something either metalic or non meltable made its way into the hot end. The only time i’ve ever even seen a report of one that jammed up to the point is when someone was using cheap filliament that ended up having ball bearing fragments from the filliament machine in the filliament, which blocked the nozzle. If you get the nozzle up to 230 degrees C, whatever plastic is in it except the PET tube is going to melt eventually. If you have it up to temperature for a good 20 minutes or so and it still isn’t letting anything come out, chances are you have a foreign obstruction inside the nozzle itself, and the only way thats coming out is to remove the nozzle while the unit is heated to at least 160 degres C, using a good wrench and a backing wrench on the heater block.

If you’ve tried everything else, it may be time to just try brute force and risk the threads. at least then you’ll know.

If anyone is going to be cleaning their nozzle in the near future, could you take some pics of the process? Mine has been working without any problems, but I know eventually I need to clean it, and I’m a visual person.

Does anyone know a good supplier where I could get a couple cheap nozzles? As a backup. I have only been printing for about a week and already got a clog :blush: . I am getting frustrated loosing several days of printing letting the nozzle soak and after printing with a 0.35 nozzle the 0.5 just doesn’t cut it.

I tried the plug idea to clear the clog 3 time to no avail. It just gets all stretchy and I don’t have the heart to take the blow torch to it.

:bulb: Has anyone ever tried heating there oven up to like 450-500 with the nozzle inverted to try and clear the clog?


For what it’s worth, internally, I don’t think we’ve ever taken nozzles apart and had to soak them in acetone. So something else is going on there. It shouldn’t be needed at all in the course of normal usage. I’m pinging orias to take a look at this thread to help you through it. Thanks.

It’s excedingly rare for nozzles to clog as long as you are using good quality filament. Extrusion issues are typically caused by impropper tension on the extruder idler, or by a misaligned filament path between the extruder and the hot end, or if using PLA, heat creep when printing without active cooling, printing too slowly or by leaving the hot end at extrusion temperatures when idle.

With all the parts and printers we have printed and used, we’ve never encountered clogging in the fleet. What are you encountering?

To clarify a bit: we’ve had printers jam (e.g. stripped filament) and the like, but even doing 100s of thousands of parts, we don’t have a bunch of nozzles sitting around in acetone getting “unclogged”. I can’t think of a single time. I don’t think we’ve ever taken a blowtorch to one either. So if you are repeatedly seeing a condition where you need to do that, something else is wrong. It isn’t normal, even after extended usage.


Well I have only had one clog but I have had the printer less than month. I got the filament from Makergeeks (per an IRC recommendation). I soaked it in acetone over night and then it was easy to free it with the pick and the brush.

Maybe I will try your guys filament next time.

To be honest the blow torch just sound like a recipe for disaster.

Bad filament can definitely wreak havoc.

I won’t blame the filament quite yet, most likely the result of incompetence and operator error on my part.

I had clogging issues which were resolved by submerging the nozzle in acetone, that still left some residual gunk inside, I don’t remember how I removed it, possibly with the “precision probe” (sharp needle-like tool provided in the tool bag).

Upon recommendation from someone on the #alephobjects IRC channel when I got my AO-100 last year, I do not set bed and hot end temperatures in Slic3r. I set them manually in Pronterface. I used to start heating up the bed and the hot end both at the same time. It’s a mistake. The bed takes a lot more time to reach its temperature than the hot end (that old Mk.1 PCB is not quick to heat!). The result is that the hot end was kept idle at 230ºC for 10 to 15 minutes before each print.

Since then I heat up my bed first. When it reaches 85-90ºC, I heat up the hot end. By the time the hot end has reached 230ºC I can start the print. Obviously those values are for ABS. I haven’t printed PLA so far.

I haven’t had clogging problems since.

That’s good advice and I will start doing that. Someone else probably thought of this already, but I generally turn my heated bed on manually and put a washcloth on the heated bed to act as a little blanket while it warms up. Then when it hits temp I take it off and start the g-code. Seems to heat up faster.

In slic3r don’t set bed and nozzle temps, do them manually. If you use Kisslicer, then set your bed temp and let it work up for a while, then you can start up the print. I normally warm the bed to 80c-90c before turning on the heater for the nozzle. Normally use 110c for bed and 220c-230c for ABS. If using PLA on glass then about 50c-60c for bed. If printing PLA on painters tape or other material I don’t use heat.

If you do have temps set in Slic3r it is ok, but make sure you warm the bed up, then the nozzle before starting the actual job. You will find the right temp to turn on the nozzle heat after a few cold runs. Some beds take longer to warm up then others based on a number of factors.

I have had one clog before and I just used the soaking in acetone method to clean it out (I normally only use ABS).

Just wanted to share my experience and how I was able to remove a clog. I am not sure what caused it, but suddenly only very tiny amounts of ABS were being extruded from the nozzle. So it wasn’t completely clogged, but definitely not right. After a few minutes, I pulled out the filament and sure enough the hobbed bolt had chewed into the filament since it wasn’t moving forward. After loosening the idler baring thing that you would open as if putting in new filament, I pressed pretty darned firmly on the filament to attempt and extrude some “by hand”, and it still only extruded a tiny amount.

So I came and read this thread, lamenting that I was going to have to disassemble the hot end, I had an idea. I still had the filament in the hot end, and I had been pressing quite hard on it, so I decided to turn off the hot end and let it cool completely. My thought was to try and pull it out of the hot end once cool, hoping the melted end had stuck to whatever was clogging it. Well, even after more force than I’d like to admit, it was clear the filament wasn’t coming out of the cooled down hot end. So at that point, I started tugging up fairly firmly, and then started to preheat the hot end as if to print. While maintaining upward pressure on the filament, the temperature reached to around 150C, and POP up came the filament! The filament I had been trying to manually force through was green, and the filament that was in when the jam happened was blue, so after the green filament popped up, I was surprised to see about 2" of it was blue. There were little rings and dents in it too that were strange. I can’t say I clearly saw what was causing the blockage, but after letting the hot end get up to full temp, I cut away the blue tip on the green filament, and reloaded it. Manual extruding now looked clean, so I locked it in place, and then used the LCD to extrude about 20mm, and low and behold it extruded back to normal!

Nozzle unclogged! YMMV.

Ya, that sounds like the “heat it to 150C - 180C, put filament in there to stick to what is clogging it, and hopefully pull the whole thing out” fix. That is a quick way to solve it, for instance if some debris got in the hot end.