Octoprint Timeout

Howdy folks. I’m a new Taz 6 owner and have Octoprint setup on a Raspberry Pi 3. It’s been pretty great when it works. I’m mostly kicking off prints while near the printer (though I have kicked some off remotely and it’s worked most of the time).

However, sometimes I get stuck in a situation where everything times out. It usually seems to start during the auto-leveling process, so maybe that’s taking longer than Octoprint would like. When it happens, I’ll reboot both the Raspberry Pi and the printer. Sometimes this fixes it, but sometimes I’ll be stuck for a while and just have to leave things sitting for a while until it inexplicably resolves itself. Even setting heatbed or hotend temperature won’t work. I’ve played some with changing timeouts, but that hasn’t seemed to help.

Has anyone else dealt with this? If so, do you have any recommended settings for the timeout values or maybe something else that I’ve missed?


If you have an SD Card installed, try removing that.

Sorry, I didn’t get a notification that there was a response, but thanks a ton for the suggestion! It’s actually been fairly stable this week, but I went ahead and removed the SD card anyway, since I’m not using it.