Pronterface fan turns off

I added a button in pronterface to turn the fan on and for different speeds, ie. M106 s190. This will turn the fan on for a short period then after completing a layer it kicks back off. Is there anyway to set it so that the fan consistently stay one when the M106 S… code is entered?

Your fan is being turned off by gcode probably, due to your cooling settings. Are you using Cura or Slic3r and what profile are you using?

I am using slic3r. I usually have the cooling setting set in slic3r but I guess I forgot somehow on this print I was running and didn’t realize until a little while into the print so was hoping to override what settings where in the gcode. I guess that is not possible though?

You can watch the print, and turn the fan back on if you notice it off if the print is still running. Otherwise, once the print has finished, search the gcode file for the M107 command and delete it out of your gocode if you want the fan always on with that particular gcode file.