Taz 6 stops extruding on retraction

I’ve got a Taz 6 that’s probably about 8 years old with a slightly newer tool head using Cura Lulzbot Edition 3.6.3. Lately, when I print with retraction enabled, the filament will often stop extruding partway though the print. Sometimes it starts extruding again several layers later making a big mess. The problem seems to go away when I print with the retraction disabled, but that leads to messy prints and ignores that possibility that this is symptomatic of another issue. There are some other posts on the forums about this issue, but they don’t have detailed enough solutions for me to follow. Can anyone give me specific instruction on how to fix this, or is this part of a larger problem?


What toolhead are you using? What material?

Jamming partway through a print is usually caused by a combination of factors. One of those factors alone may not be enough for a jam, but a few of them together can do it.

Heatcreep: Going too slow (softened filament isn’t pushed soon enough), too many retractions (heat pulled by the filament upward), too hot (more heat transferred to the heatbreak), too cold (more resistance for the filament to push through)

Clogged teeth: A vicious cycle, where anything in the teeth reduces pushing force and reduces contact points, increasing chances of more stirpping of filament, clogging more teeth.

Clogged nozzle: Increases backpressure on the filament, leading to stripped filament from the gears and increasing chances of heatcreep causing a jam.

Z offset too low: Increases backpressure on the filament, leading to stripped filament from the gears and increasing chances of heatcreep causing a jam.

Flow rate too fast: Increases backpressure on the filament, leading to stripped filament from the gears and increasing chances of heatcreep causing a jam.

So… it’s a lot of potential causes that you need to work through.

1 Like

Thank you for the reply, I should have stated originally that I am using a 2.85 mm PLA printing at 195 C with a SE 0.5 mm Tool Head. I’m using 3DXTech ecomax natural PLA. The recommended print temp is 190-220. This is not the original tool head because that one get wrecked somehow. This printer is at my work and was not purchased by me, though I am now the only one using it.

I have tried a variety of temperatures and print speeds with no luck. It’s currently set at a print speed of 60 mm/s and then 30 mm/s on the walls and 40 mm/s on the infill. That’s the bottom end of what I’ve tested. Along with print speed, I’ve tried a range of layer heights from 0.1 to 0.43 mm but that doesn’t seem have any effect on the success or failure of a print. I’ve not done this in a systematic style, but rather scattershot attempts to get it to work.

I’m not sure how to check the Z offset. It does an automatic bed levelling before each print. Does that not take the Z offset into account?


I’d recommend updating to Cura 4.13 and flashing the latest universal firmware for the Taz 6. Be sure to record your Z offset before updating the firmware, as it will be reset to default values after flashing. Then restore your Z offset when the flash is complete.

Do some test prints with their default PLA profile for a Taz with the SE 0.5 toolhead and see how those come out.

The bed leveling doesn’t do anything about Z offset. The Z offset should equal the difference in heights between the level of the top of the washers and the top of the bed. With the glass and PEI bed, it is typically around -1.25 to -1.3 on the Taz 6. Octograb bed puts it at about +0.3.

If your first layer is fine, you shouldn’t have to change it, but if you get jams frequently in the first 1-3 layers, it’s worth checking.

That’s really good advice, upgrading the firmware seemed to resolve a lot of odd jams my rehabbed Taz 6 was having. I haven’t explored many of their other material profiles and have found cloning the Generic one and making new profiles works best. I bounce around between Ultimaker 2.85mm, Colorfabb (which seems identical in manufacture but I can’t get either party to endorse that!) and Polymaker materials.

Thank you both,

I messed around with the Z-offset, but the initial setting was the best (-1.20 mm).

They keep computers on lockdown around here, but I will see what I can do about updating the Cura and firmware.

I installed the most recent version of Cura LE and updated the firmware, but I’m still getting the same results. It typically stops printing in after probably 10 layers or so.

With the new Cura, it also tells me the tool head that’s on the machine is not the tool head I’m using. I don’t know how to find out what tool head Cura thinks I’m using.

Can you screenshot the error you’re getting? the toolhead doesn’t talk to the printer - it’s all one-way communication, and the selection of your toolhead from the toolhead menu only changes a few settings, none of which identify the toolhead in use. So if there’s an error from CuraLE, it’s based on the actual firmware loaded. and what toolhead is on the machine vs. what you selected from the “add a printer” dialog?

What firmware version does your printer report on the About screen?

1 Like

Here is a photograph of the screen.

I’m using a SE 0.5 mm Nickel Plated Copper. (P/N: KT-CP0136). The Firmware is and the Cura is version 4.13.8.

Here is what a failed print looks like if it’s any help:

1 Like

Not sure why you’re getting that error, maybe you selected the standard extruder (which also has a .5mm nozzle) when you set up the printer?

But as for the other picture - that Z offset looks extremely low. I can see where it’s scraping the bed instead of extruding the skirt. This is going to cause jams and stripped filament.

Going of that picture, you have a Z offset of about -1.5, and it’s typically around -1.25 to -1.3. If your Z offset is actually around -1.25 to -1.3, then your nozzle is not completely clean, so it’s giving a false reading of the bed lower than it really is.

I’d like to chime in and inquire if the material is dry too.

Hi Nor,
Are you sure it is PLA and not PetG? All the comments are spot on. Make sure your retraction is below 1mm, preferably 0.5mm unless you really think you need more.

I’ve never seen PLA that clear before, it’s definitely PETG. Well, technically I have - Atomic Filament has PLA that clear and non-yellowed, but they do something to it and won’t divulge their secrets.

The way light is passing through it is exactly like PETG.

UPDATE: Well, after looking at 3dxtech’s website - their PLA is pretty clear and white. So who knows.

It is 3dXTech EcoMax Natural PLA filament. I purchased it a few months ago. They were selling it on sale and they no longer produce this particular filament, so maybe I may be underestimating its age.

Wrathernaut, You are correct that the Z-offset certainly doesn’t look right in the photo. It was definitely set to -1.2 I tested it up to -0.8 and it look better on the first layer print, but I still get the same problem. I don’t know if that is a result of the instrument and the software disagreeing on what toolhead I am using. I created a new printer in Cura and made sure it was the nickel plated copper nozzle.

The retraction was set to 1.75 mm. I just changed it to 0.5 mm. We’ll see if that helps. Before I updated the software and drivers the only ay I could get a print to finish was to disable retraction, but that of course is not ideal.

Thank you all for your help!

If that’s -1.2mm offset, your nozzle is dirty. I can almost feel your bed being pushed down by the nozzle during measurements from here.

I took the filament out to clean the nozzle and forgot to put it back in before I started the print again. With the filament out, I could clearly see that the bed was not level. It looks like it’s off by over 2 millimeters front to back. I was testing the Z-offset with a very small test print in the same area so it was only calibrated for that one spot.

Unless anyone has any better suggestions, I’m going to follow the instructions here: Method to prevent nozzle from digging into print bed

I’m on travel next week though so I probably won’t get to it until the week after. I will update then.

Thanks all!

The method does from your linked guide ignores bed leveling completely and manually set the spot you have the nozzle at as Z0.

The mini can somewhat get away with it, since the bed is tiny. You’re going to have some change in height with a 300mm bed.

Cleaned up (disabled commands removed), this is the startup gcode (with comments from me):

;This Gcode has been generated specifically for the LulzBot Mini
;Basic settings: Layer height: {layer_height} Walls: {wall_thickness} Fill: {fill_density}
;Filament Diameter: {filament_diameter}
;Nozzle Size: {nozzle_size}
G21 ; metric values
G90 ; absolute positioning
M82 ; set extruder to absolute mode
M107 ; start with the fan off
M140 S{print_bed_temperature}; get bed heating up

First block sets the basic startup conditions for the printer, and expects you to have put the nozzle at Z0.

Second block here lifts the nozzle, homes the X and Y and heats the nozzle and bed. X0Y0 isn’t over the disc anyway.

G1 Z5 ; raise z
G28 X0 Y0 ; home x and y
M204 S2000 ; Restore standard acceleration
M109 S{print_temperature} ; set extruder temp and wait
G4 S15 ; wait for bed to temp up
M140 S{print_bed_temperature}; get bed temping up during first layer
G1 X5 Y5 Z0 ; LOWER Z BACK DOWN TO Z0, but stay over at 5,5 XY so you don’t hit the corner disc

This method ignores any bed leveling completely. The Taz 6 can’t be mechanically leveled. This method is bad. If you do have a 2mm height difference front to back on your printer, you will grind your nozzle into the bed. Severely… or you will be floating so far over the bed on the other end that you will be printing spaghetti.

I think I copied the wrong link. This is the one I was considering trying: SOLVED: Taz 6 auto leveling is >0.5mm off (NOW PERFECT TO 0.01mm!) - #45 by b-morgan. However, Wrathernaut, you commented on that article with some good points about the leveling process. I think the problem is ultimately that it is not bed levelling reliably. I ran the bed levelling 10 times in a row and the standard deviation of the points between measurements was ~0.6 mm! It was really pushing the bed down a lot on the levelling rather than just barely touching it. I cleaned off the nozzle and the washers really well and then tried again with no filament in and the standard deviation went down to <0.004 mm. I have been able to print several things, large an small successfully, however, I need to keep an eye on the bed leveling process. It doesn’t always work and it tends to work better when I take the filament out and clean the nozzle manually with an extra nozzle cleaning strip right before it goes into the procedure as it seems that some filament leaks out of the nozzle after the machine nozzle wipe. This is functional, but not ideal. Does the nozzle need to be really cleaned (ie removed and sonicated in alcohol) or do I need a new nozzle? Alternatively, can I prevent it from bed leveling automatically and manually enter the appropriate leveling values? I suppose before doing that I should do a bed leveling procedure once a day for 10 days and make sure it doesn’t change much daily.

tldr; SOLUTION: My nozzle was dirty, preventing the bed from leveling correctly.

Thank you for all the help!

The sequence to get a Z starting position is to lift Z a safe distance (so it doesn’t hit washers).

Home X/Y so that the Zmin button position can be hit reliably.

Push the button to get (rough) Z zero position.

Lift Z appropriate distance to clear washers.

Start leveling sequence, use the washer position to get fine Z position to set (fine) Z zero position.

So, even if you stored the bed leveling matrix, and restored it, your Z position gets lost whenever the Z steppers sleep and get de-powered, requiring the touching of the washers to get the same Z zero position again.

Or - figure out the exact offset of the Z zero button activation position relative to the bed, and use the M851 command after zeroing Z on the button to correct for the offset. Restore your known good bed leveling matrix and you’d be good. Now, since any plastic on the nozzle would cause a slightly earlier activation of the button, it’s still going to need to be accounted for, but the effect should be less than the electrical connection interference. Any shifting of the bed relative to the nozzle is going to throw your matrix out of whack too.