TAZ dual extruder mod files

I have thought about using a bowden type extruder for the secondary extruder option (extruder mounted to frame, tube going to hot-end). This would be the lightest option. but might limit the type of material for the secondary extruder.

I’m actually doing just that 1013, just need to decide on a lightweight 1.75mm hotend before I move forward with it. I have all the printed parts and hardware to build http://www.thingiverse.com/thing:126778 sitting on my desk.

For the mounting of the head I’m thinking of mashing up this http://www.thingiverse.com/thing:116880 with the budaplate on my Budaschnozzle 1.3 http://www.thingiverse.com/download:56481

BTW, I have not had any problems due to the weight of standard extruders.

I just got my dual extruder setup this past weekend! It’s definitely a tight fit with the lulzbot development version, but works well so far. I think I need to loosen the rear extruder and align the hotend though, because it’s a bit too hard to extrude through it now :confused:
Other than a few potential issues I have with slic3r, all looks well. Calibration isn’t too bad either. Wish pronterface handled multiple extruders differently, but that can be changed.

ok parts should be here tomo so i can start my upgrade. i use octopi as printserver, what will be my changes on that end of it and will running different nozzle diameters be good or bad?

I haven’t used octopi yet, but the changes to slic3r were easy enough. Just make sure that you set up each extruder properly.
You will have to make sure that your layer height is set to a maximum of 80% of your smallest nozzle :exclamation:

I’m not sure if it is fixed yet, but even if you set everything to be extruded by extruder 2, the first skirt loop is still printed by extruder one in slic3r.

ok cool, thanks, i will factor that into my design then. didnt know that…

OctoPrint (which is the actual software you’re running if you’re using the OctoPi distribution) doesn’t support multiple extruders just yet. So you won’t need to change anything there per se, but you also won’t be able to control the temperature for the second extruder (or issue extrude/retract commands).

The OctoPrint support for multiple extruders is coming based on a recent post on G+, but it’s not going to be ready just yet.
https://plus.google.com/110130855001142142895/posts/28Yi58kF2Eq

I don’t have a dual extruder setup on my TAZ yet so I can’t speak from personal experience, but just keep in mind you’ll need to have Slic3r control your extrusion temps (as opposed to setting the temps to 0 in Slic3r and manually setting the temps in OctoPrint). Otherwise, there shouldn’t be any reason OctoPrint won’t work for you since it’ll just pass along whatever Gcode you send it.

Good luck with the upgrade if you give it a try. I’ll be curious to see how it goes if you do try a dual extruder TAZ with OctoPrint.

  • Adam

I should have known that to dangit lol, yeah, shouldnt really change anything besides my slicing and figure out which nozzle i want as primary. Buddy has a Replicator 2x and he has issues with the 1st extruder sucking up filament from the second. is that a extrude/retract problem also?

I am having problems with the second extruder working with Pronterface. If I select tool 1 and try and extrude the “Y” motor turns on and hums. I have validated the wiring and the motors and there is no issue there. I used the S/W from http://devel.lulzbot.com/TAZ/accessories/dual_extruder/dual_extruder-1.0/software/ and had no issues compiling. Am I missing something? - Thanks

Wow, that is strange. How are you selecting tool 1? I usually add custom buttons; T0 = Extruder 1 and T1 = Extruder 2. If that’s how you’re doing it it might be an eeprom error. You might try restoring default settings (control --> restore failsafe on the LCD screen)

Hope that helps
-bam

Thanks you for our fast response. What I did was enable 2 extruders in Pronterface. Then I selected Tool 1 and pressed the extrude button. How do you set up custom buttons?

Thanks Again.

Hmm, it may be using a command that isn’t set up in marlin. There should be a small box with a [+] in it on the bottom of the pronterface interface, if you don’t see it you may be in the compact view. You can switch to standard using settings–>options–>user interface.

Clicking on it will allow you to add a custom button that will send gcode to the printer every time you click it, I find it really useful for turning on fans and extruders.

It’ll ask you for
*button title - call it anything that makes sense to you, it’ll be labeled on the screen (I named mine frontey and backey :sunglasses: )
*command - the line of g-code that you want to send, T0 for extruder1 T1 for extruder 2
*color - here you can just type in the name of a color, dark red, light grey, etc

Let me know if that doesn’t solve things for you

Cheers
-bam

Thank you Bam. Your suggestions worked. I can’t use the extrude button in pronterface, but I can manually extrude. I haven’t tried to print anything yet, it appears to be working.

Mark