The Ciclop has landed! Unboxing begins.

Fedex delivered a surprisingly large box today with my Ciclop in it! The box is quite nice. I opened it up to find:

Nicely packed inside too. But wait, what’s that…

I hope there are lots of drawings and photos because the only languages (other than English) that I know are C, C++, C#, Objective C, Pascal, Fortran 77, Java, Javascript, HTML, Python, PHP and a bunch of others. I think this is Spanish?
Ah, no need to fear, the instructions come in 7 languages, each booklet nicely illustrated. This is some of the nicest kit I’ve seen!

And, each of the boxes is also nicely packed:

This scanner is a lot larger than I thought it would be. Here are some of the printed parts:

Ok, back to work. And then I get to assemble!

Thanks Lulzbot!

So you can get a sense of scale:

Well, that was incredibly easy! This is one of the nicest kits I’ve seen in 20 years. The printed parts are perfect, everything fit with no trimming. The instructions are nicely illustrated with very few words. I started assembly at 4:30pm and it is 5:06pm now. Less than 30 minutes and that included taking photos.

Here’s the completed mechanical assembly (and stepper motor). The teaspoon is so you can get a sense of scale. I really thought this scanner was about 1/2 the size it is! This is going to be a nice addition to my work.

What’s better than sharks with fricken laser beams attached to their heads?^1

TWO lasers for a 3D scanner, that’s what!

  1. Dr. Evil in Austin Powers

The electronics went together easily. The design of the plastic parts is very well done with built in wire management. It took about 30 minutes to assemble the electronics and the scanner is done! Here it is on top of my paper scanner/printer:

I’ve now installed the Horus software on my iMac. Virtually no configuration. The only minor things to watch out for in the Preferences:

I have a built in video on the iMac. It appears as camera 0, the Ciclop camera is 1 and needed to be selected.

I have a printer with an Azteeg X3 Pro controller hooked to this iMac so I needed to select the correct serial name. Baud rate is 115200 (default). I did not burn new firmware, I’d like to try it out a bit before going down that path.

During the Calibration I did have to invert my stepper direction. The platform needs to rotate counterclockwise when viewed from above.

Ok, running through the setup wizard the first time it asks if I’d like to calibrate the lasers. The manual says that close is good enough. However, I didn’t understand what “calibrate” meant! It means the laser scan should be vertical. I skipped this without knowing why it is important. Long story short, you can resist laser calibration in the calibration workbench - which I did. Here’s what the left laser looked like, the right one was even worse:

Calibration is done by loosening the screw that fixes the laser and simply rotating the laser until the scan is vertical. I used the checkered calibration screen to make this easy. Took all of 1 minute to do both and now they are vertical as they should be:

Now that the Ciclop is assembled, the fun/learning begins. Slowly I’ve put bits and pieces of information together. I still have some problems I’ll describe below but wanted to capture what I’ve learned that might help others.

  1. Setting up Horus software was very easy. I use a Mac/OSX. I did have to choose “camera 1” as my Mac has a built in camera that Horus recognized.
  2. I have a 3d printer with an Azteeg X3 Pro card so I had to make sure to select the correct Serial connection. Baud rate is 115200 for the supplied board and firmware.
  3. When you first run Horus it asks if you want to calibrate your lasers - YES! you do. I skipped this since I didn’t know what it meant. The laser scans must both be vertical. You correct that by loosening the cap screw on the side of the laser mounts so you can rotate the laser and then fix it in place. I put the target screen on the platform so it was easy to get the lasers parallel to the checkerboard. If you skip this, you can align the lasers manually from the calibration workbench. Click Laser settings then click the Left or Right button to turn that laser on to adjust it.
  4. The background behind the scanned object is very important as I found out. My printer is behind and I had all sorts of issues. A simple sheet of white paper made things much better.
  5. Lighting is very important. I have an overhead light. It is too intense and causes glare. A nice even flat light would be better. I am going to make a box with an inverted light table on the top to light the object.

Now on to my issue. If I scan using both lasers I end up with a point cloud of 2 objects offset from each other by about 1 mm. I don’t know how to fix this. My laser scan lines are about 6mm apart at the center of the platform (I placed the target screen on the center and turned the lasers on as described in 3 above). Each is about 3mm from the center line. My laser triangulation calibration seemed to give good results. I’ve attached it here for comments.

And my platform extrinsics also seemed reasonable although I don;t know what the dots are around the back. Here’s it:

Here’s my setup and what I’m scanning. Notice that there are 2 shells in the point cloud - that’s the issue. Also, the back half of the object is not scanned. If I scan with just the right laser, I get a complete scan. If I scan with just the left laser, I get a similar hole.

You’re getting similar results to what I am able to generate so far. I need to work on this more this weekend. Going with a higher resolution web camera seems to have helped some.

I posted on the Ciclop google group. Another gent there has a similar but larger issue. Is that you? Seems to maybe be a common problem that needs some good 'splanin!

BTW, my machine makes an odd plasticy sounding CLICK during some portion of the platter rotation. If I rotate the platter by hand it is as smooth as silk with that big bearing but under stepper control I get these clicks. Do you?

I did another round of calibration and did the camera intrinsics first this time. I am getting much better results. I don’t think I see a ghost now, just one object.

It looks like you have some gaps that you can clean up with the camera settings. Try exposure/saturation or even gain (if you can change it) to get Horus to pick up the laser on darker colors.

Thanks, I’ve been traveling for business for a few days so just getting back into it.

I do believe my environment is not optimal. I have a daylight florescent lamp about 8" above illuminating. It may not be bright enough or cover a wide enough area. I am now using a white paper backdrop and that has helped a lot. I think a box with an open front lined in white might be ideal for lighting so I am going to try to rig something up this week.