X-axis shifting with large prints

Hi everyone, I’m trying to print a larger item that is basically has a flat bottom with walls, and the walls are severely shifted. I’ve tried tightening my belts, but it doesn’t help. Smaller items, such as the octopus test print, are fine, it’s only larger items that have this issue. Does anyone have any suggestions?

Here is a picture of the whole object printed with the shift:

It has been getting worse, here is the latest print, stopped early because of how bad it was:

I’ve also attached the gcode file I used (I can attach the STL if anyone would like to see it, but I figured the gcode file would have more info about the settings I’m using).

Thank you!
cgr_hollow_fwall1.gcode (1.37 MB)

You aren’t getting any lifting that I can see. I’d try tightening the set screws on the pulley for the X axis if it isn’t the belt. Do you have a belt tensioner on the X axis, or are you tightening it manually by loosening the belt and pulling on it with your hands?

for some reason it is loosing steps. in X. try to slide the x axis by hand left and right while the motor is active. (just do a manual move in x and the motor should stay active for a few minute). you will be fighting the motor that is trying to hold the X carriage in place, but if you can move the carriage by hand, you might be able to see what is slipping.

I have been tightening it manually by loosening the belt and pulling on it with my hands, though I have to admit, I usually need another person to help, I am usually unable to do it myself.

The belt seems to move when I manually move the carriage back and forth. Here is the belt’s position when the carriage is on the opposite side:

It seems to hang right off the edge, but never comes completely off. Here is the belt when the carriage is on the same side:

Does it sound like this could be the problem? Also, the tensioner part doesn’t look right to me, but I don’t know what it should look like. Here is a picture of mine:

Things don’t seem to line up quite right, but I don’t see how they would, because in order for the top part of the belt to be exactly on top of the bottom, the belt would have to be shoved all the way to the back of the black plastic part, but it can’t really do that because there are other screws there. Can anyone show me a picture of what that should look (or even just a good description) so I can make sure that at least is correct?

Check this for sure. The motor pulley has a set screw and that has been known to come loose sometimes.

Can someone point me to a picture of where the set screw(s) is/are for the motor pulley? I can’t seem to get anything to work so I just want to make sure I’m even looking at the right parts.

Thank you!

opposite end of the machine to the first two pictures you posted above. there is a small flat on the motor shaft. the set-crew in the drive pulley should be pushing on this flat. make sure it is tight. should be a small set screw. 1mm or so allen wrench.

Looking at the pictures, your belt is definitly too far over on the bearings. It should be centered right in the middle of them ideally. Something is way out of allignment though. The pully on the shaft is probably loose and has worked towards the edge of the Nema 17 motor. you’ll need to slide it back closer to allignment and then tighten it down. Also check the motor mount screws for anything that is loose. It could also theoretically be cracks in the motor or idler mounts or a loose idler bolt, but the idler bolt side looks fine and the bolt tight from what I can see.

If you can, upload a picture of the motor side.

Also try this as a belt tensioner: http://www.thingiverse.com/thing:87023

There might be a better TAZ one out there, but that one will work. You’ll also want to adjust where the belt is clamped down to make sure it is in line as much as possible with the idler bearings centerline.

edit: the belt pulley in the picture at this link should be similar. if so, the set screw is going to be located at the base, and is that black dot visible in the picture. Often there will be more than one set screw: http://www.lulzbot.com/?q=products/gt2-16-teeth-timing-pulley

Thanks piercet, here are some pictures:

  1. The original motor side:

  2. I then loosened the set screws and moved the flat part all the way close to the motor, but the belt still moved around on the other side, so I moved the flat part to various different locations on the shaft until the top and bottom part of the belt seemed as lined up as they’d be. After every small move, however, I tried moving the extruder back and forth, but the belt still moved and hung over the end. Here is how the motor side ended up, with the belt a little better aligned, though this didn’t fix it:

  1. One thing I noticed is that the bottom part of the belt seems to move quite a bit vertically as the extruder moves back and forth. This first picture is what it looks like when it’s on the opposite side from the motor. As you can see, the belt is so low that it’s hitting the black plastic piece underneath and forcing the belt into a slight angle downward:

This next picture is what it looks like when the extruder is in the middle of the x-axis, and as you can see the belt has moved up:

This last picture is what it looks like when it’s all the way on the side close to the motor. It’s moved up so much that it now seems to rub the underside of the tensioner, or at least is extremely close to doing so:

I’ve checked for anything that’s loose anywhere, but I can’t find anything anywhere that seems loose, or in any other way looks out of place. The printer is new, so I haven’t even done much with it yet other than a few small things, since I can’t get it to print this piece that is important to a project I’m working on. Thank you for the belt tensioner link, I will try that out to make tightening the belt easier.

Well, your motor is mounted fine from what I can see. As long as the belt is now centered on the idler and isn’t canted on the motor pulley too much, you should be fine. Close to hitting is ok as long as it isn’t actually hitting. The most important thing is that the belt is square on the idler and the motor pulley and isn’t tending to migrate towards one side with each pass. If it goes towards the edge one way, but returns to center on the opposite direction that should work fine. If it is actually hitting things in that tensioner space, you may need to adjust it some more. I’d try printing with it like that and see how it behaves.

I tried printing again, but the problem doesn’t seem to be any better. I took a picture of the first layer, as you can see at the top, it kept going a little bit past the skirt. As layers get higher, it will keep going farther and farther past the skirt.

You can see I have other issues as well :slight_smile: The z-index height isn’t right at the top, even though I’ve spent hours trying to get it calibrated properly, and it lays down a little extra filament when it changes direction, even though I measured the filament with digital calipers and the setting is correct in slic3r. I will continue to work on those issues, but the major issue is the shifting.

The belt or the drive pulley is loose in the direction of bottom to top of that picture, whichever that axis alligns with. Maybe it isn’t your X axis but the Y axis? It’s definitly the hardware somewhere, and it’s definitly skipping. Try 1013’s suggestion from earlier in the thread if you haven’t already. If you’re careful that should show you where the movement is happening.

Looking at this picture again, you can see the reflection of the X axis bearing rods in the build plate glass. It looks like the shift is occuring in the Y axis direction, perpendicular to the X axis.

It’s working again, thank you! Nothing seemed obviously loose, but I messed with it and it’s working now, must have been the Y axis as you said. I figured it had to be something with the X axis because of how messed up it seemed to be, but I guess not!

You’re welcome! Glad it’s working for you again!