y-belt slipping

I’m trying to do a 2 hour print… and about an hour into it each time, the y belt slips (I can hear it) and then the print head is offset in the y-direction from the already printed part.

How can I fix this?

Is your belt well tensioned?

This might be relevant. https://forum.lulzbot.com/t/y-skip-troubleshooting/217/1

One other possible thing to consider:


I’m going to try reducing the “Speed for non-print moves” from 200 mm/s to 150 mm/s and see if that helps. Attached is an example of how the slipping looks.

The print worked fine by limiting the max travel speed to 150 mm/s. I could probably fine tune it faster but it didn’t seem to slow down the print much so I’ll probably just leave it at 150 mm/s.

Have you tried any of the fixes in the previously linked threads? Make sure your Y axis belt is taut and your Y axis stepper motor pulley is secure and wiggle free. If you pause a print and can move the Y axis you have something loose mechanically. Once you make sure that the Y axis is mechanically sound you will want to use the SLic3r speed limiting gcode line linked above and here: https://forum.lulzbot.com/t/setting-max-z-speed-in-slic3r-is-it-possible/109/1

I don’t have a TAZ so this may not be any help, but I ran into the same type of offset with my AO-100, it ended up being one of the z axis couplers was loose, so the printer was not raising high enough on one side and was actually hitting the side of the part, which caused it to skip on the belt. The belt itself wasn’t the issue, but the coupler where it joined the nema 17 motor to the threaded rod was juuust loose enough that it was managing to work itself loose over a longer print, but apperently managed to settle back to starting position by the time i tried the next print. Took me a while to figure out what was going on. If your belts look fine you might want to start there?

The y-axis belt has the same amout of tension as the x-axis belt… I’m not sure how to quantify this but it feels taut. If the stepper motors are energized I cannot move either axis. To be perfectly honest I’m not sure where to adjust the tension. Is there a picture somewhere showing how to adjust this?

I don’t think it would be a z-axis hitting issue because the problem went away with the slower Slic3r speed.

You can adjust the belt tension by loosening one of the screws on the belt clamp under the Y axis bed and pulling the belt taut. Does the wiring harness to the heated bed appear to potentially get caught against the rear Y axis panel? If so, make sure that the harness moves away from any pinch points while the bed moves towards the rear.

Thanks for the tensioning tip.

The wiring harness is secured so that it doesn’t get stuck.

Ever since I lowered the max non-extrusion travel speed it has been printing great. The slipping problem only happened on bigger parts to begin with.

I was having a similar problem, and just raised the belt pulley on my Y motor…there seemed to be a lot of friction on the y axis and think it might have been emanating from the pulley rubbing against the motor. we’ll see!

Just to close this out and maybe help someone else, I think I found the source of the issue (when it failed entirely).

There is a piece that goes on the shaft of the stepper motor and the belt goes around this piece. The set screw that holds this piece to the stepper motor shaft was loose and last week it backed out enough to where the piece with teeth wasn’t clamping to the stepper motor shaft at all.

Retightening the set screw fixed all the problems.