Y skip troubleshooting

I have been trying to troubleshoot inconsistency with a y axis skip I am getting lately. I am pretty sure it is not hardware related… so I posted under software.

The y skipping is random with the amount of Y distance & at what point in the build it skips.
Here is an image of the latest one:

  • I have recently replaced with a new Lulzbot stepper motor, no change
  • I have marked and watched my pulley and belt. No movement.
  • I have marked and watched my pulley and motor shaft. No movement.
  • I have double checked all connections.

Software troubleshooting:

  • I have created a stl and re-sliced a model several times. Still random Y skipping
  • I have tried kisslicer. Still random Y skipping
  • I have tried completely different stl / gcode models. still random Y skipping.

Here is a link to a google doc of my slic3r ini, gcode, stl.

Thank you for any help and suggestions,

did you try this:


it was meant for the Z skipping, but it will limit the speed of all axis’s to whatever you want and it is an easy G-code command you can try.

How tight is the y axis belt?

Thanks for the link. I will try this out.
On my the the concern is this is happening at my normal speed of 60mm/sec and down to 30 and as high as 90.
I have not run over 150mm/sec on non-print moves.

tigher than my x. I do not know how to measure tightness to give you a reference.
I marked the belt and pulley so I know it is not skipping. So I am sure it is not too loose.

That picture shows some definite missed steps. I doubt it is mechanical, since it always goes one direction.

i would check the wiring going into the board and specifically the connectors. maybe there is a loose wire somewhere…try to pull them out and find it.

I’ve had skipping like that in only one direction before. Tightening the belt helped. Either way, it’s hardware related.

I put the speed limits on the slicer code.
Removed the raft and exported a new gcode.
Started good for a while… then skipped in 2 y directions this time.


I will double check my connections.
I still do not think it is mechanical.
I tried the recommendation to swap the x&Y connections to the board… that did not work.

I tried tightening the belt. I could not get it any tighter.
For tightness reference:

  • Bed moved in y all the way opposite of the stop.
  • place a stepper motor on the belt.
  • belt deflects 4mm
    It is really tight. I fear too tight?

there are really only 3 ways a stepper motor can skip steps.

1- it is commanded to move too quickly. (try the Mcode linked above to limit the max speed WAY slow).
2.- The belt or pulley slips. ( you seem to have that under control)
3.- There is something faulty in the electrical system (you are checking the wiring, but may need to check other electronics)

Thanks 1013,
I am throwing $ at it and replacing the pololu stepper.
Seems to be the cheapest next step.

I assume you are using a board with seperate stepper drives then?

if so, just swap the X and Y drives and see if the problem follows the drive.

I tried this unsuccessfully. I swapped the plugs, but it also reverses the direction movement for each axis. It looks for the stops and tries to throw the bed off the other end of the limits.

You can simply reverse the stepper motor connector orientation to compensate for that when testing. Just flip it 180 degrees.

Done, it heads the right direction. Then hits the stops and keeps trying to go. Duh, I did not swap the stops. So I swapped the x & y stops on the board. It still tries heading into the stops. Awful noise. Put everything back and works fine with finding home and manual movement.

So I try again. swap & flip 180 the x & y motors on the board connections. Swap the x & y stop connectors on the board.
start in the middle of the table. Manually move the y 10mm on software, to move the x carrier. Horrid sound like it is skipping the pulley… but it is not. It is in the middle of the table and moving correct just the motor is making the noise internally. So I manually command a -10mm… the x carrier moves with the same noise, but in the +10 direction. After it stops, the motor makes a soft jittering noise. No movement, just the noise. I hit the main power switch after that.

That noise is it trying to move faster than it can. Use the M code in the link I put up before to slow it down… at least temporarily

I wanted to post an update with the problem resolved.
After reading on Reprap forums. One suggestion was to cool the board if the stepper chips are getting hot.
My stepper chips actually burnt my finger upon touch. Put a small fan on the board. I ave been printing great since the addition.

Thanks for the suggestions and help everyone.
Hope to contribute to this forum more.

My y axis is also skipping steps.

I ran the M203 through the command line, setting y to 200, and then to :

M203 X150 Y150 Z3

and the second skirt loop skipped by about 3mm each time.

So for now I’ve just disabled acceleration in slic3r and set max travel movements to 150mm/s and all other speeds to >120mm/s

I’ve checked my belt tension and that seems fine, I checked that the electronics connections are tight also.

Are most agreeing this is a software / acceleration issue?