A101 - Budaschnozzle - too hard to unscew the nozzle

Hi everyone,
I’m newbie and getstuck while changing the nozzle.

The built-in 0.5mm nozzle was easy to unscew.
Then I put in the 0.25 nozzle, print but the first layer can not stick into the bed (I thought z-calib problem)
Screw off the 0.25 nozzle was easy too.

I then tried screw in the 0.35mm nozzle, I had to put much of force to screw it in.

Now I tried to scew out the 0.35 but it stuck at the middle. I can not scew up or screw down either.
It is too too hard. I’m thinking of using longer wrench to have more force, but it may break the hot end.
I think there is something wrong here.

I’m appreciate if someone can advice… any idea to get out from this stuck?

Thank you a lot.

That is sort of the problem I had with my 1st hot end that came with that machine. It messed up the threads and ruined the hot end. If you are not using the 2.0 nozzle you must use the plumbers tape on the thread or the nozzle will get stuck.

When you change the nozzle you must make sure the nozzle distance from bed is right, a piece of regular paper should slide through without too much force.