Aerostruder Mini Install

Early adopter with some GAMMA testing results.
To this point, and despite my best efforts, I’ve managed to "get lucky with a 10x10mm calibration cube. And that’s after 8-10 hours of digging around tryging to make heads or tails of the bizzarro land behaviors I’ve experience with this new printhead

First, preloaded PLA got stuck while retracting. Even if you let the aerostruder get to 205, (which wasn’t easy), the tensioner needs to be tightened from the shipping state in order for the hob not to just chew it up. But, that wasn’t a big deal.

Walked through the install instructions. It was simple and quick to get installed and plumbed up. Unfortunately that was the last of any real progress made.

updated Cura to 2.6.6 and F/W on Gladiola (S/N 10307) to:
2 [02:44:46] M115
3 [02:44:48] FIRMWARE_NAME:Marlin FIRMWARE_VERSION: EXTRUDER_TYPE:Aerostruder SOURCE_CODE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:LulzBot Mini EXTRUDER_COUNT:1 UUID:351487b6-ca9a-4c1a-8765-d668b1da6585

Towards the end of instructions you get a “Heat the hotend to appropriate printing temp. and then remove the included shipping PLA” Yeah, not so much. First attempt at about 200 degrees, temp started fluctuating wildly, down to 191 and then immediately back to 201 then 201.5 then 186 and then:
Error:Heating failed, system stopped! Heater_ID: 0
Error:Printer halted. kill() called!

Hmmm. So, I took the head off check all the connections. Everything was proper. Not really sure what to think, I tried again with the same results. Uninstalled Cura, reinstalled checked firmware. Notice baudrate wasn’t getting set properly, or, if it was wasn’t being reflected properly in settings:
Baudrate 115200.PNG
There are multiple threads on the Aleph repo’s and in the release notes referencing the change to the a baud 250000. So I set baudrate as referenced in one of the included links, (but not mentioned anywhere in docs other than the release notes where it was made to sound like a default config). Tried again, and same Heating failed message and killed().

So, I turned to google. I found a bunch of interesting stuff, including a couple threads on the Aleph repos that had reports of both of the problems I ran into.

V3 Heating Failed: (This was actually regarding a V3 dual extruder, but was very similar to my experience with the Aerostruder)

Eventually I just went to the IT-Works site and tired “Tune PIDs” on the the following page.
IT-Works Thermistor PID Tuning:

I did that, and got wildly different numbers than those included in the defaults and referenced here:

Mine came out to:
AUTOTUNE Therm. PIDto 235C
< [02:48:29] PID Autotune start

< [02:53:53] bias: 226 d: 28 min: 231.25 max: 235.39 Ku: 17.22 Tu: 42.44
< [02:53:53] Classic PID
< [02:53:53] Kp: 10.33 Ki: 0.49 Kd: 54.80
< [02:53:53] PID Autotune finished! Put the last Kp, Ki and Kd constants from below into Configuration.h
< [02:53:53] #define DEFAULT_Kp 10.33
< [02:53:53] #define DEFAULT_Ki 0.49
< [02:53:53] #define DEFAULT_Kd 54.80
< [02:53:53] ok P15 B3
< [02:53:53] T:234.61 /0.00 B:24.01 /0.00 @:127 B@:0
< [02:53:53] USBPrinterOutputDevice: Resending from: 1
< [02:53:55] T:234.22 /0.00 B:24.26 /0.00 @:0 B@:0

(Here’s a reference to similar observations from Aleph QA from the aleph’s Cura repos,…Interesting that everyone testing the aerostruder is using Legacy Cura 20…
Hot End PID: (I thought this would help me, but it just ping ponged to Thermal Runaway)

I also set fan to 30% and tried again.

Still, got Heating failed errors in Cura. One last try to fan with 15% and attempted print…got to 240C then either Cura or the Mini over-rode the fan 15% setting and blew up to 100%. Printhead dropped to 207 C and:
< [04:28:16] T:207.10 /240.00 B:110.01 /110.00 @:127 B@:114
< [04:28:17] ok N657 P0 B2
< [04:28:17] ok N658 P0 B2
< [04:28:17] ok N659 P0 B2
< [04:28:17] ok T:207.05 /240.00 B:109.98 /110.00 @:127 B@:122
< [04:28:17] ok N661 P0 B2
< [04:28:18] ok N662 P0 B2
< [04:28:18] Error:Thermal Runaway, system stopped! Heater_ID: 0
< [04:28:18] Error:Printer halted. kill() called!

,So,… after the fan kicked the mini from 240 where it was at least trying to print, all the way down to 207,…which is the opposite of Thermal Runaway, killed with a Thermal Runaway. Pretty sure that’s not how any of this works. This is when I quit. Because the Firmware, and Cura are clearly so broken, that trying to figure anything else out is just a waste.

So, I tried with Simplify, there…the heating worked just fine,…until the Mini called Thermal Runaway. It called that while stable at 240C, where it had been for almost 10 minutes with no change. So, I just tried turning the the fan to 10%, and tried printing a 10mm calibration cube. Interestingly, I had to set baudrate in SF3D to 250000 also,…but once it started printing the Mini kicked it down to 115200. Hrnmm, that seems wierd. In the end, the cube printed, but everything is still so weird that I have no idea if that minor success is repeatable.

In summary, I don’t even know. I know early adoption means troubleshooting, but I’m 0 for 2 so far. The modular print bed has been great, but it was a week after it arrived before I could use it. (Check the only other thread I have here.) I’m not sure how anyone could have tested this print head with 2.6.6 and it’s packaged firmware and not seen this behavior.

It seems like there are at least a couple problems. The first is that either the sensor is puking, or the fan in the aerostruder is overpowering the heating element. This is reinforced by dev’s stating that “I don’t have the issue if I turn the max fan down to max of 30%” The crazy fluctuations seem like their most likely related so some comms funk resulting from the baudrate change, or rather, that baud needs 250000 to establish connection, but then pushes that down to 112500 once printing begins…i don’t honestly know, I’m just guessing. The fact that the change isn’t referenced in the instructions or default config doesn’t help. FInally, PID values in the default config are quite a ways away from anything that worked for me. Again, this could be a result of something else, but it’s hard to rule out with all the other problems. I’m going to ping support tomorrow and will update the thread if I get to any real understanding or helpful insight.

I do not have an Aero tool head, but does it have a silicon sock on the heat block to keep the filament fan from cooling it too much? The radial fan pushes more air through compared to the old axial fans.

I don’t think so, but here are a couple pics as I’m not certain I’d recognize one if it was there. They’re not the best pics, but short of disassembling the tool head, were the best angles I could achieve.

I don’t think it’s possible for the baud rate to actually change during operation. It’s hard-coded in configuration.h, so a given firmware build only knows one baud rate. Seeing it reported as something other than 250k in Cura or S3D would make me suspect communication problems. Try a different USB cable? Maybe garbled comms are responsible for some of the problems.

My Aerostruder PID numbers (for 240c) came up as: 22.35, 2.16, 57.70. I haven’t had any heating issues – before or after adding a silicone sock – it’s been very stable, within 1.2c when printing, even with the fan at 80%.

A silicone sock looks like this:

Right on. Yeah the baudrate anomaly sent me down that path, but same issue with not only different cables, but also different pcs. The machine settings page in Cura 2.6.6 with new x.x.70 firmware applied displays baudrate at 115200, and Cura connects without issue. S3D fails to connect with the Mini at baud 115200. If I manually change it in S3D to 250k, it connects without issue. But, when examined during print it’s displayed as 115200… /scratches_head.

Thanks for the pic of the sock, did you just order it from IT-Works?

Your PID, that was with fan at 80%, off, or something else? Also, did you manually set your PIDs for 240 to achieve stable temps, or are you using the defaults hardcoded in the the newest Firmware?

Thanks so much for taking the time to respond, much appreciated.

The setting in Cura 2.6 machine settings page is just what it “tries first”. If it can’t connect at the rate specified, it will try other rates until it gets a connection. So that part sounds “normal”.

Same here, S3D doesn’t appear to have any “automatic” setting – so it has to match the printer’s rate.

Odd – I can’t duplicate that. I set the dropdown to 250k and hit connect, it connects. Close machine control, go back, still 250k. Send a short print, still stayed at 250k. ?? But I’m sure Marlin can’t change, so it is running at 250k – if S3D says otherwise, I’m thinking that’s a bug in S3D. /scratches_head_with_you

Does everything look OK in the console? If there is a baud rate mismatch or cable problem, you will generally see some “junk” (odd unprintable characters, various errors) in the console.

Only other thing I can think of for the problems (“heating failed”, “Thermal runaway”) would be bad thermistor or maybe a bad connection. That thermal runaway is particularly odd, since you say it was reporting a steady 240c when it happened. I’m out of ideas there…

Yep. Great deal at $2ea, helps keep things clean and theoretically helps with temp stability, although I never had a problem with temp before putting it on so can’t really attest to that.

Fan was OFF when I ran the “M303 S240” for PID values. But now that you mention it… I should have probably done it with fan on. I just ran it again with fan at 50% and got P 24.69, 2.34, 59.55 (without fan it was 22.35, 2.16, 57.70).

I’ve been building the firmware myself, since I like a few other tweaks, so I just enter the PID values for hot end and bed there before building. Then I can just do a M502/M500 when flashing. But using M301 to set them, then M500 to save works too – you just have to remember to check after each firmware flash and enter again if they get reset to defaults.

Wow, thanks again for taking the time to come back with all that info. The only time I’ve gotten strange console chars. is from S3D when it’s set at 115200. Uninstalled everything and the installed the original Cura Legacy that came with on USB with the Mini, and the associated firmware, so that I could then do a “fresh” update. Deleted the previous 2.6.66 installer ran that and updated firmware.

Went back to autotune PIDs. For a second I thought everything was working, then this,

[14:47:49] M303 S240
< [14:47:51] PID Autotune start
< [14:47:53] T:22.34 /0.00 B:22.87 /0.00 @:127 B@:0
< [14:47:55] T:22.50 /0.00 B:23.01 /0.00 @:127 B@:0
< [14:47:57] T:23.75 /0.00 B:23.08 /0.00 @:127 B@:0
< [14:47:59] T:26.00 /0.00 B:22.80 /0.00 @:127 B@:0
< [14:48:01] T:29.09 /0.00 B:22.80 /0.00 @:127 B@:0

[14:52:59] T:236.64 /0.00 B:23.35 /0.00 @:127 B@:0
< [14:53:01] T:237.81 /0.00 B:23.25 /0.00 @:127 B@:0
< [14:53:03] T:238.20 /0.00 B:23.46 /0.00 @:127 B@:0
< [14:53:05] T:238.98 /0.00 B:23.28 /0.00 @:127 B@:0
< [14:53:07] T:238.91 /0.00 B:23.28 /0.00 @:127 B@:0
< [14:53:09] T:238.28 /0.00 B:23.35 /0.00 @:127 B@:0
< [14:53:11] T:237.11 /0.00 B:23.32 /0.00 @:127 B@:0
< [14:53:13] T:234.77 /0.00 B:23.18 /0.00 @:127 B@:0
< [14:53:15] T:232.66 /0.00 B:23.46 /0.00 @:127 B@:0
< [14:53:17] T:228.38 /0.00 B:23.39 /0.00 @:127 B@:0
< [14:53:19] T:223.19 /0.00 B:23.42 /0.00 @:127 B@:0
< [14:53:21] T:188.32 /0.00 B:23.28 /0.00 @:127 B@:0
< [14:53:23] T:193.22 /0.00 B:23.35 /0.00 @:127 B@:0
< [14:53:25] T:198.72 /0.00 B:23.25 /0.00 @:127 B@:0
< [14:53:27] T:201.88 /0.00 B:23.28 /0.00 @:127 B@:0
< [14:53:29] T:204.20 /0.00 B:23.39 /0.00 @:127 B@:0
< [14:53:31] T:205.13 /0.00 B:23.22 /0.00 @:127 B@:0
< [14:53:33] T:196.25 /0.00 B:23.22 /0.00 @:127 B@:0
< [14:53:35] T:204.82 /0.00 B:23.22 /0.00 @:127 B@:0
< [14:53:37] T:197.11 /0.00 B:23.42 /0.00 @:127 B@:0
< [14:53:39] T:208.79 /0.00 B:23.18 /0.00 @:127 B@:0
< [14:53:41] T:206.07 /0.00 B:23.39 /0.00 @:127 B@:0
< [14:53:43] T:204.78 /0.00 B:23.35 /0.00 @:127 B@:0
< [14:53:45] T:198.72 /0.00 B:23.15 /0.00 @:127 B@:0
< [14:53:47] T:208.39 /0.00 B:23.28 /0.00 @:127 B@:0
< [14:53:49] T:210.99 /0.00 B:23.42 /0.00 @:127 B@:0
< [14:53:51] T:208.08 /0.00 B:23.32 /0.00 @:127 B@:0
< [14:53:53] T:213.33 /0.00 B:23.25 /0.00 @:127 B@:0
< [14:53:55] T:207.05 /0.00 B:23.22 /0.00 @:127 B@:0
< [14:53:57] T:208.79 /0.00 B:23.18 /0.00 @:127 B@:0
< [14:53:59] T:205.00 /0.00 B:23.18 /0.00 @:127 B@:0
< [14:54:01] PID Autotune failed! Temperature too high
< [14:54:01] ok P15 B3
< [14:54:01] T:317.75 /0.00 B:23.28 /0.00 @:0 B@:0
< [14:54:01] USBPrinterOutputDevice: Resending from: 1
< [14:55:42] ok N0 P15 B3
< [14:55:44] ok P15 B3

So, it got all the way to 238.98 before sporadically jumping it’s way down to 205 at 14:53:59. The second later PID Autotune fails with a reported temp of 317.75. I don’t know that it’s possible to jump 100+ C in 2 seconds, I’m thinking it’s not. However, I can say that it was VERY hot, I could smell the hot. So quickly reconnected to ramp up the fan, opened console to:
< [14:55:44] ok T:257.60 /0.00 B:23.28 /0.00 @:0 B@:0
< [14:55:46] T:256.25 /0.00 B:23.25 /0.00 @:0 B@:0
< [14:55:50] T:254.48 /0.00 B:23.56 /0.00 @:0 B@:0
< [14:55:52] T:252.19 /0.00 B:23.35 /0.00 @:0 B@:0
< [14:55:54] T:250.83 /0.00 B:23.11 /0.00 @:0 B@:0

So, it seems like maybe,
“bad thermistor or maybe a bad connection. That thermal runaway is particularly odd, since you say it was reporting a steady 240c when it happened. I’m out of ideas there…”
is a fairly good guess.

I’m gonna go back to support and see if they have any ideas. Will update.

Okay, so this is crazy. But came across a post referencing noise from parallel cables causing similar bizzaro land wierdness. So,…I pulled the lines feeding the little 5v fan attached to the heatsink out of the bundle running underneath, and am running them over the top.

Everything is perfect, no under/overheat no more jumpy temps, just, working. Even with fan at stock F/W settings.

Interesting discovery… Perhaps the fan is defective? Hard to imagine it could throw enough interference to affect temp readings, but who knows. Or maybe just moving wires around fixed an intermittent connection? Best course might be get the entire toolhead RMA’d so you have a new one, and Lulzbot can inspect/test the old one to learn what went wrong.

Yeah. Rerouting the 5v fan lines resolved all the bizarro land jumpy temps that were causing my Thermal Runaway and wild fluctuations. But even after rerouting, I was limited to maybe 10% fan (S25.5) and even that is hit or miss. Anything above that and the heater just can’t compete with the fan.

I’m hoping that there is also an issue with the heater in this head, and if you haven’t had any issues and are running the stock 24V 30W, that would appear to be the case. Cause almost any fan, and mine never makes it to the 235-245 range that I generally reside in. Initially I was tuning PID with the printhead Z homed. Once I got it down within about 10mm of the bed, I could only get to 240 with the fax down near 2-3% (M106 S7 to S11).

Also, for anyone else like me who didn’t realize this, fan speed range is 0-255, so S25.5 isn’t 25.5%. It’s 10%. Thanks again for all the insight Scott. Much appreciated.