BETA: Cura LulzBot Edition v20 and Marlin v1.1.x for Mini

Cura v20.01
Major new features:

Download here:

Edit: newer version for Marlin

This is the feature i’m most excited about. I will test it starting now. I was always bewildered that AO included a non functional limit switch as the limit switch for the z-min was not functional at all, which i guess functionally was replaced by the nozzle touching the washers (but if that’s the case then why wire up a useless limit switch at all? And why not program it to be a backup switch?). While this firmware change does not address that issue at least this software functionality should help prevent major catastrophic failures, so i’m excited about that.

Can we pause (and then re-start) prints to change material yet?

Yes, pause/resume has been available since v18 (released in January of this year)

That’s supposed to work, but I didn’t have much luck in Cura. I did get it to work with Octoprint. I was using Simplify3D to slice, but it should be possible with Cura as well. There was just more info available at the moment to do it with Simplify and I was in a bit of a hurry.

I will check that out, I do not remember what version I have.
I know I tried to use the plugin that allows you to pause at level, and it paused for a second, then automatically restarted.

I was looking for an actual pause button on the print controller. I did not see it on the screenshot, but perhaps the “print” button changes to it.
Otherwise, is it just a G-code that is put in the right spot?

I just wanted to report that the new mini firmware is awesome! Better bed leveling and just works out of the box! I didn’t even need to adjust my z-offset at all. I like this newer firmware a lot!

and the new cura seems good as well. I haven’t noticed any real change other than more filament options.

Is it possible to update the Mini firmware but remain on the current release 19.12 Lulzbot Edition Cura version? Or, if you update the firmware you need to use the Beta Cura?

Yes. Firmware is independent of cura. Just download the beta firmware hex file and open any version of cura and use the upload custom firmware option or whatever it is called.

Thanks. Because of your z-offset comment, after the firmware update, I did an M851 in the Cura window and it reported back a different offset than mine was previously. I have mine set at -1,23 in firmware and it reported -1.4(something). I set it back to -1.23 and saved it. Seems to be Ok. Wonder if it reset because I used the "install custome firmware’ option in Cura?

Anyway, with the new firmware it seems the nozzle cleaning doesn’t bury the nozzle as deep into the cleaning pad. Also the probing sequence seems faster.

I loaded this firmware (Marlin_Gladiola_v1.1.05_f5e8154.hex), ran a few prints, and have some observations to report.

  1. The only MAJOR issue I had… With the second print I started, the firmware stopped responding during pre-heat. The firmware stopped sending temperature reports, and would not respond to any console commands. I had to reset the printer to clear the condition. I haven’t done enough prints to know if this was just an anomaly, but I have never had this happen with any previous firmware.

Other MINOR items that don’t affect printing functionality…

  1. Homing position is now at Max-Y instead of Min-Y, homing to X=0, Y=191 (as reported by M114) instead of X=0, Y=0. Note that Y=191 is outside of the “print envelope”. This causes an issue with Simplify3D’s XY position readout and jog controls, since S3D has provisions for the “Home” position to be Min or Max Y, but not beyond Max Y. This isn’t a problem with CURA or Octoprint, since they don’t attempt to track/display the current XY coordinates. Not sure how to get Simplify3d to know it is at Y=191 after Home, while still understanding that the print envelope ends at Y=158.

  2. With my Dec-2015 vintage Mini, the controller fan is now either FULL OFF or FULL ON with this firmware. It is OFF until motors are activated, then FULL ON, and stays FULL ON during printing. It returns to OFF a few minutes after the last motor movement. The FULL ON speed is LOUD. My controller fan used to run at about 60%, which was plenty for cooling and a lot quieter.

  3. The rear bed probing locations are closer to the center of the washers (about Y=164), rather than at the edge (Y=157). The front washers are still probed near the edge, as with prior firmwares. No functional difference, just surprising the first time you see it.

  4. The Z positioning (before probing) is about 1mm higher than with previous firmwares. With previous firmwares, I found the default Z for wipe/clean (Z=0) to be too low, putting too much pressure on the pad/bed, so I had revised it 1mm higher (Z=1) and that is too high with the new firmware. The original value (Z=0) in the default CURA scripts worked perfectly for me with the new firmware. Anyone who has, like me, changed their wipe/clean positions will need to change them back.

NOTE: Both old and new firmware have Z_Max_Pos as 159 in the configuration.h file. However, when homing, the old firmware immediately adjusts for the Z-offset as stored by M851. My Z-offset is the default -1.43, so the old firmware sets Z=160.43 instead of 159 when hitting the ZMax endstop. The new firmware reports Z=159 (no adjustment for M851 Z-offset) after hitting the ZMax endstop.

The new firmware behavior (in my opinion) is better here, since setting Z=159 when homing (and not adjusting for the M851 offset before probing) correctly puts the top of the wiper pad at Z=0 as intended. After probing, the M851 Z offset value is applied, which compensates for the washer thickness plus the amount of “first layer squish” desired.

6. The Z-probing seemed to take longer. I didn’t time it, but the descent speed is obviously much slower on the “second touch” at each washer. Approaching the washers more slowly likely improves reliability, and if so, the extra time may be a good trade-off.

For now, mainly due to #1 (firmware hang) and #3 (LOUD fan), I rolled back to previous firmware.

I see #1 as I use Repetier-Host to test printers with(need extra printer controls that Cura does not have). But I do not see it if I use Cura, as it resets the printer when you open the control window to start the print. So I have seen this for several releases of Mini and Taz firmware.

Hmmmm… I was printing a second copy of the same print, so not sure if I opened/closed the print window (thus resetting).

But in the past, with previous firmwares, I have used Cura direct USB, Simplify3D direct USB, and Octoprint using sliced Gcode from Cura and Simplify3d. The only one of those that typically resets between prints is Cura direct USB. But I have never had the printer lockup/hang during preheat with any of them.

It shows up very rarely for me, maybe once every month or two, and comes and goes with no change to the print file. I use the same testing gcode file so I know it works, but BOOM all of a sudden I get the no response problem showing up. So I think it might be a very corner case problem that you just have not seen before.

hmm. interesting. Yeah, i was having to set custom z-offset for my mine with the older firmwares and i was under the impression that updating the firmware for any version resets the z-offset value. Which is why i was surprised at the beta firmware because i didn’t have to change it back, it just worked for me. But i don’t know why. I do have a different toolhead on my machine now than before, so maybe that’s the difference.

The probing sequence is faster and i like it because it seems more smooth somehow too. I hadn’t noticed the nozzle wasn’t as deep when cleaning on mine, seems about the same from what i can tell. But the best part is now when a tiny piece of plastic is blocking the nozzle and the tip can’t make the 5v connection to the washers. Before it would bend the bed horribly like 20mm or something crazy and would do that for all four corners before continuing to print as if nothing was wrong. Now with the beta firmware it stops after like 2mm and recleans the nozzle vigorously in a different way and then re-levels with all four washers! It’s amazing. So i like the fact that they took the Taz6 firmware and ported it back to the mini.

You wouldn’t be using a MAC by chance would you? Before i built my mini i was testing the one at the local library and it was on a MAC. There was a few times that some weird stuff happened (maybe because i would start a print and stop it to change something and then start it again), but with Cura and direct USB it sometimes would loose the heat value for the nozzle and the bed and would slowly go down lower and lower. It was bizarre. I would need to completely close down cura and/or restart the computer. I never heard if anyone else had that issue, but i know some people were having problems on MACs with the latest mac updates at one point.

Nope! Windows.

There have been different perceptions of whether the Probing sequence is faster or slower with this firmware. I thought it was a bit slower, but others perceive it to be faster.

So I made a video of each. Both videos are from the same machine, using the same script. Both videos start after preheat is finished and when the initial head descent begins. They continue through wiping and probing, and terminate where the head pauses for final heating.

The first is with firmware I compiled in April from the Lulzbot 1.02 Gladiola branch. Wiping and probing takes 0:55.
The second is with the 1.1.05 mentioned above, downloaded from Lulzbot. Wiping and probing takes 1:12.
So if all goes well (successful first probe), the compile of 1.02 that I have is a bit faster. Don’t know about other versions. Of course if there is a problem with the probing that requires a second attempt, the new firmware should be faster since it will “retry” whereas with the old firmware, you would have to manually terminate the probing, reset the filament position, and then restart the entire process from the beginning again. That’s a huge win for the 1.1.05 if you tend to have a lot of “failures” during the probing.

Thanks for the videos. Makes me want to flash back to the previous version and look at it again. Your first video seemed really fast. Maybe it is all just perception.

Though interestingly, you can see the nozzle wipe difference in both videos.

Then endstops.h file seems to be missing from the Marlin directory. It won’t compile.