Anyone else having issues with the DualStruder V3?

Was really looking forward to this since I came across it in the devel hardware section a few months ago. Got one shortly after it was announced. Im having a few issues;

Filament loading is very difficult as the printed part dosnt guide smoothly into the metal hold below it. Filament tends to dead-head against the bottom of the channel and not feed in. Makes it incredibly difficult to get filament in without it popping out the side if you miss a roll ending, especially since there still isnt a filament sensor on the tool head.

Filament unloading is nearly impossible until you figure out the trick. It seems the material is melted a bit up the nozzle, and is then too thick to pull back out. Even trying with the motor just ground up the filament. I had to feed it in about 10mm, then pull it back up while it was still semi melted before it solidified too much to remove.

Octoprint communication issues. None of the other updated firmware versions are giving me errors in octoprint, but with the dualv3 flashed, I keep getting checksum errors and needing to force acknowledgement for octoprint to continue (Recv: Error:No Line Number with checksum, Last Line: XXXX). Tried turning on the repitiere fixes, but no dice. Problem followed a different raspberry pi, and usb cable. Disappears when plugged in via usb to cura. Disappears on same hardware with different toolhead (Its been running ninjaflex on the flexystruder v2 for the past 2 hours without a hiccup). I still need to try this on one of my other machines and see for sure that the problem follows the toolhead, but at minimum the new standard heard and flexystruder firmwares dont do this. I don’t have any jobs calling for flexydually or moarstruder atm, so I don’t have a window to test.

Missing some commands. Routinely from S3d the G1 Z1 command at the tart of wipe is skipped and it just swipes away from 10mm high.

Nozzle on an angle. The right nozzle is about .3mm lower than the right in the mount on my machine. I may print a brand new lower lip for the mount just in case this is the issue. This taz 6 has quite a few hours on it.

Mount bolt dosnt line up to triangle hole in the face. Wouldnt it have been nice if the triangle went up just a few mm more so you could fit the wrench straight through?

Live Z offset adjust. Dosnt work here. Did work for the Flexystruder v2.

Cura profile still sends tool head to front point for probe instead of back which is now first.

Also not sure if this is intentional but there is no estep sticker on the back of these like prior toolheads. Is this intentional as the gears are now molded parts instead of printed?

So anyone else spend this week fighting one of these?

I was looking at the parts and thinking on the fillament loading issue, and I think an easy fix would be to extruder a triangular shaped bit of material up with the fillament hole through it so that the empty space between the idler bearing and the Hobbed thing wouldn’t allow a slightly curved piece of fillament to miss the feed hole. The mounting screw bolt triangle clearance is a good call, that would be easy to implement and reinforce around. I plan on building one when i can get the parts.

Thanks for sharing the experiences… I’m interested in getting one of these, but probably a few more months.

Don’t have much for you for the Gcode or Octoprint… check the options on the “Serial Connections” section, maybe try a slower baud and the try the “Ignore unhandled errors box…”

The v3 looks to be a variant/hybrid of the aero titan. The esteps for the aero titan seem to be fixed at 837. More info here: Titan Aero Wiki

The mount triangle has some play on the X-carriage due to the screw holes, you could possibly loosen and slide up to get a better fit. Or modify the mount… modify with elongated holes to allow for adjustment.

I was wondering about adjusting nozzle height of the hotends in the single heatsink. If its only .3mm, I’d try loosening a few of the screws holding the aluminum block and work with the play in the screw holes. Melting threaded insertss into plastic will have different tolerances.

As for feeding filament into the extruder. Maybe try cutting the a more elongated “chisel” tip to allow the filament to flex into the metal portion.

Its unfortunate you need to mod the toolhead… but it definitely has potential.

Very interested in solutions and progress… Please keep us posted.

As for the filament feeding, I have tried to cut a sharpened tip. As the first reply mentioned, if the filament is even slightly curved (and cmon, 2/3 down a roll of 2.85mm PLA can you tell me it wont be?) it hooks away from the intended hole and nothing stops it from either sliding out the back edge or just getting stuck.

The angle seems to come from the fit to the carriage. Ill see if I can work it out there.

The comm errors I dont want to just ignore as its actually missing commands. I cant print customer parts with that.

On the fixed multiplier, thats fine and I assumed something like that was in play. Ive just become accustomed to seeing that in documentation on the toolheads. I change frequently so its a good reference.

Ive put this on the shelf until I catch up. I may have some more time next week to mess with it.

I just installed one yesterday. First issue was that the back plate is too short. When you install it and bottom it in the mount, the screw slot is too low so I couldn’t put the screw in without raising the head up a couple of millimeters, so it’s no longer seated firmly in the holder. I’ll have to cut the screw slot a bit taller. For the filament load problem I cut the end of the filament at an angle. It’s easier to install that way but I still had to play with it. For the filament unload problem I preheat the nozzles and do an extended retract. The instructions say to turn the gears by hand but that only works if you release the motors. The most critical issue I’ll report under a separate header.

Sounds like loading the filament with cut chisel tip is finicky also. Try with the tip pointed down, so the extruder curve guides the filament down, the wedge of tip will keep the tip away from the wall and into the metal hotend section…

As for the mount… that’s a good idea to elongate the hole on the toolhead side so it reaches the theards on the X-carriage.

Hello silent_ninja1,

We do apologize about the troubles you are having and appreciate your feedback. Please reach out to our tech support team at or +1 970-377-1111 for help with the New V3 tool head.

On a quick note, the issue persists with, the latest firmware in the devel branch. Can only occasionally get good prints out of it connected to the PC. Nothing good from OctoPi since it will halt on an unacknowledged command.