Auto level failure

My Mini printer is continuously failing auto level calibration at washer 3. The nozzle is reaching the washer and presses hard before rises and rewiping.
I have tried:
Cleaning nozzle
Cleaning washer and swapping washer
adjusting z axis lock nuts
reloading firmware
updating Cura software.

All to no avail. Please note washers 1 and 2 always pass in auto level. Please assist, at wits end/

Different firmware versions probe the washers in different order, so I’m not sure what you mean by “washer 3”. But if #1 and #2 are the left-hand washers (closest to power supply), and it fails on the first of the right-hand washers, it is possible that your X-carriage is not parallel to the bed.

See the instructions in the 6th post of this thread, as it may help:

To clarify, left front and right front washers pass calibration, right back is the problem washer. thanks

Sounds like you have the newer firmware, which starts with both front washers, then moves to the back. If both fronts consistently succeed but the back right fails, it is “less likely” to be the x-axis level (still possible, but less likely).

Given that it is pressing hard on that 3rd washer, that sounds more like an electrical contact issue. Try cleaning the washer again (maybe hit it with some scotchbrite and alcohol) and checking that the screw and tubular spacer are making good contact with the bed.

Next, check that the wire secured to the underside of the bed is tight, and the wire connected to the heat block (just above nozzle) is connected securely.

If the nozzle is clean, the washer clean and making good contact to the bed, and the wires to the bed and nozzle are secure… Only other thing I can think of that would make fronts “succeed” and back “fail” would be a break in the bed’s wiring harness. It isn’t uncommon for those wires to break, and the result is usually "intermittent’ contact depending on the position/flexing of the cables.

I levelled the x axis again and the touch down contact is gentler at the rt back washer during auto level, but it still fails. I even attached an alligator clip wire from the underside wire direct to the rt back washer but still auto level fails.

Is there any way to modify the auto level code to widen the acceptance criteria, eg increase the distance nozzle can travel to contact before re-wipe?. Or skip washer 3 even (half serious)?

No easy way to skip that washer. The travel limit could be changed by re-compiling the firmware, but that really wouldn’t fix anything – it would just continue further (and maybe to the point the motor would skip steps). And if it “bends down” during leveling, you’re going to end up with incorrect measurements that would cause the print head to be too close (or even touching) the PEI surface. So I advise against that.

Is it still pushing down (deflecting, bending) the bed when contacting that 3rd washer? If so, and x-axis is leveled, my best guess for the cause is a broken wire from the Rambo to the aluminum bed.

(Note: If you are still under warranty, or you aren’t comfortable with electronics, beware that poking around inside the control box could cause other damage – so you may want to let Lulzbot troubleshoot.)

But if you are comfortable doing so, then what I would try next: Open the control box, find the wire from the bed. If you have one, use a multimeter to check continuity from the board-end of that wire to the bed while moving the bed forward and aft. If you see a break when the wires flex, that’s the problem. Alternately, if you don’t have a multimeter, just connect a temporary jumper from that pin to the bed (i.e., essentially replacing the board-to-bed wire with a temporary jumper), close everything up and give the leveling another try.

If it is a broken wire, it isn’t too hard to replace – just takes a bit of time to “thread” the new wire through the cable chain.

Only other thing I can think of to check is that the y-axis (bed) is travelling normally. Manually move the head & bed such that the nozzle is directly above the front-right (2nd in probe sequence) washer, and measure from the washer up to the head. The move the bed forward such that the back-right washer (3rd) is under the head, and measure from that washer up to the head. Are those measurements close? If not, I would look for something amiss with the y-rods, y-rod ends, bed mounts, or frame.

I have observed a tilt from front to back in the bed plate. The back washers are about 2mm closer to the nozzle than the front washers. I observe this tilt with a bubble level also. Is this tilt a problem or within specs?

You have something broke. Mine is within a tenth or two ( 0.1 or 0.2 millimeters) when it levels, as reported by Cura.

2mm sounds like a lot – and could be causing the issue you have with leveling. I don’t know what the “spec” is, you’d have to ask Lulzbot support for that, but I would normally expect all 4 to be within less than 1mm – I think all mine are within 0.5mm of each other as measured by the probe sequence.

Since the front and back are in the same Y location when doing the probe, I think the difference would have to be between the rods and the bed surface. Check the bearing holders attached to the underside of the bed. Make sure they are tight against the bed at front and back. If the screws are loose or something else has caused a “gap” between the bearing holder and aluminum bed at the rear, that might explain the 2mm difference you are seeing. Also check that there is nothing under the bed corner – the spacer between the bed and washer should be tight against the bed and washer, no gaps.

I would check and make sure the heat inserts in the Y motor mount in the back have not pulled out of the plastic.

OK so you are a genius , scotty. I checked the connection from the bed plate to the wire end in the circuit board and I do lose continuity when the plate is moved to certain positions. I never would have suspected tthat.

So how does one re-thread a wire along that formidable path? Where does one find that type of wire? thanks

The bed tilt was a red herring btw.

Great - identifying the problem puts you half-way home. :slight_smile:

Just to make 100% certain, I’d probably connect a temporary jumper wire – just route it along the cable chain with a little tape here and there to keep it in place. Then run a test sequence to make sure everything works.

Once you are 110% positive it’s the wire…

The 1.03 (and earlier, I think) Mini’s used individual, generic AWG24 stranded wires in the harness. The 1.04 model switched to pre-made IGUS Chainflex cables, which look like multiple wires inside a larger sheath. Mini 1.03 and earlier also had a silver bed, whereas I think all the 1.04’s have a black bed. You likely have a 1.03 – as the IGUS Chainflex on 1.04 are way less prone to breaking.

If you have a 1.03… Just get some good quality, insulated AWG24 stranded wire (same color as the old to keep things organized). Work the wire through the plastic cable chain, and then into the black plastic “split loom” going to the control box. It’s tedious work, but doable. Once you get it all the way to the control box, you can cut the old wires ~1" from the terminal, then splice those ends (with the terminals) onto the new wire. (If you have terminals and a crimper, obviously that’s better – but if not, you can splice/solder/heatshrink the old terminals onto the new wire.)

If you have a 1.04… To do a “perfect” replacement, you’d need to identify which IGUS cable contains the bed ground wire – and then purchase that pre-made cable, with terminals. Same process, but larger multi-wire cable, more connections, and harder to get through the cable chain and split loom – I think you’d have to do some disassembly to go that route. Alternately, you could just add a new single generic AWG24 wire, just as described for 1.03. It won’t be “OEM”, but it will work.

If you have a 1.04 and decide to replace the IGUS cable… I recommend contacting Lulzbot support or and see if you can get their help identifying the specific cable p/n that contains the bed ground wire, and just buy the cable from them.

For that matter, even if you go with an individual AWG24 wire, Lulzbot or may be able to sell you a premade wire with new connectors. So I’d probably start by giving them a call – they can help identify what you need, and I’m sure one of them can help with the wires/terminals. They may even have some good tips for the replacement process.

Only other thought… If that wire has broken, you may have others near failure – as all the others have all undergone the same number of bends. The best guarantee for long, trouble-free service would be to replace all the wires in the harness, but obviously that’s a ton of work and may not be necessary. If everything else is working, I’d suggest just replacing that (1) wire for now.

*** All of the above assumes your printer is no longer under warranty, or don’t want to ship the printer to Lulzbot. Because if it is still under warranty, I’m pretty sure Lulzbot would happily fix the problem – although you’d likely have to pay shipping costs, which aren’t cheap. ***

Let us know how it goes!

1 Like

Silly question. Whats the best way to install a jumper wire when the original wire is part of a two pin connection? If I pull the connector out to access the jump-pin, the other wire and pin is disconnected. Yes, I am inexperienced. thanks

There are a few ways…

Sometimes you can insert the wire into the “back side” of the plug, along side the wire you are trying to replace. That’s iffy, depends on the connector and jumper wire, and whether it fits and gives a good connection.

Second option is (carefully) use a knife to bare a little of the wire, just outboard of the connector, and use an alligator clip there. Presumably that’s where you will splice in the new wire later – which will cover the exposed wire. But if you don’t end up replacing it, some electrical tape will do the job.

Probably the best option is to just cut the wire about 1" from the connector (where you’d be splicing in the new wire), bare the end, and connect to that. Then you either splice in the new wire, or (if you end up not replacing) splice the old wire back.

Just to follow up on my problem, I did splice in a new wire and the auto level now proceeds with no issues, and I am printing regularly again. I saw no obvious damage to the old wire I removed, but of course there could be a break inside the insulation. A very devious mystery solved. Thanks again for your troubleshooting acumen.

Glad to hear you fixed it! Those wires take a lot of “repetitive bending”, so like you said - probably broken conductors inside the insulation.

Happy printing. :slight_smile:

Thank you for this post. My exact issue was auto-levelling having a problem at “washer 3” and based on my firmware, that was the back right washer.

For reference, this is my firmware:

< FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup for gen6 FIRMWARE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:Mendel EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000

I did the connectivity test by taking off the side case by removing 5 screws and the back and 5 on the front. I then used the instructions found at and went to step 4. The BLACK wire goes to the lug nut on the bottom of the build plate. I disconnected the plastic clip from the motherboard. I took out that connector and did a continuity test from the black to the build plate. I slid the build plate back and forth and sure enough, it stopped sounding in places. In some places it worked. This wire had broken somewhere on the inside and sometimes it worked and sometimes it didn’t.

I thought it was going to be really hard to just replace that wire but it wasn’t too bad.

Here are the steps I did to replace just this black wire with a couple of really useful tips:

Given I had it out of the black plastic harness, I worked to unravel it until it was loose and I could see where it went into the conduit and through the hole to the build plate side.

I removed the 4 washers on the build plate to get access to the hex counter-sunk screw head and I disconnected the lugnut from the bottom side and then the black wire was disconnected on both ends.

I had some wire of a similar gauge so I cut about 15 inches of it to have enough to thread through.

I tested that continuity worked through the new wire.

I cut the metal connector that goes into the plastic connector about an inch from the metal connector.

SUPER-TIP: I cleaned both ends of the new wire and the black wire that was in the plastic connector. I then used super glue to glue the new wire end to the black wire. I put on a little bit of scotch tape over the glued spot. I then carefully pulled bad wire from the build plate side and pulled the new wire through the entire harness. IT ACTUALLY WORKED.

On the build plate side, I snipped off the metal eye, and soldered it onto the new wire. I re-attached the lugnut and tightened it sufficiently. I tested that continuity worked through the new wire.

I trimmed the wire leaving about 4 inches on the case side.

SUPER-TIP: I took the metal connector end that goes into the plastic connector and stripped off some wire. I then soldered the old connector to the new wire and put some heat shrink up to the metal connector. I then re-inserted the metal connector into the plastic connector and then plugged the plastic connector back in.

To bench test, I re-assembled the case putting only the top and bottom screws into the back and front. I opened cura, chose an STL to print and allowed it to go through the self-levelling test and it worked like usual.

Thanks again to getting me down this path. I was misled by the x-axis issue as it was close but not the same.


1 Like