Bed heater failure

While running a long print, I noticed that my bed temperature was changing erratically with a downward trend. After about 10 minutes it just stopped heating and slowly cooled down to room temperature.

I had a spare heat bed kit (heater, glass, PEI combo), so I installed that. That didn’t resolve the problem, still no heat.

Everything else is working fine, I get heat on the extruder, and everything moves as it should. Since I did a replacement of the heater, any poor connections there would have been discovered.

Any suggestions?

If you look inside of the control box you should see a RED led start flashing when you manually turn on the heat bed. If you do not see that led flashing then you need to check the 15 Amp fuse on the Mini-RAMBo inside the control box. If the fuse looks and measures good. then you have a RAMBo failure. If you see the LED flashing you also may have a wire that has broken from the RAMBo to the heat bed.

I found a solution.

I did not suspect a fuse, although I did look there, because of the erratic behavior prior to failure. I would have expected a fuse to be an instant failure.

I measured the voltage on the two purple wires that lead from the board to the heater. I got nothing at the heater connection. I then measured the voltage at the connection to the RAMBO board and got 24 volts.

I removed the wires from the RAMBO board, did a continuity check on the wires, and found that one of them had an open. Further investigation revealed that the wire was broken about three inches from the heater connector.

I expect everything will work fine when I replace that wire.


For any of you who are interested…

Replacement wiring harness on the way, thanks to Lulzbot/Aleph Object’s excellent customer service.



I found this thread when our Taz 6 had the heatbed failure. I opened it up to check out the rambo since all the wire connections seemed intact. I saw a red led light when I tried to heat the bed, but there was still the failure. The fuse was perfect. I started checking the actual connections on the rambo and found that the heat2-bed connection at some point had overheated and melted the plastic. I scraped out the plastic, put the wire connection back and turned on the heat bed again. This time it worked with the red light flashing. When I spoke to support they said the heating can happen, but is rare.

As a precaution I am going to replace the rambo and the wire connection. Lulzbot doesn’t have the rambo in stock anymore so I will have to order elsewhere or maybe they have an alternative.

It looks like we don’t have the 1.3 RAMBo in stock currently but we do have the newer 1.4 at this moment. You can use the 1.4 RAMBo as a direct replacement for your Taz 6.