Can't install Cura on mint 19.1

I am attempting to install Cura on linux mint 19.1 but I am running into issues. I had it working on 18, but since I did a clean install of 19.1 I need to re-install Cura.

$ cat /etc/apt/sources.list
#deb cdrom:[Linux Mint 19.1 _Tessa_ - Release amd64 20181217]/ bionic contrib main non-free
deb bionic main

(note that I also tried substituting ‘tessa’ for bionic in the sources.list file without success)

I get some suspicious messages when I update:

$ sudo apt-get update
Hit:1 bionic InRelease
Hit:2 bionic-updates InRelease                                                                                                                                                                    
Hit:3 bionic-backports InRelease                                                                                                                                                                        
Ign:4 bionic InRelease                                                                                                                                                                        
Err:6 bionic Release                                                                                                                                                                          
  404  Not Found [IP: 80]
Hit:7 stable InRelease                                                                                                                                                                           
Hit:8 bionic InRelease                                     
Ign:5 tessa InRelease                                                          
Get:9 bionic-security InRelease [83.2 kB]                                                      
Hit:10 bionic InRelease                
Hit:11 tessa Release                                         
Hit:12 bionic InRelease                                
Hit:14 bionic InRelease                                        
Reading package lists... Done                       
E: The repository ' bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

and an install attempt fails:

$ cat /etc/apt/sources.list
#deb cdrom:[Linux Mint 19.1 _Tessa_ - Release amd64 20181217]/ bionic contrib main non-free
deb bionic main

What am I doing wrong, and how do I fix this?

I managed to get it installed.
‘tessa’ is the code name for the version of Mint I’m using, ‘bionic’ is the version of Ubuntu it is based on, and ‘buster’ is the version of Debian that ‘bionic’ is based on. So I tried ‘buster’, and that worked.

A lot of great things seemed to break with the current CURA-LE software. I wonder why developers don’t package their releases as Docker images or just complete Linux distributions.

So they used Debian Buster for the latest release, which means it does not work with ANY Ubuntu or Mint release. Even the googled links to fixes are now broken.

On top of that, once you drag out that old Windows PC, the instructions for installing the FlexyDually extruder don’t match up with the current release of CURA. I.E. “Dual Extrusion Merge” is not a choice on windows or linux with CURA-LE 3.2.32.

Frustrating. I’ll be in a better mood when I can start printing again.

We actually build for Buster, Jessie, and Stretch for Cura LE. Grab the latest package listed in the README.debian file for your architecture.

The naming has changed slightly, but the process is very much the same. Instead of “Dual Extruder Merge” It is just “Merge”. If you would like to revert back to the version of Cura for those directions, you can find 21.08 here:

As always, if you have any questions feel free to reach out to our support team at

An update to cura has broken the working install on Linux Mint 19.1
Cura now requires GLIBC_2.28, but Mint 19.1 only has version 2.27-3ubuntu1
Anyone know how to get GLIBC_2.28 installed on mint 19.1 in a way that won’t break the rest of the system?

As a work around, I installed slic3r from the software manager, but that just does a core dump.

I tried using my windows work computer, but looking at the gcode, it is different from what the old software was doing, and I suspect that it requires a newer firmware to be installed on my printer to work, and I can’t haul my printer to work to update the firmware.

I am stuck and can’t print.