Problem installing Cura Luzbot Edition on Ubuntu 18.10


I’m trying to install Cura Lulzbot Edition on my Ubuntu 18.10 (cosmic) laptop. I’ve added the following to /etc/apt/sources.list.d/cura-lulzbot.list:

deb stretch main

After doing apt update I get the following:

# apt install cura-lulzbot
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cura-lulzbot : Depends: libssl1.0.2 but it is not installable
E: Unable to correct problems, you have held broken packages.

Sorry to hear about the difficulty! It sounds like this is the same issue as was reported here:
On that page there is a link to the debian package you should need to resolve this. I am also including the link here just for the sake of ease:

Wouldn’t it be better to depend on a proper Ubuntu package instead of a Debian dependency that has to be manually installed? Say Also, if something needs to be done, the article should be updated accordingly.

Hi mcamou,
We are building CuraLE on Debian buster, therefore all the dependencies are taken from Debian, not Ubuntu.
I have added libssl1.0.2 to our repo.
Also I noticed you do have a stretch repo added in your first comment. since 18.10 is based on buster, the repo line should be

deb buster main

Great! Thanks @alexei. I was able to install it now. Perhaps it would be a good idea to update ? That’s where I got the installation instructions from (and the first result when Googling “install cura lulzbot linux”).

I’m on 18.04 (bionic) but I had great success using this:

sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak && sudo sed -i '$a deb buster main' /etc/apt/sources.list && sudo apt-get update && sudo apt-get install cura-lulzbot

I didn’t find a bionic repo but the buster (18.10) repo worked great for me. It also had the missing library.

Indeed, this helped me a lot installing cura-lulzbot on Ubuntu 18.04.1 LTS


Thank you all for your feedback! We’ve updated the instructions at:

I am now having a different problem, this time with Ubuntu 19.10:

$ sudo apt update
Err:11 buster InRelease                                                                                                                           
  Could not connect to ( - connect (113: No route to host)
W: Failed to fetch  Could not connect to ( - connect (113: No route to host)
W: Some index files failed to download. They have been ignored, or old ones used instead.

The instructions at have removed all mention of an APT repository. I really don’t like installing .deb packages directly due to having to remember to manually update them. What should I do?

1 Like

I’m having the same Problem. It seems that the complete link doesn’t work anymore. You can’t download any of the Debian packages through it. I tried adding it to my sources.list thingy, but it doesn’t like that at all, since it can’t read anything from the link. There currently is no way for me to install cura-lulzbot. I’m on Ubunut Disco. I don’t know why there is no snap version available or why it’s not on the ubuntu software store.

@AntsAare I just recently downloaded and installed Cura LE on a fresh install of the latest version of Ubuntu. I am going to post some of the steps that I took to make it work. I got the binary release from the lulzbot gitlab DPKG gave me issues with dependencies so I had to track those down and install the .deb files for them then use DPKG to manually install them. I also used the dependency install line from curabuild gitlab before tracking down individual dependencies.

I don’t have an answer for why there is no snap version available other than there isn’t. I do however want to say that we are working on improvements and I will make sure to take note of this. Feel free to send any questions