Changing Taz6 Head Throws Off Z Axis - Crashes Into Bed

When I change the print head (SE) with another SE, it apparently changes the Z axis enough that the head deflects the bed and switches about a half inch before I killed the power on it. Is something not working right to allow it to sense the position? I’m surprised it didn’t break the bed surface. Is there a way know how much to change the Z offset, or do I just keep changing it until it ‘looks right’? Very disappointed that a machine this expensive had to have the power killed to it when I heard a buzzing sound because it was trying to push itself through the switch, bending the bed.

If it is hitting the button correctly at the start of leveling before trying the washers, your problem is more likely a lot of plastic on the nozzle, or a broken/disconnected Z-sense wire, and is not related to your Z offset. Check the connectivity between the nozzle and the Z sense wire on the harness.

If it is not hitting the button before leveling, you need to make sure you update the firmware to match the new toolhead (or change the toolhead in the firmware if you’re using an up-to-date Taz 6 Universal Firmware), as the nozzle position is a little different, so it won’t hit the initial z sense button.

You shouldn’t need to adjust the Z offset with different toolheads, since that only measures the difference between the washers and the bed, and you didn’t change the bed.

Thank you for your response.
I should note that I thought my print head had failed several months ago, so I bought a new SE head, and replaced it. After replacing it I started a print and found out 15 minutes later when I checked on it that the print head was mashed down on the button, of course while still hot, and had damaged it somewhat. I removed and tested the switch, which seems fine. After two months of trying different ideas from this forum, I finally tried changing the Z offset. I had to tweak it a couple times, but then it worked, and I have printed quite a bit since. This week, it ran out of filament, clogged, and I haven’t been able to clear it after about an hour of working on it. I figured I would just switch back to the old head, but it is deflecting the surface about 1/2" by pressing down on the switch again! I have adjusted the Z offset, but don’t remember how much it took.
I would assume there is a way to manually get the printer to find its location, but I haven’t figured this out yet. I have preheated the nozzle, used an abrasive pad (lightly) with no success. This switch it just that. A microswitch. So, I don’t understand. Since it is working, why doesn’t this printer stop it from pressing too hard? Does it also need continuity for the switch to work? But I have had the same exact problem with each of the two SE heads.

Thanks again!

Start the homing sequence and just immediately press the button with your finger. If it fails to stop, the button or one if its wires is broken.

If it’s not hitting the button dead center, with the appropriate firmware loaded, you may need to physically re-position your bed.

I decided to switch back to the head I have been printing with and try again to clean the head.
I did the test with the button, and it did stop, but it also says: Homing Failed PRINTER HALTED Please reset. Is this normal? It did this with both heads, BTW.
Also, can you give advice on cleaning the head? From what I’ve read, I should be able to heat safely to 230C to clean the head. I have done this, and the clog is still very solid. I can barely press a sharp probe into it. Ideas?

Thanks again

One of the most common causes of a clogged tool head is “heat creep”. This can cause the filament to melt before it reaches the heater block. Normally, this is prevented by the “cold end” or “extruder” fan but if it does happen, this premature melt can cause a clog.

One solution is to force the “heat creep” to happen again while you are prepared to clear the clog. Heat the nozzle to the high end of the temperature range of the filament and block the cold end or extruder fan. This will cause “heat creep” which hopefully will melt the filament causing the clog. While in this state, manually push some new filament through the system and once it is flowing nicely, unblock the cold end fan and lower the temperature of the nozzle to the low end of the temperature range. Keep the filament moving until the cold end cools down enough that the filament melting is only occurring where it is supposed to melt, in the heater block.

There’s lots of information available in this forum or on the internet. Use “heat creep” and “cold pull” and “clog” in various combinations as search terms.

If I haven’t mentioned it, this all happened because I ran out of filament during a print. The nozzle, of course, still stayed heated, cooking what was left in the cold end. To allow intentional heat creep I removed the cold end fan, turning the temp up in steps to try to soften the plug. I have had no success with it softening, and wonder at what temp I will make it worse by overcooking… Very frustrated.

Sorry you were unsuccessful at clearing the clog. Sometimes you have to resort to physical means. I found some how to articles and videos using the search string “3d printer clearing clogs”. You can also search for “clearing clog Titan Aero Hot End and Extruder” to find information specific to the SE tool head.

I will work on disassembling this head to try to clear it, thanks.

It the mean time, I went back to the original head. I went under ‘Motion’ and selected ‘Home Y’. It seemed to work fine, although the ‘pad’ switch does deflect a little more than I would have expected on the second touchdown. Maybe 1.5mm. It stated Y Offset Saved. I hoped I was out of the woods, but when I start a print, it tries to go right through the switch, deflecting it probably 5mm before I hit the power switch. I don’t understand the difference. It seems to see the switch when doing a Home Y, and while doing an Auto Home and pressing it early, but not while printing. I would get a switch if I thought it would help, but it tested well with a meter as well.

Is this correct?

You have two identical TAZ 6 SE toolheads. What firmware version do you have installed?

One of them is clogged and the other one doesn’t complete a G28 (and/or a G29).

I have my TAZ 6 connected to a Raspberry Pi 3B running OctoPrint. I can also connect it to my Windows 10 system and use Pronterface (Printrun) to execute these commands. With an Aerostruder and firmware version

  1. An M119 shows all endstops in the “open” state.
  2. An M851 shows “echo:Probe Z Offset: 0.27” (because I have a Magnetic Flex Bed V2 installed. With the default bed, the Z-offset was around -1.27).
  3. A G28 XY completes without heating the bed or the nozzle.
  4. A G28 Z positions the nozzle above the Z-min switch and touches it with no deflection of the bed.
  5. A G29 V4 requires a heated nozzle and completes without any visible deflection of the corner washers (if the nozzle is clean). Adding the V4 parameter just prints more information.

Where exactly do each of your tool heads fail using the above sequence?

The firmware is

This is a work machine, and it takes a lot to get software approved for use on the network computers, so I’m not sure how to implement the steps you’ve given.

I am somewhat embarrassed to admit that I realized something this morning. When selecting Home Y, it goes through the steps fine. Although, as I said earlier, it depresses the switch roughly 1.5-2mm, which seems too much. Anyway, I realized this morning that when I start a print, it actually misses the center of the switch, and catches the edge of the button, causing it to press the entire switch down, not just the button section. I have tried using Home Y first, but it still changes where it thinks the switch is while printing. Any ideas?
I should also mention that while doing the Home Y, it presses the very edge of the switch. Also, I just found out that while doing a probe test, it slightly misses the button in the Y axis, and fails.
Thank you so much!

Firmware is the Universal firmware and allows for selecting different tool heads from the LCD console instead of reflashing the firmware for each different tool head.

The obvious question then becomes, have you selected the correct tool head from the LCD console?

Is the printer’s USB port connected to something? If so, what OS is that system running and what software do you use to communicate with the printer? You can manually send commands to the printer from CuraLE (or just about any slicer).

THAT WAS IT!!! Even though I selected the toolhead in Cura since I updated the firmware, I didn’t know there was an option on the printer to select it as well. I need to fine tune the Z Offset, but I am finally able to print!
Thank you so much for your efforts, patience, and time! I really appreciate it!

It was in the first reply, but glad it came full circle back to the solution.

You’re right. I had read this at the time, but thought it was hitting the button okay, and did not see that it was catching on the surrounding trim. Thanks!