Confusing slicer issues

I was trying to print this new cover ( to add a Raspberry Pi to my Kittaz. I have been printing everything so far using the the medium settings for slic3r and had no issues. After slicing this however, the gcode in pronterface seem to want to print a strange block of the negative space under the cover. I loaded the stl in to cura and tried slicing using the suggested meduim settings. The code looks fine but when I print the first layer doesnt adhere well. I am printing with ABS with almost all default the settings. I adjusted for feed steps and actual wire size. Any reasons why this part wont slice correctly in slic3r or better settings for cura?

After slicing this however, the gcode in pronterface seem to want to print a strange block of the negative space under the cover.

Are you talking about support material?

Are you using the “no_support” slic3r profile?

I tried both with and without the support material. When I looked at the preview in pronterface from either setting, the total print is only about 3/8" high and the results look nothing like the model i downloaded.

What version of the Pi cover did you download, and what version of Slic3r are you using?

There’s a View/Cut button in slic3r. What does that look like in Slic3r?

There’s a v2 and a v3 of the Pi cover. Which one did you try? Have you tried the other one? :question:

I’ll have to check & see which version of slic3r I’m using. I havent noticed a way to see the layers in slic3r but would load the gcode into pronterface and scroll through the layers there. I tried both the v2 & v3 of that part. Both gave me a similar looking shape. I tried slicing a different cover that was made for the B+ and it looked fine.

This is a handy application:

Free and does a great job rendering gcode so you can see what’s going on.

I’m using slic3r version 1.1.7, which appears to be the latest stable version. I looked at the file through the view/cut option and saw a few weird artifacts on the bottom flat but it looked mostly like the model. I checked the resulting gcode on the site and it looks just like how pronterface shows the preview.

Loading both the STL files there into Netfab shows they have errors in the models, so they will not slice properly.

To make matters worse, the different slicers try to fix STL mesh errors and frequently do not get it right and don’t report that there was an error and what they did. This lulls users into a false sense of complacency that all was ok with the model. I’d say that a good 20% of the models I’ve downloaded from Thingiverse have mesh errors. It’s a bit unbelievable thatches are allowed since it is easy to check at upload time.

The allows you to actually plot the gcode one line at a time within a layer and/or layer by layer so you can see how the part will actually be printed. This helps identify issues. I’ve not seen that ability in Pronterface on the Mac. Does it exist on the Windows version?

Wow. Slic3r says it “auto-repaired” 4319 errors. :open_mouth:

Then the Pronterface “review” of slices shows some bizarre stuff going on.

I think there’s issues with the stl file from Thingiverse. I’d find a different one, or design my own.

I went through the both slicers, converted and transferred settings by hand from slic3r to cura and tried the print again. After about 8 hours i had a successful print. Apparently cura could work around the errors in the model but the default profile was not as well tuned as the slic3r profile.

It’s unfortunate but a fairly large number of models posted to Thingiverse have really bad mesh errors in them. Some slicers do a better job at healing but a different model may go the other way. The best thing to do is to use NetFabb (free cloud service) to fix bad STLs and not rely on the slicer. Even models fixed by the slicer can have horrible artifacts in them that can lead to bad prints and difficult to diagnose problems. I even had a situation where after 12 layers the printer would shoot off to the side then home! It took a bit of work to track that to a model issue.

The simple transference of slicing parameters from one slicer to another (except for S3D which is very (painfully) different) is a fairly straight forward process and as long as you pay attention to the big items, you’ll get a good print, then you can learn the details of the new slicer to fine tune.