Cura making supports in the middle of model

Hey all. So I have this model, it was made in sketchup, not by me but a co worker.
When I go to slice it it randomly takes out parts and makes it into supports. Please ignore the handrail I know it has issues. I am more concerned with the step unit.

It does not seem to matter how I rotate the model it puts in random chunks of supports at different points in the steps.

Any ideas why or how to fix it? I am using the right version of Cura

Here is another example

What happens if you change supports from “Everywhere” to “Touching Build Plate”?

What happens if you turn Supports off?

Have you tried setting “Print Thin Walls”?

Can you upload the .stl file so we might examine it and experiment with it?

Out of curiosity, try Ultimaker Cura 5.1. Their new slicing engine may produce better results. The new Arachne slicing engine is also included in PrusaSlicer 2.5.0-alpha3.

I have “print thin walls” checked. and if i remove supports or change it to touching build plat i just get empty areas like in the photo.

And I am to new to attach the STL file. Not sure what else is an acceptable way on the forum to share it.

Probably the easiest way to share the .stl file would be to upload it to a free file sharing site like MediaFire or share it from a Google Drive, Dropbox, etc. Then just post the link here.

If you scale the model up to 110% or 120% does that fix the problem?

What happens if you change the profile from Standard to High Detail (i.e. a smaller layer height)?

You could also just change the “Layer Height” and/or the “Line Width”.

here is the google drive link.

Tried to scale up and down same issue
Tried changing detail same issue.

The .stl file has errors. While looking for the best option to repair it, I found this link which suggested using Slic3r to repair the file.

I did that and Slic3r auto-repaired the file. There were 22,909 errors, 20821 facets reversed, 2088 backwards edges (see the screenshot below).

I saved the file and here it is:

Stairs1.stl (7.7 MB)

See if that doesn’t work better in CuraLE. Let me know if you have any questions about the process. Figuring out why the .stl file had errors in the first place is an exercise I’ll leave to you. :grin:

There are other programs for repairing STL files. See and

Microsoft’s 3D Builder is available for free. I was able to repair the file using that as well.

Sketchup isn’t great for creating 3D print files (although I am very guilty of using it anyway), since it isn’t a “solid” modeling program. You can accidentally or intentionally create reversed faces, faces in solids, reversed faces in solids, holes in models and just about every other type of non-Euclidian geometric feature you can think of. While tinkercad is arguably less powerful (no direct manipulation of edges, vertices, etc) it does work based on solid shapes and is much less prone to creating problems with geometry. Onshape is extremely powerful, but harder to learn.

Thank you all for the help. I will look at the repair software and see if I can fix it like you all did.

I agree how bad sketchup is, but the person doing the designing likes it best. So I am just trying to make my part of the job work.

Love all of the help