Cura 21.08 "Initial Layer Line width %"

In Cura 21.08, does the Advanced setting of “Initial Layer Line width %” actually DO anything?

I am pretty new to 3D printing, and I am still trying to get everything dialed in, and to get experience with tweaking settings to get a desired result.

Using PC-MAX, my settings seem fine. When I switch to Polymaker PLA, the first layer is too stringy ad the fill lines do not squish together properly. I have already tweaked the Z-Axis offset and it is fine for PC-MAX. Therefore I think this setting is “correct”.

So, I have tried to increase the “Initial Layer Line width %”. I pushed it from 125% to 180% and the first layer looks exactly the same. I pushed it to a ridiculous 200% and it is STILL the same!

Is there some reason that this setting will have no effect on the width f the lines of plastic being laid down in the first layer?

I have the “Initial Layer thickness (mm)” set to zero. I want the first layer to be exactly the same thickness as all the others. Is this wrong? Should it be set to the same number as the setting in the Basic settings of “Layer Height (mm)” which for my recent prints was set to 0.15mm.

Can someone tell me what G-Code should be generated or changed by setting the “Initial Layer Line width %” to a custom setting? I would like to compare the G-Code for two identical prints varying only in the “Initial Layer Line width %” setting.


I personally like to have a semi-high initial layer height to help adjust for any bed surface defects like bumps and peaks in the actual bed surface. Then when it is laying the next layer it tends to be a now even more flat layer surface height.

Plus in math terms if I remember right: 0(initial height) X 200% is still 0% change.

I agree, 200% of nothing is still nothing!, But I am not at all sure that’s actually how it works. I suspect that it is 200% of the normal extrusion rate to change the WIDTH of the stripe of plastic, not the thickness of the stripe. But it certainly does not appear to be doing anything at all!

Additionally, the initial layer thickness, is supposedly, according to the little pop up in the software, ADDITIONAL thickness above and beyond the normal layer thickness, which in this case is set to 0.15 mm.

I agree, in general, I do not mind having a little extra thickness on the first layer, and I agree that it is a good idea to try to give clearance for surface irregularities of the PEI sheet. However, in this particular situation, I need dimensional accuracy.

Additionally, the very thin lines occur no matter what initial layer thickness I said, from zero, up to the 0.4 XX mm default thickness.


If you set initial layer height to 0.0 to set that you keep your initial height to your default height of 0.15 then you are basically disabling that setting. So the program sees Initial layer height is ‘0.0’, so initial width is 0.0 X ???% = no width change.

So the program sees Initial layer height is ‘0.0’, so initial width is 0.0 X ???% = no width change.

I will have to check that out. I would have EXPECTED that using an Initial Layer Height of zero would cause the first layer to be the same as the rest of the layers (e.g. 0.15mm) would not cause the initial width setting to be completely ignored. I expected that the extruder rate would be a function of the height (default, not actually zero) and width (nozzle size multiplied by the width% setting) and the flow rate setting. But what ACTUALLY happens is whatever the software writers decided to do!

I can check this pretty easily by testing two width settings with the height set to zero, then the same width settings with the height set to the same number as the rest of the layers.

It is not clear to me that changing the “Initial Layer Line Width %” setting will actually result in more squish and better contact between the lines. I suspect that the overall flow rate setting and the Z-offset setting are the only factors to have a major effect,.

Yesterday I tried increasing the flow rate to try to get better first layer squish: I set it all the way up to 140%. Then I lowered the Z-Offset to get great squish. But then it was massively over-extruding for the rest of the layers. 120% seems much better for the rest of the layers, and the squish (without further lowering the Z-Offset) seemed OK. Maybe it needs a slight further lowering of the Z-Offset setting.

But I will try to optimize the flow rate for the other layers first, then fine-tune the Z-Offset for the first layer. Right now I have a good ball park setting for the Polymaker PLA filament.