Cura 3.2.23: pause at layer

Is there a trick to getting pause at layer to work with 3.2.23?

I had it working with 2.6.69, but upgraded to 3.2.21 and both broke. Uninstalled everything and tried again with 3.2.23 without luck.

I like the features of 3.2.23, but it seems like I would need a clean install of only 2.6.69 to get a working plugin?

And by ‘broke’, I mean the print head tries to move through the print bed when I resume…

Can you post the gcode for a print that exhibits this behavior?

LM_Cone_40mm.gcode (1.55 MB)
Here you go, thanks! Lulzbot Mini (1), btw.

The gcode inserted by appears to be correct.

When the code is executed, the printer should raise Z by 1mm, move to (default) X,Y 190,190 and then (because current Z is less than 15) raise Z to 15mm to allow some room under the nozzle. When the pause is resumed (under the assumption that the toolhead has not moved, only filament adjustment), 50mm of filament is extruded, a (default) 5 second pause for the operator to wipe the nozzle, Z is lowered to the original Z plus 1mm, and X,Y and the value for E are restored to their original location / values. The first command from the original gcode should lower Z by the 1 mm added by the pause code and the print continues from there.

If the nozzle is being driven into the bed, one possibility is that the assumption that the toolhead was not moved while the printer was paused is wrong.

I guess another possibility is that the pause time was so long that the firmware timed out and lost track of the Z position.

My last guess (which may be my best guess), X190 Y190 is outside of the dimensions for a Mini. The script allows for those values to be input, 190 is the default. Perhaps a default of X0 Y0 would have been a better choice as that location should be valid for all (Lulzbot) printers.

Can you provide any additional input that would narrow down the actual cause of the error?

Where is this plugin? How do I get it? How do I toggle it?
I’m using Cura LE 3.2.23
Installed and Browse Plugins doesn’t show a “Pause at Height” plugin

Look here:

Post Processing

Then you will find it under Add a script on the window that pops up.

Thank you!

that helped! I went with your last guess and set it to X0 Y0 and it worked fine… for the first layer.

After that it would extrude a big blob and then retract as fast as I’ve ever seen it go, stripping out the filament. Next layer it didn’t extrude the blob, but did retract again and strip the filament.

Are there assumptions or corrections the firmware will do that would cause the extrude/retract behavior?
LM_Cone_40mm.gcode (2.76 MB)

Sorry I’m a bit late with my reply!

I looked at the gcode and the second and subsequent uses of the script are generating bad code because the script seems to have forgotten that the E mode is absolute. The first instance sets E mode to relative and then sets it back to E absolute. The second and subsequent uses insert relative E commands without setting the mode to relative (and all hell breaks loose).

I’ll see if I can figure out what’s wrong and post a revised version of the script when I do.

I’ve attached an updated version of the script that fixes the second and subsequent uses of the script in a single gcode file. (6.49 KB)

Awesome. I have the same problem, even after upgrading to the newest version of CURA 3.6.3.

I thought maybe three versions later it would be fixed, but I have the same issues peokuk has had. At first I thought it was because I put the gcode into octoprint server and something on that end was screwy. So I tried printing directly through CURA. It seemed to go well until the print head moved slower down below the print bed, behind the wiping pad. I turned off the printer before it decided to dig into the bed.

Do I just change 190, 190 to something else?

How would I implement your script posted above?


The post processing scripts (with a stock install) are located at:
C:\Program Files (x86)\cura-lulzbot 3.6\plugins\PostProcessingPlugin\scripts

Place the script I posted in this folder. It has a different name so it will not overwrite the one that came with 3.6.3.

I believe the one I posted uses a default X,Y of 0,0 instead of 190,190 because all LulzBot printers have a 0,0 (190,190 is out of range for the Mini).

Edit: If you using 3.2.32, the location is:
C:\Program Files (x86)\cura-lulzbot 3.2\plugins\PostProcessingPlugin\scripts

That’s useful, thanks!

Might you know of a script to do the old “Tweak at Z” plugin, please? Running my Mini Mk.1, I have this idea to make a base in ABS and then print/bind a cup onto it in NinjaFlex. Many thanks!

Ah, I missed this … As kmanley57 noted, in Extensions --> Post Processing --> Modify G-code shows “TweakAtZ or Layer 5.1.2 (Experimental)”. Will give that a try.