Pause at Height Issue Lulzbot Cura 3.6.3

Is anyone else having an issue with pause at height working on this version of Cura? Please see attached file I was trying to print to see the g-code I was using. I used the basic script inside of cura with no luck. I had the highest layer at the top and lowest layer at the bottom. I tried to put the time to 300s just to see if it would work and that seemed to make no change. Also I am the use the Pause at Layer not pause at height. I appreciate any help. Thank you in advance.
LMA_pittsburgh-steelers-mk.gcode (435 KB)

In 3.6.20, there are multiple “Pause at…” post-processing scripts available and some of them have issues. I have attempted to fix most of the issues in There was also some issues with getting the updated versions into CuraLE so I’m not sure which version is available in 3.6.3.

From the gcode you posted, I see 3 pauses, layers 2, 4, and 5. What specifically isn’t working?

It is no pausing at all on the printer it just seems to keep on going with no change. I am using an original Lulzbot Mini with and Aerostruder Toolhead.

What is the printer connected to (i.e. what software is controlling the printer)?

Does the printer move to 190,190 and raise Z at the chosen layers?

If the printer doesn’t “pause” then the M0 command either isn’t being sent or isn’t recognized by the firmware in the printer.

I am seeing the exact same issue.
Here are the details:

  • Lulzbot Cura 3.6.20
  • Lulzbot Mini with latest firmware (
  • Running on stock OctoPrint, fully up to date with no plugins
  • In Cura, using setting “Pause at height or layer”
  • on an 18-layer part, telling it to pause at layer 13
  • Printer does not stop, even briefly throughout print.
  • Ouput file contains no “M0” callouts
  • Same settings in vanilla Cura 4.3.0 contain script with M0 as expected

Both files are attached, and I’ve triple checked that the pause at height post processing is active in Lulzbot Cura, it’s just having no effect. Also, If I close Lulzbot Cura and reopen, the post processing script is gone (which I like because I constantly forget to remove them later) whereas in vanilla, they persist after reopening.
Pause Working on Cura 4.3.0.gcode (530 KB)
Pause Not Working on LCura 3.6.20.gcode (393 KB)

Very strange. Just so we are clear, @cybercore’s issue is different than @myurkoski’s issue. In @cypercore’s case, the post processing gcode was inserted. In @myurkoski’s case, no code was inserted.

My initial test of CuraLE 3.6.20 failed to insert any scripts, not just PauseAtHeightorLayer so I decided to regress to previous versions to see where it went wrong. On another system, I installed 3.6.3 and it worked, 3.6.18 worked so I came back to my main machine and tried 3.6.20 again. This time it worked.

For PauseAtHeightorLayer, it will insert “;TYPE:CUSTOM” and “;END:CUSTOM” around the gcode it adds (for each instance).

I have no idea why it failed and then succeeded.

So I found a solution to the issue. I ended up clearing my entire computer of all Cura files (Literally going through windows explorer and searching my hard drive and deleting anything named cura). After that I did a full re-install of Cura Lulzbot Edition as well as fresh firmware flash and that seems to have fixed the issue. Stop at height is now working. It seems to be a software issue with Cura. I will say on resume after a filament change you will want to re-home your X/Y Axis otherwise I had issues with it not printing correctly, just a heads up. Thank you everyone for all of your help.