Cura 3.6 No Longer Working

I have a lulzbot mini and the cura 3.6.36 software i am using has just broken on all three of my computers at once. I can no longer communicate with my printer. I have tried everything on my end from reinstalling everything to even reinstalling windows and starting completely fresh. The startup screen loads the green octopus logo and then it just crashes.

Is there a way I can use a different software like utlimaker? There are no profiles for lulzbot on there and i dont know how to add a custom printer or where to get the settings since i cant even get open my prior program.

I use simplify3d. There is a lulzbot configuration.

awesome thanks! Ill give it a go!

woah $150? Is there anything more affordable or a free alternative?

You can download Slic3r for free. I don’t think there’s a specific lulzbot configuration.
Simplify3d might have a free trial just so you can check things out.

Software “breaking” on three computers at once is quite rare, can you explain what you mean by “broken”?

First, I would uninstall CuraLE completely and clear the cache as shown in https://lulzbot.com/support/cura-windows. Second, install CuraLE again. Third, configure your printer.

At this point it doesn’t matter if you can’t connect to your printer as you are just going to use CuraLE to configure whatever alternate slicer you prefer.

With my TAZ 6, I use Ultimaker Cura, PrusaSlicer, Simplify3D (I decided it was worth $150), and other free slicers. I’d recommend Ultimaker Cura as that’s going to be closest to CuraLE.

In each case, I use CuraLE printer settings to configure a custom printer. Most of the printer profile is easy enough to just copy values from CuraLE to the new custom printer. The start and end gcode may need some adjustments because CuraLE has more variables (enclosed in {}) than other slicers (and Simplify3D uses [] instead).

After you pick an alternate slicer and get started creating a custom printer profile, ask here if you have specific questions.

The splash screen will load with the green octopus and then just go away. Almost like a direct x crash on a video game or something. Similar to a driver issue. Must be a conflict with windows.

And the problem is software availability, the problem is getting my printer to communicate with the software. I dont have the specs or profiles of my printer so it wont communicate with ultimaker/prusa.

Where can i find the profile for the lulzbot mini? I dont have the gcode. I cant open the software to copy anything. Everytime i google it i just get forums with nothing objective.

Here are screenshots of the Machine Settings for a LulzBot Mini from CuraLE 3.6.36:


Here are the Start Gcode and End Gcode as text files:

Mini-StartGcode.gcode (2.9 KB)
Mini-EndGcode.gcode (1.1 KB)

Use this information to create a custom printer in either Ultimaker Cura or PrusaSlicer.

Awesome! Ill give it a go. If you dont hear back from me it was a success!

SO i have added the gcode but i cant even get the printer to register as connected. It appears in my device manager just cura isnt picking it up. I cant control or connect anything at all. Do i have to upload firmware or anything? I dont even see an option to select com portsin ultimaker.

Also the xmin/max arent allowed to be set as it only wants negative numbers.

I suggest starting with something simple like Pronterface. If your printer cannot be seen by that, then it probably cannot be seen by Ultimaker Cura (or PrusaSlicer or CuraLE).

I’m not sure I understand the “xmin/max” statement. Perhaps a screenshot would help explain the issue better.

In lulzbot software, in the image you posted, the xy/min are positive numbers. In ultimaker cura, it does not accept positive numbers. Only negative numbers are able to be entered. I also have multiple 3d printers (that are off) so i feel like i would need an ability to manually select some ports.

Ill install ponterface and see what thats about.

The Printhead Settings define a box relative to the nozzle that comprises the heater block (and anything else) that would interfere with a existing print when you have selected “One at a Time” printing. If it won’t take positive numbers, use negative numbers.

Pronterface allows selecting the port.

Unfortunately, Cura (both Ultimaker and CuraLE) depend on autoconfiguration to find the correct port.

For my LulzBot TAZ 6, I use OctoPrint running on a Raspberry Pi (using OctoPi which is a pre-built OS with OctoPrint already installed). Windows is flakey enough running one printer so I wouldn’t want to run multiple printers directly connected to it. Using multiple RPi systems, one for each printer is the recommended configuration. Raspberry Pi Zero 2 systems are fairly cheap (when the supply problems are resolved) so having one for each printer won’t break the bank.

Im going to fresh install windows on one of my spare laptops and try everything from scratch to get LE working again. Maybe all this switching around broke something. but i still dont understand why it wont work on my other device either.

Is there a linux alternative to octoprint (or is it linux)? Can i install octoprint on a traditional PC?

OctoPrint is a application written primarily in Python 3. It can be installed on any system including a traditional PC as long as there is a version of Python 3 available. You will find setup guides for many operating systems at https://community.octoprint.org/docs. The most popular installation uses a Raspberry Pi with OctoPi, a variant of the Raspberry Pi OS (which is a derivative of Debian Linux) with OctoPrint pre-installed.