Cura won't run on Ubuntu 18.04 wrong GLIBC required

I have a fresh install of 18.04. Cura installs but when I try to open it I get the following error:
/usr/share/cura-lulzbot/cura-lulzbot: /lib/x86_64-linux-gnu/ version `GLIBC_2.28’ not found (required by /usr/share/cura-lulzbot/cura-lulzbot)

output of ldd --version:

ldd --version
ldd (Ubuntu GLIBC 2.27-3ubuntu1) 2.27
Copyright © 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
Written by Roland McGrath and Ulrich Drepper.

You can see that the required library is 2.28 but Ubuntu 18.04 has 2.27. I have updated the OS

Try installing this version: and use the instructions here to install:

Once downloaded, in a terminal navigate to the directory containing the file and send the following command:

sudo dpkg -i cura-lulzbot-version.deb


If that version works for you, great! If not, reach out to the support team at and they'll be able to help.

I have the exact same problem. It seems like the Ubuntu version was built against the wrong library version.

I would rebuild from source, which should resolve the problem, but I can’t seem to find the source anywhere.

Am I the only one with this problem? I can’t seem to get it fixed on my own.

I’ve tried installing an earlier version of cura-lulzbot (3.6.3) and I get the same error.

I’ve tried downloading and building from source, including (I hope) all of the dependencies, but I get a Python error:

Traceback (most recent call last):
File “/usr/local/bin/cura-lulzbot”, line 10, in
from UM.Platform import Platform
ModuleNotFoundError: No module named ‘UM’

I’m pretty sure this is a basic Python error, but since I know next to nothing about Python, I don’t know how to fix it. I was not able to find a comprehensive set of build instructions, so I had to fumble my way through, and I have no idea if everything got built and installed correctly.

For the record, here are the dependencies I’ve installed:

I sure would like to get this fixed, since my printer is sitting here gathering dust.

Reach out to the support team if you haven’t already at We’ll also note this in a related ticket on our code tracker:

I’ve been able to successfully launch Cura LE on Ubuntu 18.04 by doing a local build to get around the dependency issue. Here’s the instructions to do so if you wish to try it yourself:

Install build libraries and dependencies

sudo apt-get install python libsm-dev libxi-dev libfontconfig1-dev libbsd-dev libxdmcp-dev libxcb1-dev libgl1-mesa-dev libgcrypt20-dev liblz4-dev liblzma-dev libselinux1-dev libsystemd-dev libdbus-1-dev libstdc++-6-dev libglib2.0-dev libc6-dev libssl1.0-dev libtinfo-dev libreadline-dev libharfbuzz-dev libxkbcommon-dev gfortran gcc uuid-dev git wget curl cmake build-essential

Setup project directories

mkdir Projects && mkdir Projects/cura

cd into our cura directory

cd Projects/cura/

Clone into repo

git clone build-master

Create folders for build

mkdir build-master/build && cd build-master

Run the build script. Go ahead and put that casserole in the oven - this could take about 90 minutes.


Install the freshly-generated DEB package. Replace 3.6.15 with your version if different.

cd && sudo dpkg -i Projects/cura/build-master/build/cura-lulzbot-3.6.15-Linux.deb

Have you been able to do this again, recently (9/27/19)? just made the attempt and at 12% returned

Cloning into ‘PythonAppDirs’…
fatal: unable to access '>> ': The requested URL returned error: 500


I did a fresh install of 18.04.3 last night and was able to build Cura LE 3.6.21 using the above steps. Am I correct to assume you got that error when running “./”?
I know there was some maintenance on on 09-27 - it may be worth another try.