Dependency issues installing Cura-Lulzbot on Ubuntu 20.04

I am trying to install Cura-Lulzbot 3.2.21 on Ubuntu 20.04 (actually Pop! OS 20.04 but also tried on Ubuntu 20.04, 18.04 and KDE Neon) and the installer requires older versions of packages.

The dependencies I encountered were

  1. libgl1-mesa-glx (just wasn’t installed)
  2. libquadmath0 (wasn’t installed)
  3. libssl1.0.2 or libssl1.0.0 (libssl1.1 in repositories)
  4. libtinfo5 (libtinfo6 available)
  5. libreadline6 or libreadline7 (libreadline8 available)
  6. libgfortran3 (libgfortran5 available)

To Lulzbot’s credit the installer does list only up to Disco (19.04) and does not have Focal (20.04) listed. I don’t have the libraries listed missing for 18.04 (Bionic) which IS listed for the installer.

The only thing I haven’t done yet is to try 18.04.00 or download the libraries manually.

Fedora has it right. They have it in their package so you just sudo dnf install cura-lulzbot to install it.

I think using a flatpak or snap would solve a lot of issues here because it would contain the EXACT version needed and not care what is in the repositories. Of course that’s easy for me to say, I don’t know how to package these.

My recommendation would be the grab the missing dependencies and install them. We will be working on improvements in the future.

For anybody coming along this thread, I found links for different architectures for the missing dependencies. I don’t know if there is an easier or better way to install them, or through apt, nor do I know if they cause any conflicts (I’m kinda wading into new territory here).

These are in the repositories and do not have a particular version required:

  • libgl1-mesa-glx
  • libquadmath0

should be installed with just
sudo apt install libgl1-mesa-glx libquadmath0

The others I found these links that look like they enable downloading for different architectures. Chances are be using amd64, (Intel-based 64bit) so be careful to not grab arm64, which is right next to it in the list.

Ubuntu name and nubers: Xenial (16.04LTS), Bionic (18.04LTS), Eoan (19.10), Focal (20.04LTS), Groovy (20.10)

Should I use Focal for my Ubuntu 20.04 Studio version?

Even trying these dependencies it didn’t work. I ended up installing Fedora for now, and have Windows 10 as a backup.

sounds like they want to get it all worked out this fall. They have been bought out or changing hands so management will be in flux for a bit. I wish they would pursue the Ubuntu 20.04 fix quickly

I would hope that they would utilize Flatpak or Snap for this since that technology should address these dependency errors AND actually open it up to other distributions (openSUSE, Arch, etc.) that are currently not supported. Plus it would consolidate to one codebase to maintain.

Personally I don’t care if it is Snaps or Flatpak because I’ll work with either one. I run Ubuntu or Pop! OS usually but that doesn’t mean I’m wedded on Snaps. The only thing I don’t know is if the extra permissions step Ubuntu has to do

sudo usermod -a -G tty $USER
sudo usermod -a -G dialout $USER

would be an issue.

I think I would prefer Flatpak only because I think that is more agnostic of the two. I’ve heard Snap doesn’t always work well with non-Ubuntu distributions and use of the Lulzbot printers is more than just one distribution.

Is the source code available? I think Cura is but what about the Lulzbot component?

I was under the impression the source code is but, I have never checked. Support has begun to be more responsive although I have a really annoying homing issue that they have not really resolved for me.
the y axis lands 12mm further into the build plate than it should in the home position.
Perhaps it is due to the fact I have an older machine (Taz 5 with Dual Extruder V3)
Otherwise I do have loyalty to this brand and I hope they can evolve into something even better and more responsive soon.

disclaimer: I’ve only been working with Linux for a year. figuring it out one day at a time. I’m not an expert, let alone knowledgeable.

I was able to compile from source by following this thread:

currently have curaLE v3.6.22 running on ubuntu18.04. Only caveat is I run it via “sudo cura-lulzbot”. like I said, noob.
did it 9 months back and doubt I remember much of how I stumbled through it all so I doubt I’d be helpful anymore. sorry, but I do hope this helps you out even a little.