Dual Extruder problems on TAZ 6

We recently acquired a new Lulzbot Taz 6 and after working with the single head extruder we decided to give the dual extruder a try and have run into some issues and need help. One of the issues we ran into I have figured out with the initial layer printing to thin so I adjusted the z height for the initial layer from 1.5 to 1.1 but the I’m still having other issues I can’t seem to pin down solutions to…

  1. When the head finishes the auto leveling process the is sitting idle waiting for the bed to finish heating so it can start the T1(front) nozzle will pull the filament down till it extrudes a 9 to 10 inch strand of material onto the table and in the way of the bed track then retract the filament a little bit

  2. When I try to print with only 1 color it completely skips the bed leveling process and then just starts trying to print to where the last z height it was left at (usually a few inches off the bed)

  3. I notice that while the first centimeter of the print works fine after that the hot ends seem to be to close to the print and it seems to be touching the previous layer it laid down and leaves melted tracks through the material (it’s almost as if as it gets higher the head isn’t going up the z axis at the same height as it was when it was closer to the bed.

Right now these are the main issues I am running into and any help that I could get would be appreciated, Thanks.

Sounds like your just about the same place on the learning curve as me!

I’ve installed the dual extruder and made some successful prints, but noticed similar behaviour.

  1. After seeing the T1 nozzle do this a couple of times, I realized that there is some sense to it. The T0 nozzle prints the skirt around the first layer of the print, which purges the nozzle to ensure it’s clean for the start of the print’s first layer. Since the T1 nozzle is not used for the skirt, this step acts to purge T1 for a clean start.

  2. I also noticed this. It appears that you need to force a different start and end gcode if only one nozzle used, per this thread;


I’m going to try this tonight or tomorrow, will report back.

3. I haven’t noticed this problem but admittedly haven’t tried many print jobs that run to that height since installing the dually.

I appreciate the response, I understand the need for purging T1 nozzle but as it prints a goo guard and I also usually have the primer tower on too there should be no need for it also it is spitting all the material out in a place where it would get in the way of the bed moving. I look forward to hearing from you about the gcode solution, my boss wanted to print something else so I switched back to the single head for the time being. The stuff I was printing where the over melting seems to happen isn’t that tall (maybe an 1/2 inch) and I also noticed while printing one design that when toy T1 nozzle stops to switch to the T0 it sits over the place it stopped to retract the filament up long enough to melt a divot into the plastic messing up every layer after that then repeating the process in that same spot, I was able to fix it by speeding up the filament retraction and putting the delay on when it would switch the heads.
When we first got the single head it worked great straight out of the box so the dual head has been a bit of an aggravation and I have really been forced to learn on the fly how to manipulate the settings to get a decent print.

Definitely agree that the trial and error process for the dual extruder was longer and more frustrating than I’d hoped it would be!

I did get a chance to check into the gcode setup last night. The following assumes you are using Cura for your slicing software …

To access the gcode info, you need to have your printing set to “full settings” under the Expert menu. Once you’ve selected this, there will be four tabs across the top --> Basic…Advanced…Plugins…Start/End-GCode. Selecting the Start/End-GCode tab, you will see two frames. A list of available gcode files at top, and the gcode listing for the selected file at bottom.

The Lulzbot version of Cura only populates two of these files when you select a dual extruder - start2.gcode and stop2.gcode. These are the files that are sent to the printer at the start and finish of a 2-extruder print, and they are only used if you have merged two stl files to get a green and red object in the model space.

There are two other files - start.gcode and stop.gcode - which are used if executing a single extruder print with the dual extruder installed. By default, these two files are empty. This seems odd to me, as if the programmers didn’t think that maybe people won’t use the dual extruder for single colour prints?

Anyway, what I did was a copy and paste of the complete start2.gcode into start.gcode, then edited the new start.gcode to delete all steps using T1 - heating, priming, etc. Worked first try!! I did the same for the stop.gcode, but did not edit because this file is mostly about retracting the bed and cooling it before presenting it forward again. These files are very well commented, so easy enough to figure out what to remove or edit as needed.

If you don’t like the T1 purging as it does, this file is where you’ll do it. In the start2.gcode, look for the following lines;

G1 E0 F100

This is the line that extrudes 10.0 mm of filament to prime the nozzle. If you want to experiment, you can reduce the number F100 or remove the line completely. I’ll probably keep the priming in the sequence, but set it to use a lot less filament at this step.

Hard to be sure of exactly what the problem is, but I would very carefully check and re-check the levelling as this could mean that T1 is just slightly lower than T0. After several bad prints, I found a technique for levelling that worked for me. I purposely set T1 slightly high, then moved Z axis close to the print bed. Once I was close, I made 0.1 mm moves very slowly until the T0 nozzle just barely contacted the bed. Move up 0.1 mm from there, then adjust level. With the nozzles this close to the bed, I could see how close each nozzle tip was and adjust.

Then, once I got it looking level, home all and re-do to make sure it’s still level. If not, do the same again. Took me maybe 4-5 iterations to get it bang on, and both nozzles contact the clean bed at the same time.

Hey gang, I’m new to the Taz 6 and 3d printing in general, but I’d like to do something similar where I just use the T0 nozzle for printing and not even bother with T1. When I try both nozzles heat no matter what. I’ve tried other things, changing various code options (don’t know what I’m doing), but they all ended in failure. I’m not familiar with coding, but from what I understand from this thread: https://forum.lulzbot.com/t/use-only-one-extruder-of-dual-extruder-v2/3618/1 . There’s a specific start and end gcode that I need to use if I only want to print with the T0 nozzle. Can anyone enlighten me as to what the start and end code should be for this :question: