"echo: too long extrusion prevented" problem on Taz 5

Hi everyone,

I just attempted a large print job (13 hours) last night on my Taz 5, and everything seemed fine when I left. But this morning, I found that the print had stopped halfway and there was an error “echo: too long extrusion prevented” on the CURA control panel. I’ve attached a screenshot of the error.


The filament is PC-ABS from Proto-Pasta and the temperatures are 280C for the hot end and 120C for the bed. Turns out that the filament was not spooling off the reel properly, and some filament got caught under each other. Thankfully after some fixing, the extruder still works! But I’m still not sure what the “too long extrusion prevented” error message was referring to? Is there a sensor in the hot end that knows that material isn’t coming out?



Also, does anyone know what are the recommended settings for printing with PC-ABS? I can’t find the profile for PC-ABS in quickprint.


I tried to search the forum, but can’t because of the message below, so any help is appreciated! :smiley:

The following words in your search query were ignored because they are too common words: abs pc.
You must specify at least one word to search for. Each word must consist of at least 3 characters and must not contain more than 14 characters excluding wildcards.

Indeed, the search function is not very helpful sometimes… In such cases, I use Google. Just enter: “abs pc site:https://forum.lulzbot.com:wink:

For your error message, this is a safty function in Marlin. If there is an E-value ( G1 E…) in your gcode that wants to extrude more than “length of you bed” + “depth of your bed” this extrusion is prevented. Maybe a mistake of Cura with gcode creation? What does your object look like?

Posting the gcode could help narrow in on what went wrong. Does seem to be a slicing problem right now.

And there is no filament detection sensor in the Taz, though that would be pretty awesome to have :slight_smile:

I’m working on it!