First ABS print not starting properly - first layer partly thin and blotchy

I’ve just got a new Amazon Warehouse deal Lulzbot Mini, and have successfully downloaded and connected Cura 2.6.52 to drive it from my Windows 10 laptop.

It’s my second 3D printer, but I didn’t use my first one much (a Velleman K8200) so I’ve some but limited experience. And no previous experience of Cura in any version - I used Repetier Host for the Velleman.

This version of the Cura software looks very different from the enclosed printed User Guide, and also the downloadable user guide on the website - maybe it will be updated soon?

However, in spite of that, I’ve successfully printed the test Rocktopus in PLA, and also a prototype of my own design - a food can cover for small cans (cans with 67mm OD) also in PLA. I printed them both at the medium speed and standard quality profile setting.

Both had problems starting properly, but at the second or third attempt I got good results from both. First attempts seemed to print as if the model wasn’t level on the bed in the software - the second Rocktopus ‘foot’ printed completely in the air, and didn’t stick to the bed. And the Mini didn’t draw a perimeter around it, until my later successful print. I aborted those prints at about layer 4 or 5.

In both cases, the successful print had an even and complete perimeter and first layer, so I don’t think the bed is mechanically too far off-level, and the Mini went through its automatic nozzle wiping and levelling routine first time both for the PLA prints and my latest attempts with ABS.

I’m now trying my first print in ABS filament from Rigid Inks. That particular filament isn’t listed in Cura, but I chose another ABS filament Material setting ABS (IC3D) without being able to see what its settings actually are - they don’t seem to display in the Print Monitor view. Recommended temperatures for the Rigid Inks ABS are hot-end 230-250°C and bed 90-95°C. [I’ve just worked out how to view the settings - see later.]

I’ve now tried three times, and get the same results each time. The left quadrant of the perimeter, and of the first layer of the can cover, are too thin, and blotchy. I attach an image of the latest attempt (the first two were virtually identical). I aborted the print, since it wouldn’t have been satisfactory.

I’ve checked that my can cover model is drawn level, and with its bottom flat on the x-y plane in Sketchup, from which I exported to STL.

I checked that Cura says the model is located at x=0, y=0, z=0.

I set this to print at high quality. Is that the problem compared to the first PLA prints at medium quality?

All the other settings are the Cura defaults for ABS (IC3D).

What might the problem be, and how can I correct it to get a successful print again?

Is the left hand side of the bed slightly too high, over-squashing the first layer on that side? If so, why, given that it worked fine for the PLA prints?

Is the temperature enough different from the Rigid Inks recommendation to matter (I’ve just worked out how to see the settings for IC3D filament - it has hot end 245°C which is in the Rigid Inks recommended range, and bed 105°C vs 90-95°C). Would that make much of a difference, to explain my failed print?

Is the first layer default setting squashing too much? If so, why is it only in one quadrant, the same one each time I’ve tried?

I think I’ll try again at medium quality settings while waiting for a response here.

Any help would be welcome.

I had hoped to print a few more things over Christmas, but until I understand better why this is happening, I may not be able to.

The new firmware and start scripts packaged with 2.6.52 don’t work perfectly together. One of the problems is “printing in air” on the second/successive prints without power resetting the printer. There are some more subtle leveling issues as well, and that might be contributing to what you’re seeing.

For a good starting point, I recommend trying Cura 2.6.64 and the firmware packaged with it. This is still a “development” version, but is very close to release and has fixed quite a few bugs. You can find/download it here:

After starting the new version, I recommend going to “Settings, Printers, Manage Printers…”, Delete and Re-Add the “Lulzbot Mini” printer. This will ensure you get the latest start/end gcode scripts and printer volume settings (these have changed since 2.6.52). The software should also prompt you to update firmware – do that and it should update firmware to

Now try another print – the Rocktopus in ABS is as good a test as any. Watch the washers during the “probing” sequence – it is OK if you see a slight downward deflection on the “first touch” of a washer, but you shouldn’t see any deflection on the “second touch” of the washer. If the washer deflects downward at all on the second touch, it will adversely affect the leveling matrix – I would stop the print, manually clean the nozzle, and try again.

Give all that a try. The “blotchy” results in your photo look like the nozzle is too close to the bed, preventing extrusion. If you still have that issue when using Cura 2.6.64 and firmware, and no washer deflections during probe… Then it can be fixed by changing the printer’s Z-offset slightly. The default z-offset is -1.38. Try changing it to -1.28, by going to the Console in Cura and entering the command “M851 Z-1.28” (without the quotes). Then enter command “M500” (without the quotes) to save the new offset to memory. That will cause prints to start with the nozzle 0.10mm further away from the bed.

Or, you could do what I did – revert back to the original Cura software. I did try the new Cura 2 – but IMO, it’s just not ready yet.

The original Cura software can be found here:

Thinking back to when I first started with 3D printing – there was enough of a learning curve to climb WITHOUT having to deal with broken software and firmware… so I’d strongly suggest just reverting to a known-good, solid, stable release of Cura, and struggle, er, I mean, learn with Cura 2 once it gets a bit more mature.

Edited to add: I am using Cura 21.08 with the firmware from the newer Cura 2 – and it’s working ok for me. But if you do decide to revert the firmware as well, please note that you’ll have to manually extract the current esteps value, and z-offset value, before you reflash the firmware, and then restore those values manually. The flashing process does NOT save those values for you, as I discovered. (On the other hand, having lost those values, I was forced to re-calibrate the esteps and the z-offset, and as a result the printer ended up working better than it did when I first bought it – so it’s all good.)

@mwester – Can’t argue about the state of Cura2. I’ve run into a lot of bugs, but I’m trying to persevere because it also has some really nice new features. Love the Cubic infill, for example.

Beware that using the new firmware (1.1.5.x) with the old start Gcode from earlier Cura 21.xx WILL lead to problems. One of the biggest happens when starting a second print, without power-reset of the printer. This happens because 1.1.5.x doesn’t clear the leveling matrix during G28 and treats endstops differently, and the Cura21 start gcode has vertical moves while endstops are triggered. The main symptom of this is starting a second print (without power reset), and seeing the nozzle cleaning operation occur about 8mm above the wiper pad; subsequent leveling may then fail because nozzle is dirty or nozzle is too high at start of probe. There are other more subtle issues, caused by a shifting of coordinate space when G29 moves to endstops.

The Cura 2.6.64 start gcode has some small fixes to avoid those issues. It moves away from endstops after G28, before making any vertical moves, and moves to X5 instead of X0 after G29 to avoid crashing the endstop if coordinates shifted during G29. If you are using the 1.1.5.x firmware with Cura21, I highly recommend you take a look at the start Gcode with 2.6.64 and incorporate those items.

Wow. Thanks for such prompt and helpful replies.

It’s 2am here now, so i’ll review these suggestions again during tomorrow, and see whether I should revert to an older version of Cura that matches the manual, or try the newest version of Cura 2.

I don’t quite know what this means, let alone how to do it.

Could you point me to a link describing how to do what you suggest, please?

If you haven’t set custom E-steps or Z-offset (and I’m sure you haven’t, because you just got the printer), then you don’t need to worry about this.

If you had previously set custom values for these, you could get them with a “M503” command, and then restore them after flashing new firmware.

I’ve downloaded and installed the v2.6.64 Cura program, and updated the firmware ‘automatically’.

The only thing suggested that I couln’t do was remove then reinstate the printer - the Remove option remained greyed out, even after I disconnected the printer.

It’s now working pretty well. The only problems at the start were that after wiping, the print nozzle dribbled about 8-10 mm of filament while waiting for nozzle and bed to heat up, so there was a loose strand before the start of the skirt, and another dribble carried round several times with the skirt and first layer of the can cover. I paused the print, removed the short string, and let it carry on.

It’s looking good at this point. Print has just finished. Waiting for it to cool before attempting removal.

And when I do remove it a few minutes later, it lifted off easily and cleanly - unlike the previous print which had stuck very firmly, and was extremely difficult to remove.

Thank you to all who helped get me on the right track.



Glad to hear you are up & running!

My instructions for deleting/adding a printer were not clear… You can’t delete the “active” printer, and since you have only one it is always “active”. You will need to add another copy of the same printer (it will show up as “Lulzbot Mini #2”), and then select and delete the old one. You can then rename “Lulzbot Mini #2” to just “Lulzbot Mini”.

Doing that will make sure you have the latest printer definition with updated start/end scripts.

Happy Christmas!

Thanks for the clarification. I’ll try that later today or tomorrow.

After a couple of successful prints each started while the printer ‘was hot’ - and a previous print had just finished - I’ve run into the same problem again printing some filament clips.

The first layer started too low, and is again squashed and blotchy.

I’ve let the print run on, and I can cut off the bottom layer, as the object has all vertical sides.

No I can’t. The rest of the print is horrible - perhaps the nozzle has a blob around it?

But why the inconsistency? Has previously worked fine, now doesn’t, and I haven’t changed any settings, as far as I know.

Trying again from a ‘warm start’ without switching the printer off between attempts.

That works fine.

So what’s different about a ‘cold start’? Something in the firmware? Start code? Something else?

Did you watch the leveling process at the beginning of each print? Did you see any downward deflection as the nozzle touched the washers?

If the nozzle is a little dirty, and deflects the washers downward (but still makes contact before triggering rewipe), then the firmware will calculate the bed position lower than it actually is – leading to the nozzle being too close to the bed. This can lead to some prints working just fine (no washer deflection during probing) and others being too close to bed (washers deflected during probing).

A Z-offset that is too close could be the culprit if your first layer height is smaller on some prints than others. It won’t hurt anything to try changing the Z-offset a little; I’ve always found the default -1.38 is a little too close to the bed. Go to the console and issue the command “M851 Z-1.28” (without the quotes), then “M500” (without the quotes). This will start the nozzle 0.10 further from the bed on the next print.

Try those tips (watch the probing to make sure no washers deflect downward, and change Z-offset to -1.28), hopefully that will help.

Thank you for the advice - I’ll try it on the next cold print. I didn’t watch the previous one closely. Maybe the nozzle got a little dirty and didn’t wipe clean? It only took one wipe, I did notice that.

Does the code you suggest make a permanent change in the starting Z-level? Or do I have to repeat it every time?

If the latter, is there another way to make the change permanent (until the next firmware update, at least)?

The “M851 Z-1.28” sets the current Z-offset value to -1.28. By itself, that change would disappear the next time the firmware reboots (i.e., power cycle or connect).

The “M500” saves current settings to memory, which is semi-permanent. It will stay that way until you change it again – or until you upgrade firmware. Newer firmware can sometimes use the existing values, other times it cannot and resets everything to the new firwmare’s default values.

You can see current values using the M503 command. The two values most frequently customized are Z-Offset and E-Steps. The E-steps value controls the extrusion rate, default is 833, and you’ll see that near the top of the M503 command’s output as part of the M92 line. The Z-offset is reported near the bottom of the M503 output, on the M851 line.

If you ever want to go back to “factory defaults”, you can do that with M502 (followed by M500 to save them to memory).

Blotchy and thin first layers can be uneven bed-level too. Usually the nozzle is too close to the bed. Make sure to clean the metal discs also… also try changing or flipping the wiper pad to help with cleaning of the nozzle.

What layer height are you printing at? A lower layer height .1 or .15 will also create thin and blotchy first layers. In the case of low layer heights, the print will recover as it progresses taller… Just be patient. If the first layer is removed from the bed by the nozzle, then its definitely a bed level issue.

Good point. I didn’t mention that, because he appears to be using the built-in Cura profiles – and they all have “first layer height” at 0.425. Even their “high detail” profile (0.18 layer height) uses 0.425 for first layer to minimize issues with bed height/level.

@johnwmcc - Double-check the “first layer height” to make sure it is still set to 0.425 in the profile(s) you are using.

I’ve had a number of successful prints now.

I am pretty sure the bed is level, and the washers are clean.

But I sometimes notice that the placement of a new model shows a Z value of -1 in the window where one can view the model (I don’t know the proper name for it). That’s the result of the Open File command.

I’ve no idea where this value comes from. If I choose the Move command, and set it back to zero, that seems to start the print at the correct level.

I’m still having some trouble with the nozzle being slow to prime, or occasionally going the other way - starting a small dribble just before the nozzle moves over the print bed and trailing a thing string. But on the whole, I’m getting better at anticipating this, and picking the string off before the print gets fully underway.

And I was seriously impressed when I printed an M22 male thread to mount a small and cheap (£20) Cleverdog WiFi camera on the printer - it came out perfectly, and fits the camera mount ‘just right’ with no trimming or fettling. That enables me to monitor progress while not in the same room as the camera, on either my phone or a Windows computer (sadly, no viewer for Mac or Linux, and it doesn’t use a standard IP camera protocol).

Glad to hear things are going better!

I can confirm that Cura2 intermittently positions models at Z-1 in the build visualization when loading them. It is obviously a bug in how it loads and auto-positions the model, but I haven’t spent enough time to determine what triggers it since it doesn’t happen every time. As you have seen, just moving the model a bit usually snaps it up to 0.

Having the model positioned at Z-1 in the visualization doesn’t mean the printer will try to print below the bed. Rather, it means the portion below 0 in the visualization just won’t be printed – it just means that the bottom 1mm of the model won’t be printed at all (it will be “cut off”). That can actually be a useful feature if you want to print only a portion of a model – for example, to test print features at the top of a model without having to print the lower portion.

The dribble can be an indication that the hotend is too hot for the filament… but its not the end of the world as you’ve found out. :slight_smile:

Continue to use a skirt/brim or other Gcode script to prime the nozzle just before the actual print. Printing the first layer a little hot helps with adhesion (ABS). If the stringiness continues to be a problem, try lowering extrusion temps by 1-2C.

Extrusion and bed temps can vary by the print environment and filament type/brand. You’ll have to dial in your settings over time.

You’re well on the way to getting things sorted out.