Mini printing problem after software and firmware upgrade

Ages ago, my printer just stopped, and I haven’t had time to follow up for a very long time, or a need to print anything.

See Mini stopped mid-print, and now unresponsive

Well, today I had some time to restart investigating it, and something I now want to print.

So thought I’d start over with a new version of Cura (3.6.23 instead of previous 3.23) and update the firmware.

As recommended, renamed the %appdata%/cura-luzbot folder, and reinstalled both cura and the firmware update for my Mini (v1).

Probably lost the few customizations I’d made, but thought the defaults for ABS (IC3D) plastic would probably be ok. I think I’d adapted it slightly to a cooler printing temperature, but the default was 245 deg hotend, and 110 bed.

And I think I’d slightly adjusted the Z-height.

But the printing is TERRIBLE. It’s extruding far too fast, and not sticking to the heated bed properly.

How do I recover my previous settings, and why are the defaults working so badly?

Took a picture on my phone of the first layer print:

Make sure you flashed the correct firmware for your printer AND printhead combination. For example, if you have the standard print head and flash firmware for Aerostruder (or vice versa), you’ll have really significant extrusion issues.

Next up would be to adjust the Z-offset. I think later versions of Cura provide a way to do that through Cura print menu (not sure, I stopped using Cura a long time ago). But you can also do it interactively via the console in Cura, with the M851 command (and then M500 to save setting).

Sending a M503 should give you a response showing the current M851 setting. The default is probably around -1.30, depending on the firmware. If your first layer is too high, make the value slightly more negative and try again (i.e., if it is “-1.30” and printing too high, try sending “M851 Z-1.35” to move it 0.05 closer to the bed.

Beyond that, posting a video of the first layer would be helpful for further diagnosis.

Sorry for long delayed reply - other things took over in the interim.

I’ll give your suggestions a go today or tomorrow - thank you for your help.

My printer is an unmodified original Mini, with the standard print head. I’ll double check what software and firmware I downloaded, but I don’t off the top of my head think it likely that it was the wrong one.

But I’ll check the key settings.

Where would I look for the extrusion rate, which seems much too high - spewing out very fast, and spreading too far?

You can see the extrusion value (E-Steps) in the output of an M503 command. Send M503 and review the output for a line preceded by “M92”, which will then have step values for X, Y, Z, and E. For example:

echo: M92 X100.50 Y100.50 Z1600.00 E410.00

I believe the firmware default E-step value for the Mini’s original “Standard” extruder is E833.

The firmware default E-step value for the Mini with Aerostruder is E420. (I have an Aerostruder on mine, and have adjusted the step value 410 as shown in example M503 output above).

Also be sure to check the slicer’s extrusion rate – make sure it is at “1” or “100%” (not sure how Cura implements it). An incorrect value there could also cause wild extrusion.

Yes, i believe you lost the custom z height offset AND the extruder esteps settings. You will need to reset those to get back to working order.

After a long lapse I’m trying again to reset the starting values.

With the defaults, I see a response to the M92 command of
X100.50 Y100.50 Z1600.00 E833.00

When I try to Extrude 10 (?mm) I get about 120mm extruded - a factor of 12 too high.

How should I reset the Extrude Steps, and to what value?

And where do I reset the Z-offset value?

PS. I get my first very rough approximation of the correct extrusion with the command M92 E50 when I use the manual setting in Cura “Extrude 50”. That extrudes 72mm of filament.

This is WILDLY different from the recommended default of E833, or even for a different print head of E420.

When I give the printer the command M92 E34, and extrude 50, I get 50 mm output.

And the extrusion is very slow. But the right length.

However, something seems badly out of whack if the E value should be in the hundreds, and it only works with a setting of 34.

Haven’t yet attempted to set the z-offset.

You set the e-steps by how much filament is sucked in, not by what comes out. Yeah, it seems more logical that you should measure what comes out since that should be more important, but that’s not how it works.

The usual procedure is to measure and make marks on the filament going in, then do an extrude, and see if the mark moves by the same amount you asked to extrude. For example, make a mark 120 mm from where the filament enters the tool head, extrude 100 mm, then measure that the mark is 20 mm from entering the tool head.

I knew I must be doing something fundamentally wrong to get such slow extrusion but (as I thought, wrongly) the right extrusion length.

I’ll try to get start over and get it right tomorrow.

But why was it so badly wrong using a new clean install of the latest version of Cura, and the latest firmware, for a totally standard Mini v1?

It was spewing out filament like there was no tomorrow, and way off the build plate.

Yeah, it’s easy to rabbit-hole when you start back up after a break and something is wrong. First, your extruder could easily be extruding 120mm plastic (or more) out of the nozzle given 10mm of filament input. This is because 2.85mm filament is around 30x the cubic volume of plastic per mm as what is extruded by your 0.5mm nozzle. And as @cdsmith pointed out you measure the esteps based on the length of filament going in to verify that your machine is moving that 2.85mm filament at the rate it is set to. It’s the slicer’s job to infer the correct output based on temp, nozzle size, etc.

“Spilling out filament like there was no tomorrow” is totally open to interpretation. If the printer was putting out the same amount of filament in the correct location on the build plate this might not be a problem at all. Be careful assuming it’s over-extruding, because it could just be extruding in the wrong place, which would mean there was something wrong with the motion system or endstops, the slicer is misconfigured, etc.

Have you leveled the printer? When you jog the printhead in cura, is it moving to the correct coordinates? Do you have an older gcode file sliced with the same filament that you know you have printed successfully in the past? Assuming the printer is leveled and the motion/homing seems gtg, I might try printing that successful gcode just to remove the slicer from the big list of variables. If it prints, it would point to a slicer configuration. If it’s still having issues you have narrowed things to firmware (less likely), printer hardware/electronics or filament (more likely).

Finally, ABS is harder to deal with in general, and old filament can do weird stuff. It might be smart to get the printer back online with $15 worth of new filament just to rule out old degraded filament.

Some progress but still dreadful results, after further experiment this afternoon.

I reset the Esteps value back to the default 833, and the Z-offset to -1.3.

Marked the input filament at 20mm, 24mm and 28mm.

Ran Extrude 20mm, and the printer fed about 18mm of full diameter filament (~3mm or maybe 2.85mm). Ran a small test print, a 10mmx10mm square, 2mm thick, with a skirt 3mm outside the print. I had the minimum skirt length too long in retrospect.

First brim outer line came out quite squashed, and far too wide, with successive lines piling up thickly on top. I aborted the print, which looked like this:

Ran further prints gradually making the Z-offset more negative, from -1.3 to -1.45, which helped, but there’s still too much filament extruding.

I also reduced the Esteps value from the original 833 to an alternative suggested above of about half that: 410.

Saved all these changes with M500 command in the console.

There was also a significant ooze of filament from the nozzle while waiting for the hot end to reach operating temperature (which for all 3 default ABS materials is 240deg C). So I created a custom material and reduced the hot end temperature drastically to 225C.

In combination those improved things from an aborted messy blob to a fuzzy and still over-extruded but now separate brim and test piece which I allowed to run to completion.

But even this print with reduced temperature and Esteps and largest (negative) Z-offset of -1.45 is a mess.

What else can I do to get the printer working properly again?

In the hope it might help, I’ve added below the output from running the M503 command. I think it shows all or most of the current settings, and hope it will help in diagnosing what’s wrong.

I’ve had good results in the past , and hope to get it as good or better in the future, but don’t know what else to try.

[15:42:48] M503

< [15:42:50] echo: G21 ; (mm)

< [15:42:50]

< [15:42:50] echo:Filament settings: Disabled

< [15:42:50] echo: M200 D3.00

< [15:42:50] echo: M200 D0

< [15:42:50] echo:Steps per unit:

< [15:42:50] echo: M92 X100.50 Y100.50 Z1600.00 E410.00

< [15:42:50] echo:Maximum feedrates (units/s):

< [15:42:50] echo: M203 X300.00 Y300.00 Z8.00 E40.00

< [15:42:50] echo:Maximum Acceleration (units/s2):

< [15:42:50] echo: M201 X9000 Y9000 Z100 E1000

< [15:42:50] echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>

< [15:42:50] echo: M204 P2000.00 R3000.00 T2000.00

< [15:42:50] echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>

< [15:42:50] echo: M205 B20000 S0.00 T0.00 X12.00 Y12.00 Z0.40 E10.00

< [15:42:50] echo:Home offset:

< [15:42:50] echo: M206 X0.00 Y0.00 Z0.00

< [15:42:50] echo:Auto Bed Leveling:

< [15:42:50] echo: M420 S0

< [15:42:50] echo:PID settings:

< [15:42:50] echo: M301 P28.79 I1.91 D108.51

< [15:42:50] echo: M304 P294.00 I65.00 D382.00

< [15:42:50] echo:Z-Probe Offset (mm):

< [15:42:50] echo: M851 Z-1.40

< [15:42:50] echo:Linear Advance:

< [15:42:50] echo: M900 K0.00

< [15:42:50] echo:Stepper motor currents:

< [15:42:50] echo: M907 X1300 Z1630 E1250

Can you attach a gcode that you are trying to print to this thread? This may provide a little insight into what may be happening.

Can you send the M115 command to the printer as well and post the results.

I am guessing the gcode flavor in your Cura got changed to Marlin(Volumetric) by accident.
It should just be Marlin. This can be adjusted by going to settings>printers>Manage printers and clicking machine settings. Then change gcode flavor to Marlin.

1 Like

Thank you for such a quick response. May be busy this evening, but will try your suggestions ASAP.

The setting WAS Marlin (Volumetric), and when I changed it to Marlin things improved significantly.

Why was that the default?

I found I still had E-steps set at the wrong reduced value of 410, with the result that the print was ‘under filled’.

When I reset that to the default E833, I got a very good print by comparison with all recent previous attempts, though I think the Z-offset is still not large enough. I’ve reset that to -1.5, and printing again.

It’s now printed the test piece pretty well - probably as well as ever.

And I’ve now printed the part I wanted recently to re-print.

THANK YOU, to all who helped.

1 Like

A further concern, after I thought I’d got the settings sorted.

The brim and first layer print of another larger model seems squashed too thin. I’ve tried z-offsets of -1.5, -1.4,and -1.25, and it makes no visible difference.

I’ve changed the value using M851 Z-1.25 ( for the latest value) and made it permanent with M500, and it’s still printing too thin and squashed.

Like this

I’ve also checked that the .stl file has its bottom surface at z=0.

I’ve measured the brim thickness with vernier callipers and it stays at 0.18-0.19mm regardless of the z-offset setting, rather than getting thicker as the z-offset gets closer to zero. And the width is about 1.4mm. So too thin and squashed too wide.

Should I just keep trying numerically smaller negative values of the z-offset - like -1.0 for a further trial? The default is -1.35 I think, so I wonder how far from that I should deviate.

When the startup levelling process runs, I hear a sound I don’t remember earlier. After the nozzle descends for the second time to touch the corner washer, I hear a ticking sound as the z-screw winds the nozzle up slowly, presumably sensing when it disconnects from the corner washer and works out the z-height at which that happens. Is that sound normal?

Any suggestions for what to try next?

Well, I did some further experiment yesterday, with eventually satisfactory results. I settled on a Z-offset of -1.10 and an extrude temperature, which I set in a Custom ABS material, of 235C.

But today, with no change in the settings, my prints have a squashed first layer again (but the Z-offset is still -1.10 - I checked using the M851 command in the Cura Console).

And although I set the custom material extrude temperature at 235C, the nozzle is defaulting to heating to 250C. Even yesterday, it seemed to be adding 5 or 10C to the temperature I put in the Material settings.

I can (and have) reset the extrude temperature, once the print has started, using the Select temperature and Heat Extruder temperature override in the Cura settings.

But what’s happening here?

And after the initial few layers, it seems to be trying to print very fast when doing the infill and traversing without printing, rattling and shaking very noisily, and producing quite a rough top layer.

When laying down perimeter filament, though, it is running smoothly, though still (as normal, I think) not so fast as the first layer or two.

I’m almost beginning to wonder if something has rattled slightly loose somewhere - is that likely?