Horus Installation > Check: Wrong Camera ID Error

I stumbled on an interesting Wrong Camera error in Horus. The solution ended up being almost embarrassingly simple, but I’ll try to document it thoroughly, because why not?

Note: I am operating a personal computer, which is a MacBook Air (11-inch, Late 2010) with Mac OS X Yosemite (10.10.5). I just downloaded the latest version of Horus from bq (Version, Build 259, GitHub 38df73b).

:question: Horus and FTDI drivers downloaded, Ciclop assembled, everything connected/on, then:

Wrong Camera
You probably have selected the wrong camera. Please select another camera ID

After clicking “Edit Settings”, the following preferences menu pops up (this may have been automatically triggered, I can’t recall exactly):

Based on the error message, I assumed the Camera ID had to change. So, I changed it to “1” in the drop down menu, but this still did not work.

:bulb: To solve this: Inspired by this screen capture in the bq calibration video https://www.youtube.com/watch?v=yCIbQQu2mFk, I set camera ID back to “0”, the default option. Then, under Connection parameters I tried the other Serial name options. All I had to do was change the Serial name to “/dev/tty.usbserial-A402P||1” in the drop down menu (click the downward facing arrow ˅).
Screen Shot 2015-08-22 at 12.39.41 PM.png
You should now be able to proceed with calibration!

_If you make it this far and are able to proceed past the error, but the Horus webcam preview screen still looks dark and calibration is failing… You are not alone! But that is a topic for another post since it has nothing to do with the software. Read more on that here: https://forum.lulzbot.com/t/horus-installation-calibration-failing-with-dark-screen/2158/1

:laughing: Consider me confused. I fired up the Ciclop today with everything plugged in the same way, saw the same Wrong Camera error, but this time I did need to change the Camera ID from 0 to 1. It’s working now. We’ll see what happens the third time I plug it in.