IDE compile error problem

I am trying to load some new firmware on my TAZ 4 for a new hexagon hot end I installed. I have read the Lulzbot documentation and the documentation on this forum for doing the Arduino verify and compile for uploading this software, but I can’t get pass the verify/compile of the code. The following is the error that I get:

C:\Program Files (x86)\Arduino\libraries\Marlin_2015Q1_TAZ5_0/ultralcd.cpp:738: multiple definition of `u8g_dev_st7920_128x64_rrd_buf’
ultralcd.cpp.o:C:\Users\user\AppData\Local\Temp\build7762107252506360423.tmp/ultralcd.cpp:738: first defined here
*collect2.exe: error: ld returned 1 exit status
Error compiling.
*

I have downloaded the Ardunio add-on-files that are needed
I have downloaded the TAZ 5 firmware for the hexagon hot end
I am running version 1.6.5 of IDE
I can compile and upload arduino firmware for other cards with no problem.

I have move these files to the correct libraries, I think???
See the following attachment for screen shots of where the files are located
The first is the Arduino folder where the file is located, it is called Marlin_2015Q1_TAZ5_0
You can also see all supporting folders

The second screen shot is where the file is located and the name of the ardunio file that I am trying to compile.

Any help or direction of where to go next would be greatly appreciated
Ardunio file location screen shots.odt (334 KB)

It is telling you that you have multiple copies of the needed libraries on your machine. You need to find and remove one of them, so the IDE can compile the code.

I did the same thing a couple weeks ago. :blush:

We have recently come up with a more point and click way to re-flash your printers firmware through Cura. Run through this guide and see if it is a little easier.

Also, don’t forget to calibrate that new extruder for the best results.

Thanks for everyones responses, I re-installed IDE and make sure I had only one copy of the supporting files. I can now compile the code. I think I was having problems with too many of the same files names or where my files need to be.

I have one additional question:
I have tried to do changes to the configuration.h file while in IDE and it won’t let me. Says the folder is read only. I have tried to change the folder to read/write without success. So now I copy the file to a new name and different folder, make my change, then delete the original file and copy the change file back where the original was. This works but it would be nicer if I could make the changes from IDE to the file. This is the TAZ 5 hot end firmware file.