Marlin_TAZ45_Uaru_1.0.0.1 Problem compiling

I am trying to do a simple edit to “Configuration.h”. This is the first time I attempt to do changes to the firmware. I am also quite fresh to both Linux and Arduino so I hope someone can help me understand this.
I have a fresh installation of Arduino IDE 1.8.3 on Ubuntu 16.04. I have added the U8glib 1.19.1 library from the library manager.
When compiling I get the following error message:

“In file included from sketch/dogm_lcd_implementation.h:38:0,
from sketch/ultralcd.cpp:75:
sketch/dogm_font_data_marlin.h:12:25: fatal error: utility/u8g.h: No such file or directory
#include <utility/u8g.h>
compilation terminated.
exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.”

My Arduino installation is in: “/usr/local/src” and I find the missing library file is in: “/usr/local/src/arduino-1.8.3/libraries/U8glib/src/clib”

Is “#include<utility/u8g.h>” pointing to folder “utility” which should contains the file “u8g.h”? Can I then simply change the #include statement or move the file “u8g.h” to another folder?

I found the following in a reprap forum:

I changed the code like this in dogm_font_data_marlin.h
//#include utility/u8g.h
#include clib/u8g.h,489503

Thank you for looking at this janajmfa,

This did help me one step ahead, but getting through the first library related issues, there is also errors in the code.
I am not experienced enough to go further into this and I have been in dialog with Lulzbot support for a while now, but they are not willing to help me in this issue.
My conclusion is that the firmware for Taz 5 on Lulzbots server “” is not in working order and Lulzbot can not tell me how to get a stock firmware to compile in Arduino IDE or point me i the direction of any other working firmware (Other than their working .hex).
I have decided to try Sebastians version from the topic: “Latest Firmware for TAZ5 - advanced development version”. There is a tremendous amount of work being put into his version, and a lot of really happy users.

Hey alias I tried it out and was able to reproduce the errors you are seeing. I was also able to upload the firmware without any errors by doing the following: Get this arduino 1.0.5 from here , extract it. Then get the arduino addons from here and extract that. Then move the RAMBo hardware and the U8glib libraries from the arduino addons into the arduino installation folder.

Your file paths might be different, but the basic idea is to move this:


to this:


and move this:


to this:


I think the main issue you are having is the U8glib library is missing from your arduino installation, but it’s nice to have the RAMBo board definition too. Something similar to this might also work in other versions of arduino, but I only tried it in 1.0.5 since it’s a known-good. There might be something to using the executable in the arduino program folder to run arduino rather than using Ubuntu’s APT version, idk.

I’m curious, what are you trying to change in configuration.h?

Thank you for your answer rufu5,

I really appreciate someone from Lulzbot looking at this issue. I have tried your suggestion, with Arduino 1.8.3 and Arduino 1.0.6, but not with Arduino 1.0.5. Since Lulzbot support was not willing to help me get this firmware version to work, I have (for now) given up on the firmware from Lulzbot and downloaded Sebastians version, this version compiles, and I believe I am almost ready to upload it to my printer.

I am building a new heated bed and these are the changes I believe I have to do to the firmware:
-The new silicone heater (230V) might require that I edit the PID-settings.
-The new Y-bed plate might require that I change the physical Y-endstop position, and I guess I must edit Y-travel limits.
-Possibly I am replacing the Y-stepper motor with a 0,9 deg motor and believe I have to edit Y-axis steps per unit.

And this is a change I want to do to the firmware:
-This is a minor issue, but quite annoying. The wheel on the LCD has inconsistent clicks with the menu choices. This is a simple fix according to Thomas Sanladerer in “3D printing guides - Setting up a LCD and SD card controller panel”

For me, this is also about trying to learn about working with Marlin, Arduino and G-code.
I have a few more questions for the forum before i can change the bed and upload the firmware, but I believe a new topic is right for that.

Regards Robert

I can confirm that using Arduino IDE 1.0.5 and following rufu5’s instructions the firmware now compiles.

Thank you for your help rufu5!