Latest marlin firmware for TAZ 5

Awesome!

I’ll build it and try it out tonight!

Are there any changes i need to make in the slicer to account for FW retraction?

Such as using

M208 S-0.05 F180
M207 S1 F1800

Enabled Auto Bed leveling and flashed. Working better than ever. Thanks!

In slic3r, there is a checkbook in the printer tab “use firmware retraction”. I read a post somewhere that also cura is able to do that, but I have not in my mind where it’s hidden.

No other changes are necessary.

Can’t find anything in S3D on it. Apparently it isn’t supported yet. I disabled it via the LCD for now. I have noticed the fan for the rambo runs more frequently and aggressively on this build. Any idea on how to tame it?

If you turn Autoretract to on in the LCD, marlin treats each extruder only move as retract or unrectract. So it’s not absolutly necessary that the slicer supports it. But I have not tested this.

The fan is the only thing that was better with stock firmware, thats true. I think it was temperature-controlled, now it’s only coupled to stepper movement. If the first stepper is engaged, it’s starting, if the last stepper wasn’t moved for x seconds, it’s disabled again. I have not found an option in marlin to changes this behavior. But I was not trying to hard, the fan from the powersupply is 10x louder than the rambo fan, so who cares…

its in Configuration_adv.h

#define EXTRUDER_AUTO_FAN_TEMPERATURE 50

the extruder hotend cooling fan should come on above 50 degrees on either ex for truder. You can change the speed with M106 P10 S??? where ??? is betweeen about 160 and 255. Below 160 the fan won’t start. I meant to measure the voltage but it’s always 0 now :frowning:

I usually update the latest dev firmware to work with a TAZ every few weeks. I can start making a post once I get it working. I also add a Home Z Axis only, change the time out before the LCD returns to the Status screen, change the status screen to display an extra decimal place for the Z axis, and I’m sure I missed a couple of other minor changes I make for my own use. The new Z axis ballscrews were really working well, too, but I may go to a rostock before rebuilding the TAZ.

Thanks for the info. I was referring to the Rambo cooling fan in the case though. It seems to run as described above rather than as before on 2015Q1.

Sebastian, I see there is a new RC3 out for Marlin. Have you had a chance to look through the changelog to see if it’s worth updating?

I’d love to see a forked branch of the Dev 1.1 someone was keeping up to date for the TAZ 5

I’m looking on https://github.com/MarlinFirmware/Marlin/releases from time to time. There, it’s still RC2…

From the readme of RC3:

RC3 - 01 Dec 2015 A number of language sensitive strings have been revised Formatting of the LCD display has been improved to handle negative coordinates better Various compiler-related issues have been corrected

Doesn’t sounds very intresting… There are no compiler issues for the lulzbot config and I don’t need new languages (I’m german, and still using the default english menu. German menu entries always reads very strange if you are used to the english terms :laughing: ).

@Discojon: I just have seen you linked my marlin config on Thingiverse… Time to do an update!

I tried the filament change command a few days ago, there is a bug with the automatic filament change option! The hobbed bolt will eat your filament if you try to use it this way :open_mouth:
Therefore I disabled the autochange-option. If you use the change-command, here is how to change the filament:
.) The head will move to the front left edge of the print bed.
.) Remove the filament as usual.
.) Load the new filament, pushing the rest of the old color out of the nozzle by pushing on the filament itself or close the filament release clamp and turn the extruder gear by hand. The stepper is disabled at this step.
.) After purging all old filament, press the LCD knob. The head now moves to the part and continues printing.

Small Changelog to my last release:

  • Disabled automatic filament change options (see above)
  • Added PETG preheat profile

You may have problems with you settings (PID values and so on) after flashing, thats due to the changed EEPROM layout (added PETG profile). Simply load factory defaults and then choose “Store memory”.
Marlin.rar (964 KB)

Thanks for the update. I personally don’t use that option. I have a script that i manually embed into the gcode to do my color swaps.

I needed this firmware because I am using a #11 thernistor on my extuder and the stock (older) Taz firmware doesn’t define 11. However, now my heatbed is reading about 5c low at ambient. I even tried using another #11 thermistor on the heat bed, changed the bed sensor to #11, reflashed, and it still read 5c low. I was having intermittent problems with the bed sensor, but I thought it was a loose connector.

Is this a problem with my Rambo? What if I wanted to use T3 (instead of T2) on the Rambo for the heated bed. How hard would it be to make that happen? Could that resolve my issue?

Try to flash back to the original fw and see if the error persists. I can’t imagine that this is due to the fw change, as long as you don’t changed to bed sensor accidently.

By the way, it looks like RC4 with a huge amount of bug fixes will be released very soon :slight_smile: I will configure this release for the taz 5 again as soon as it’s available.

I’ll give it a try. Thanks for all the work you do with getting these setup for the Taz. It’s nice to have the latest release for Marlin.

I’m in for RC4 :smiley:

Switching back to stock Taz 2015 firmware corrects the issue! I ended up manually changing the thermistortables.h to use my custom extruder (thermistor 11 doesn’t appear in current stock Taz firmware).

I am using thermistor #7 for the bed (I am using a customized bed also) and it works perfectly with stock 2015 Taz firmware. When I flash to the firmware posted by Sebastion in this thread, none of the thermistor selections work properly for the bed before or after running PID optimization. It reads about 5°C low at ambient and is off by about 15°C at printing temps (100°C). I wonder if there is a bug in Sebastion’s firmware somewhere?

There was some discussion about the thermistor tables a while back on marlin git. Maybe this bug is also in the RC2…
Stock TAZ 5 thermistors should work fine, I have no problems woth them.

Yup that’s probably why few noticed the issue. I switched to an E3Dv6 with a #11 thermistor. Which is not listed in the 2015 Taz 5 firmware. So when I switched to your version, I was able to use #11 and it worked. But then it broke my bed thermistor (#7) which used to work perfectly in the 2015 Taz 5 firmware.

Because I have a hybrid setup… most Taz users won’t see a problem here.