Latest Taz5 Firmware Source

So I recently upgraded both my Taz5’s with BLTouch sensors and while I’ve got them working I’m having problems with some features missing from my printer that worked previously…

Support told me that what they sent me was the most recent source, but that’s obviously incorrect or they have left settings out of it deliberately.

M300 S392 P436 doesn’t make noise anymore, it did prior to changing from factory firmware.
Temperatures were set differently (I’ve corrected this)
And god only knows what else is wrong…

Is there a more current release of the firmware source than:

(Note, I specifically need the flexystruder version as I do not print anything but Semiflex.)

I apologize you were incorrectly linked to an older firmware in our file system on Helpdesk. The Cura 20.01 update, setup for Flexystruder, flash default firmware: has you right where you want to be.


Here is the link to our firmware :

Instructions on how to download and install the firmware are located on that page.

The firmware that was sent to you is indeed the latest version. The BL touch sensor is not offered on our printers so it wont be activated within any of the firmware for the.

I hope this helps,

I’m after the source to that version so I can enable the BLTouch and still be running firmware specifically written for my printers/extruders.

I realize the BLTouch isn’t supported by your firmware, I’m asking for the SOURCE to your current firmware…

What I was linked does compile and print, but it’s absolutely not the same source used to compile what cura installs - the screens beeper doesn’t work and the temperatures are different - I have no way of knowing what other shortcomings exist in this firmware, but it’s obiously not the same.

Source could be here:

OK, I’ve gone to your forums and a local makerspace for help and I’ve gotten farther on this… you guys have source stored pretty much everywhere…

The last firmware I updated from Cura was 2015Q3, and the versions you’ve provided thus far dont’ show that version information anywhere… my digging based on support gathered elsewhere shows me:

What I’ve been provided so far…

Useless, I need source:

Wrong Version, not a flexystruder, AND old version:

Wrong max temps (235) and no beeper (What else is wrong?)

Potential (Provided by Google Groups feedback)

Found this exploring the files here…

This looks like the best match for what I’m after, BUT it’s not Flexystruder centric… if the only difference between the firmware is the materials on the pre-heat menu I don’t care and this likely solves my problem… but if there is other tuning that makes the flexystruder a rock solid solution then I need the 2015Q3 version for the Flexystruder…

Open the Marlin folder under the Flexystruder V2 tag in the middle of the page. I believe the version of Marlin flashes up on the LCD on start up.

Still not the same version of firmware installed by Cura… For a company that speaks to open source so much it certainly is frustrating that the source isn’t available.

I suspect the source is there. Its the same problem with all “open source” projects, finding the right version… :slight_smile: Open source means its published for public domain (which it clearly is).

I don’t use the M300… so I couldn’t care less if its supported (its actually news to me that there’s even a piezo buzzer of any sort on the RAMBO). I rarely use the LCD panel to pre-heat in my workflow, so same goes for that also… As for “god only knows what else is wrong…”, my machine works great with the Lulzbot provided firmware… I use octoprint for control of the printer and rarely use the LCD.

Anyway… if you aren’t resourceful enough to figure it out… or adapt. I don’t have much else for you… or your attitude for that matter.

I paid a premium for a product (6 actually, 2 Taz5’s and 4 Flexystruder v2’s, but that’s not really the point), from a company that speaks of how strongly they support open source… yet when asked for that source I’m not given that source, rather I’m given old, outdated, incorrect source…

When I question this… I’m told I was given the right source, when obviously I wasn’t… and you expect me to be happy with this?

How are you checking the version?

If you want previous commits of the Flexystruder V2, click on the history button (the icon to the left).

I’m compiling and installing to the Taz, and M300 doesn’t work… when I install the firmware from Cura it does…

You might want the Flexy firmware not the Taz firmware.