Taz 6 Latest firmware is?

So when you update firmware via Lulz Cura you get 1.19.34 but is there more recent firmware updates that you can download and install via Cura “custom upload” feature?

Should Taz 6 firmware update to Marlin_TAZ6_Aerostruder_2.0.0.144_aded3b617.hex from the lulzbot download site??

… and where can I find source for Taz 6 firmware, either 1.19.34 or what’s installed on my printer ( EXTRUDER_TYPE:SingleExtruder ) ?

You can find most of the compiled versions of firmware at http://devel.lulzbot.com/software/Marlin/

In addition to the .hex file, there is a .config file that contains the #defines used in the .h files of the build.

I used to have a pointer to the LulzBot flavored Marlin GIT repository (https://code.alephobjects.com/diffusion/MARLIN/) but that link doesn’t work anymore.

If someone knows where it is now, please reply with the new link.

So to upload the lastest firmware for Taz 6 AeroStruder V2 download the .hex file and use Cura to upload custom firmware to the printer?

You can download the latest firmware for the tool head that you have. For @reinharm1959 that would be the Aerostruder V2 and for @cj11363 that would be the Single Extruder. In both cases, you can upload it with the CuraLE custom upload.

I know that I can upload the latest firmware ( and I even know of a couple of different ways to do it without Cura :).

Does anyone know where I can find SOURCE CODE for the latest version of firmware? Does Lulzbot even publish the Marlin source anymore? ( I haven’t been able to access http://code.alephobjects.com/ since the company changed hands ).

I want to tweak the firmware for an unusual configuration and for that I need the source code. hex and header files are not sufficient to my needs. Lulzbot used to publish the source files for everything, but perhaps the new owners are taking a different path ?

I’d 1) send an email to support and 2) call support and ask. Hopefully, one of these two contact methods will get a reply (which you can post here, please).

I tried a few combinations ending in .lulzbot.com but didn’t find anything.

Try https://gitlab.com/lulzbot3d/marlin.

1 Like

Well the version for the V2 toolhead via Cura automatic update is 1.19.34 while on the lulzbot.com downlaod site is So when I upload v the Taz 6 bed probe acts erratic and fails.

As you have stated, the last “official” firmware for the TAZ 6 is 1.19.34. Anything beyond that is caveat emptor. That being said, I don’t think is the best you can do. Try http://devel.lulzbot.com/software/Marlin/

Tried emailing support asking where to find source, no joy. I was able to clone the git repository that you pointed me towards ( thank you very much! ), but it will probably be a few days before I get caught up enough on other chores to work with that.

Would be very nice if the “new Lulzbot” continued to publish source files, but I’m not holding my breath on that. I was going to try to call them today, but then you pointed me towards some source code :slight_smile: that might be sufficient for my needs…

thanks again!


No joy as in no response or did you get a negative response? I haven’t seen anything published that would lead me to believe the new owners are moving away from Open Source.

The Marlin license is GNU GENERAL PUBLIC LICENSE, Version 3, 29 June 2007 so they will have to make their version available. One would hope that they do that by making their GIT repository publically available (read-only, of course).

I got a response that pointed me where I had already visited. I followed up with remarks indicating that I had already visited those links and that they did not contain the source files that I was looking for. I mentioned that the previous repository ( http://code.alephobjects.com/ ) was unavailable and asked where I should look. I never received a reply to my second email.

I have no idea what path the new owners will walk, I suspect that they are still trying to figure it out. It’s good that they have people like you to put those of us who are less clue-full in the right direction :slight_smile:

– Charlie

Do you download the hex or config or both ?

neither were of any use to me. I cloned the git repository that b-morgan pointed me towards ( and I think that will work for me ). Your needs are different, I think.


I wondered about that, but my Taz 6 is no longer sold, and I doubt that they’re spending any effort updating Taz 6 firmware, so I don’t know what obligations the new owners have in that respect.

All of the uncertainty regarding Luzlbot support was certainly a factor in choosing my newest printer :slight_smile: , but perhaps I’ll come back to Lulzbot for my next printer. I do look forward to seeing the “new Lulzbot” prosper.


I agree that continued firmware upgrades for the TAZ 6 may not happen. I haven’t tried any of the Marlin 2.x firmware versions on my TAZ 6 because I don’t have a need to do so, ATM.

I’ll be happy if I can rebuild from sources. If there’s a Marlin 2.x feature that I must have, then I’m willing to go it alone if I have to.

I think that you might no have to go it alone, https://github.com/marciot/drunken-octopus-marlin/blob/master/docs/FAQ.md

Thanks for that pointer.