Linux xfce4 on Chromebook + Cura lulzbot ed. wi Taz Mini

Hi, Trying to get Cura to recognize my USB port through xfce4 (precise) running on my Toshiba 2 Chromebook for the Lulzbot Taz Mini. I added my username to the Dialout list (which was one answer I found online), but that didn’t work. Any suggestions/solutions? Thanks!

What error are you getting?

After you add yourself to dialout, you have to log out and log back in. You could also run it as root, to see if it is just a permissions problem.

at first I didn’t get an error message, but now it says failed to autodetect port. and I don’t see the usual USB ports like I see when I run on the Mac. I did restart already, tried that. and I can’t say I would know how to run it as ‘root’. I’m a Linux noob so still learning.

Check out this link:

I think you may have to add yourself to the serial group as well.

We have instructions on adding your user to the needed groups here:

If you have trouble connecting to your LulzBot 3D printer, you may need to add your user account to the dialout/tty serial access group. In a terminal, send the following commands:

sudo usermod -a -G tty $USER

> ```text
sudo usermod -a -G dialout $USER

I believe the problem is that Chromebooks use different groups than debian. The link I sent before showed that the serial group was needed where your directions are only adding tty and dialout.

cd /dev
ls -al tty*

> And this produces a listing in which the line of interest looks something like:
> ```text
crw-rw---- 1 root serial 166,  0 Nov 26 05:37 ttyACM0

It does now :smiley:

Thanks for the tip!