Cura Communication Fix Linux Mint 17.1

This seems to have been covered earlier and elsewhere, but as a new Lulzbot Mini owner I thought it might bear repeating. When I setup my new printer I could not get Cura to connect to it using Linux Mint 17.1. Rebooted into Windows and it worked fine. I also tried on my Mac and worked fine as well (proving the hardware was at least working properly).

Searching here and on the web yielded the simple answer. Even though I was running as an admin user, my account was not a member of the ‘dialout’ group and as such could not access the com port to talk to the printer. Once I added my account to the group Cura could connect fine.

The getting started guide in the box was great, but it doesn’t really address what to do when something doesn’t go as expected. Not trying to be a nudge, just surprised this isn’t mentioned as a possibility to make the user aware.

Other than that so far it is a been working very well. As this is my first printer I am very happy.

We’ve added the serial/tty usermod commands to the linux instructions.