Lulzbot Mini 1 Excessive flow rate

I recently upgraded to Cura LulzBot 3.6.29 from an earlier version. At some point in that process a setting got changed, and now my printer is just shooting filament out as fast as it can.

I’ve never had to mess with the flow rate before (it currently defaults to 95% with initial layer at 100%), but I can watch the herringbone gear spin, and it oozes out a thick useless mess.

I’m not even sure where to start on this. Should I try to adjust the flow rate? That seems obvious, but it also feels like a kludge- I haven’t ever done anything other than the defaults for ABS, and it previously worked beautifully.

Your e-steps are probably improperly set. This is common when upgrading your firmware. Your Z-offset has probably been reset back to the default value of -1,2 also.

Obtain the current e-step settings by connecting on the console and type M92. If that don’t
work try M503 (dependent upon your version of Marlin).

Now let’s see how much filament you are extruding so we can figure out what your e-steps should be.
From the top of the print head where the filament enters into it, measure upward on the filament 100 millimeters and 200 millimeters.
Now heat up your extruded to print temperature.
Now extrude 100mm of filament.
Did you extrude 100mm or more?
Hopefully it stopped before 200mm went through.
How much length is left to the 200mm mark?
How much did you extrude? 100mm + (length left to the 200mm mark)

BTW there may be a sticker on the back of the print head of what the e-steps should be. Also if you have the original documentation for the printer the e-steps should be written down in the paperwork.

Have finally had time to mess with this.
Unfortunately, my esteps are not printed on the head, and the document I created when I last updated firmware is nowhere to be found. They are currently set to 833.0, which is what I understand the correct default for my printer should be. (full info below)

I’ve attempted to calibrate the esteps, but I suspect I’ve run into a problem of my own making. Using the GUI in cura, I’ve set prints to have a flow rate of 40%, which prints successfully, but has now ‘stuck’ in the G Code. When I attempted to calibrate esteps by extruding 100mm of filament, it’s actually very slightly underextruding, not massively overextruding like I’d have expected.
What I suspect is happening is that my flow rate correction has somehow become default, and I can’t change it. I’m assuming the M203…E40 reflects that below. I can’t figure out how to change that. (I tried “M203 E100” but that didn’t do anything. I’ve initiated a couple of prints at 100%, and that will replicate the overextrusion behavior, and remain the default when Cura subsequently reopens, but the code below doesn’t change.

Thus any attempt to calibrate will be distorted by that fix. I supposed I could try to math around it, but that’d be hard to verify, and the fact that the esteps is already at the default suggests the problem lies elsewhere? (Unless I’ve looked up the wrong default- I’ve seen 420 in places, too, but for a different extruder- I’m pretty sure mine is the basic one…)

[11:20:26] M503
< [11:20:28] echo: G21 ; (mm)
< [11:20:28]
< [11:20:28] echo:Filament settings: Disabled
< [11:20:28] echo: M200 D3.00
< [11:20:28] echo: M200 D0
< [11:20:28] echo:Steps per unit:
< [11:20:28] echo: M92 X100.50 Y100.50 Z1600.00 E833.00
< [11:20:28] echo:Maximum feedrates (units/s):
< [11:20:28] echo: M203 X300.00 Y300.00 Z8.00 E40.00
< [11:20:28] echo:Maximum Acceleration (units/s2):
< [11:20:28] echo: M201 X9000 Y9000 Z100 E1000
< [11:20:28] echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
< [11:20:28] echo: M204 P1000.00 R3000.00 T1000.00
< [11:20:28] echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
< [11:20:28] echo: M205 B20000 S0.00 T0.00 X12.00 Y12.00 Z0.40 E10.00
< [11:20:28] echo:Home offset:
< [11:20:28] echo: M206 X0.00 Y0.00 Z0.00
< [11:20:28] echo:Auto Bed Leveling:
< [11:20:28] echo: M420 S0
< [11:20:28] echo:PID settings:
< [11:20:28] echo: M301 P28.79 I1.91 D108.51
< [11:20:28] echo: M304 P294.00 I65.00 D382.00
< [11:20:28] echo:Z-Probe Offset (mm):
< [11:20:28] echo: M851 Z-1.37
< [11:20:28] echo:Linear Advance:
< [11:20:28] echo: M900 K0.00
< [11:20:28] echo:Stepper motor currents:
< [11:20:28] echo: M907 X1300 Z1630 E1250

Additional. I figured out my M203 syntax, and reset the max flow rate to 100% (I presume). Calibration still extruded 100 mm.

Additional additional: On reopening Cura, M203 returned to E40…

Decided to try to calibrate based on line width, now printing with the (seemingly absurdly low) e-step value of 126. Seems fine-ish, and is printing with a lot less angel hair residue than my flow rate adjustment (nice to have less hand finishing…) Will have to check for dimensional accuracy after job is done.
Very strange though, in that this estep adjustment, from 833 to 126, bears no relationship to my otherwise successful 40% flow rate adjustment… I don’t know if it should be a linear relationship.

I don’t have a Mini 1 but I do have a TAZ 6. I believe there is a reset to factory defaults on the LCD. If you don’t have an LCD, M502 is a Factory Reset. Before you do that, do an M503 and keep a copy. After the M502, do an M500 to save the settings. Use an M503 to see what the default values are.

Alternatively, you can reflash the firmware.

Now calibrate E-steps as detailed above or follow this. Note: You can use 200mm instead of 110mm.

You will probably need to adjust the Z-offset as well and maybe PID tune the nozzle and bed.

The output of the M503 can be converted into a gcode script with a bit of clever editing. You can then save that file somewhere where you won’t lose it :grin: