Lulzbot Mini Newb

I just bought what I thought was a Lulzbot mini second hand, But after getting it home and set up, it seems it is a Mini 2 since it has the LCD and the removable print bed according to some youtube comparison videos.

I have downloaded the quick start guide, downloaded Cura, added lulzbot mini 2, and connected to usb, and it seems to know that something is there, but there are a couple issues that i need help with

Couple issues at the start:

  1. LCD Backlight comes on, but screen is completely blank.
  2. Toolhead doesn’t appear like the original - after some googling, it seems to be the ‘aerostuder’
  3. When connecting in Cura, i am getting wrong printer error - i have tried setting printer to the mini, the mini 2, and the Mini aerostuder options, but same result. error reads: Expected that MACHINE_TYPE was LulzBot Mini LCD, but got LulzBot Mini instead.

Any have any suggestions on where to start? Thanks in advance!

The LulzBot Mini 2 has belts on the Z axis, all other LulzBot Mini’s have threaded rods on the Z axis.

My LulzBot TAZ 6 has a model/serial number printed on the back, does yours?

To determine which version you have, check your serial number against the “production batches” listed here:
https://devel.lulzbot.com/mini/

Once we have determined which Mini you actually have, we can tell CuraLE and then hopefully, upgrade the firmware to get the LCD working again.

Thanks for the info - based on that, it is clear that i have the Mini 1, but the toolhead has been upgraded - see pictures.

Before doing anything, make sure that the LCD checkbox is checked in Cura, and upgrade the firmware for the Lulzbot Mini.
04_Mini_LCD_CheckLCDBox_SFMUBz2.jpg.600x0_q85.jpg (600×392) (lulzbot.com)

I would verify that the installation was done correctly. Your serial # denotes compatibility with the screen, which is good.

Remove the panel wiring completely and follow through the installation instructions. It’s possible somebody just plugged it in wrong and didn’t assume they could have done anything wrong.

So i was able to get it to connect via usb - i disconnected the cables from the lcd screen and added printer “mini 1” with aerostruder and “no” lcd screen. It then was able to connect and prompted to upgrade firmware. Fingers Crossed…

Test Print successful! now i will try to get the lcd working with wrathernaut’s advice