Lulzbot Mini 1 won't connect

I have a Lulzbot Mini 1 with the original print head and I can’t get it to connect to my computer. I did manage to get it to show up as “connected” one time in Cura for Lulzbot, but I could not get the printer to respond to any commands. I will try to share the details of the issue below in a concise manner.
-Printer: Lulzbot Mini 1 with original tool head
-Firmware version installed -
-Cura for Lulzbot Edition - 3.6.23
-Windows 11 Pro Operating System

I have been using Cura for Lulzbot for several years with a TAZ 5 and TAZ 6. Both printers work beautifully. An unused Lulzbot Mini came to me, so I added the printer on Cura and tried to connect. A message popped up that said can’t connect to printer. I went through the process of updating firmware, and I have tried to connect many times while watching the console in Cura. The messages show as follows.
-Attempting to connect to None
-Trying to detect 3D printer on COM4
-Attempting to connect to printer with serial COM4 on baud rate 250000
-Can’t connect to printer on COM4
-Closing the USB printer connection
-PrinterConnection.close: cannot join current thread (expected)

I have tried setting the baud rate to different speeds and AUTO with no success. What should my next steps be in troubleshooting the machine? Thanks in advance for your time.

You mention updating the firmware, but that couldn’t happen without connecting.

If it’s an original mini with very old firmware, it needs a baud rate of 115200 rather than 256000. Try manually setting 115200 in Cura and see if that gets it connected.

Thanks for this suggestion. I did try that after reading some other posts where people were having connection issues. I will try again today, just to be sure, but yesterday when I changed the baud rate, I had the same results. I have tried 115200, 256000, and AUTO settings for the baud rate.

Here is an update. I tried to connect to the printer on all baud rates, one after another, and the same fail message shared before keeps popping up just with the different baud rates listed as I change them. I then went back and tried to update the firmware again. I updated it using the “Automatically Update Firmware” button. The progress bar proceeded as expected. Lights were flashing on the printer, just below the USB connection. When the progress bar finished, a message popped up saying it was successfully updated and that the printer was connected. The version that was uploaded was I then tried to preheat the nozzle and the bed. The console said that the nozzle and the bed were preheating, but they never got warmer to the touch. I also tried to move the print head on all axes. Nothing moved.

Any other thoughts out there about what the issue might be with this Mini 1? As stated above, the only time the printer seems to act like it is being acknowledged by the computer is when I update the firmware. Any other communication that I try to make with the printer on any baud rate setting results in the error message I shared above and a complete lack of response from any of the stepper motors or the heated nozzle or bed. I appreciate any help that anyone can send my way. I am about to end up with a very expensive paper weight, but at least my documents won’t blow away.

I feel like I may have been abandoned here, but I am still trying things. I clicked on the “update firmware” button in Cura again to see if I could get the printer to show as connected in Cura. Updating firmware seemed to be successful, but it still would not show as connected. This time I unplugged and replugged the USB cable into the computer, then I set the baud rate to 250000. When I clicked “connect”, The printer showed as being connected in Cura. I tried to move various axes, still no success. I clicked the “print” button and Cura actually said that the object was printing, but nothing was moving on the printer, and nothing heated up. Progress never showed up on Cura either. I am mystified. I also checked all electrical connections to the board, everything seems to be fully connected and plugged in in the correct orientation. All fuses also tested good. What else might I be able to do?

I’d try using PrintRun (Pronterface) instead of CuraLE just to get a second opinion on the USB-serial connection.

I find it very strange that you can update the firmware through the USB-serial connection but not control the printer. Since the uploading of firmware needs only a minimal portion of the controller board, it could be that the rest of the board has failed in some way.

There should be a serial number plate on the printer. Using this serial number you can determine exactly which LulzBot Mini 1 you have. This information might be useful going forward. Do you have an LCD panel?

A failure on the board is exactly what I am beginning to fear. There is no LCD screen on the printer. I do have the serial number. I can try the other software if you think that would still be helpful. If I should start talking with someone about possible repairs, any suggestions you have for that would be greatly appreciated.

I would try PrintRun just to close that option.

Armed with the serial number you should be able to find the control board part number. Not sure if they are still available. You should also be able to determine if you can “upgrade” to a board that is available and that will support an LCD panel. Maybe find one of those as well.

I’d start by contacting LulzBot support either by phone or by email. You can also root around on the OHAI site. Searching this forum will also yield lots of information.

Not having an LCD definitely makes it harder to figure out what is going on. But getting Cura to say it is connected is a good step forward. The next thing I would try is connect with Cura, then go to the Monitor page, then click the console button. In the window that pops up, type “M115” and press enter or click the send button, and it should send back a bunch of information about the printer in the console window. If a bunch of text appears you know the printer is communicating with your computer and Cura properly. You could also try typing other commands, like “G28” to home the printer. If the text didn’t come back with the M115 command but G28 makes it home, that indicates that it’s listening but not talking back.

I did try typing the codes into the console window. No luck. I appreciate the help, though. Dos this seem to indicate that the board is no longer operating as it should?

Thanks for all of your help. I had one other response from Lulzbot, so I am waiting on a reply from them. I like your idea of seeing if I can fit an updated board with an LCD. I may look into that possibility soon.

The puzzling thing about this is that for Cura to say it is connected it would have to be seeing a response from the printer. So you should also be able to see a response in the console window.

I’d hate to see you spend money on a new control board and LCD only to find it doesn’t fix the problem and it turns out to be an issue with your computer or Cura.

Yet in your first post you say you use Cura with a Taz 5 and 6 and they work. That would indicate that Cura and the computer are fine. Are you using the same computer with the Mini 1? If not, can you connect the Mini 1 to the computer that works with the Taz 5 and 6?

I am using the same computer to operate (or attempt to operate) all 3 printers. Yes, the TAZ 5 and 6 are working flawlessly.

It is pointing strongly toward a bad board in the Mini 1. But the thing that confuses me is that if Cura says it connects then it has to be receiving a response from the printer. So I’m puzzled why you can’t at least get responses to appear in the console window.

I have had this happen before. Connect only the printer and no other USB devices.

I only have the printer plugged in when I am troubleshooting it. Since it was showing as connected in Cura, but not responding, I thought that there might be wires disconnected from the board that go to the motors. I opened up the case where the electronics are housed and took a look at all of the wires. All of the connections appeared to be completely plugged in and they appeared to be plugged in in the correct orientation. The only loose wire that I saw was going to one of the cooling fans. I plugged that wire back onto the board and tried everything again. The same issues persist. I will definitely start looking into a new board.

A little bit of background. These printers are all being used at a school. The TAZ 5 was our original printer and it has worked well from day one. The TAZ 6 was purchased for our middle school. Nobody there could ever get it to print. It came to the upper school and I traced the problem down to the x-axis gantry not being square to the print plate enough to allow for auto-leveling the bed. It works great now after minor adjustments. The Mini went to our lower school. I have no idea who assembled it or if it required assembly out of the box. I also don’t know if anyone ever successfully printed on it while it was at our lower school. If anyone happens to know of anything that might have not been properly connected or assembled during the initial setup, that might help me track down the issue. Thanks so much for all of the suggestions. At some point, something will work. I am confident of that.

I would try downloading Cura 21.04 and seeing if it will recognize the printer. Sorry I missed that you were using a newer version of Cura in the original post.

I have both instances of cura I use with my older printers and my newer lulzbots.

I will give this a try and let everyone know how it goes. Thanks.

I feel like progress was made! I installed Cura 21.04 and connected to the printer. This time I was able to connect easily to the Mini 1 and a message popped up in the control window. The message was "< Error:MINTEMP triggered, system stopped! Heater_ID: 0
< Error:Printer halted. kill() called! "

I was still never able to move any of the axes, but I think that this is the error that was occurring before in the newer version of Cura, I just couldn’t see the error message anywhere. I researched this error message and the suggestion that was made was to reset the board and reupload the firmware. I tried this and nothing changed. Does anyone have any suggestions for how I might correct the error message above? Thanks again for all of the help.