Mini not wiping properly - hovers about 1 cm above pad and does wiping.

This issue is driving me nuts :imp: :imp: . I have noticed this when I installed Cura Lulzbot Edition ver: 2.6.69. More specifically when I updated the firmware for my mini.
My mini is version has a standard print head (v2). When I start a print, the print head travels all the way down to the pad, but stays about 1 cm or so right above it (so not wiping anything).

Making matters worse, a totally clean print head will not complete calibration either – just get probe failure.

The only way I can get my mini to work is by loading a very old firmware manually (Marlin-LulzBot-Mini- I was ok with this for a few weeks now, but this firmware doesn’t have the safeguards for bed leveling. Meaning the probe will just crash down if the circuit is not completed.
I even installed previous other 2 versions of Cura luzbot edition to use the older firmware. I even went to (~cura-lulzbot 2.6\resources\firmware) and grabbed the older firmwares and tried manually updating with those. All the same (except if i use that really old one).

Anyone have any ideas? I don’t understand this. WTF and all out of ideas.

You must use the firmware that matches the Cura version you’re using… and the latest Cura 2 (as opposed to the original Cura) seems to have some “difficulties” :unamused: :frowning:

I’d suggest considering downgrading BOTH the firmware AND Cura – you’ll find the original Cura (not Cura2) here:

Install that, and it has the appropriate firmware already built-in (no need to download anything more, just Cura 21.08). Simply go to the normal spot in Cura to flash the printer’s firmware, and it’ll install the correct version that it wants for that printer.

During the process of upgrading to Cura 2.6.69 did you happen to go through and clear out your computers old cache files? If not, give that a go. There have been some instances of those old files causing new firmware to not transfer properly leading to similar issues.
Here are some link for how to do that based on your OS





After clearing the cache, add a new printer in Cura (even if your old one still shows up), and reflash the firmware before trying another print.

Thanks for the replies. I have been trying everyone’s suggestions (more than once). Nothing is working so far. I checked the printer to make sure nothing was mis-aligned (lead screws, etc). And all seem fine. X, Y, and Z all home just fine. Nothing appears to be broken or moved. I will probably need to call Lulzbot support. Crazy though as I have had this printer over 2 years now and never had any issues with it.

Some minis (depending on when manufactured) have slight variations in measurements due to part changes. As a result, some older minis don’t reach the wiper/washers as they should with new firmware. The older firmware (1.0.xx) also had a bug which made it go 1mm lower for any given Z position than current firmware does.

There are a couple of good solutions to the behavior you are seeing…

(1) Add an G92 command into your start script. Right after the initial homing command (G28), add a line with “G92 Z160”. This will tell the printer it is at 160 instead of the firmware default 159 when at the home position, so when commanded to go to 0 it will move down 160mm instead of 159mm. You may need to use “G92 Z161” (to go 2mm lower) if the Z160 is not enough (depends on your printer). You will need to check/ensure you have this command in your start script whenever upgrading to a new version of Cura, or using a different slicer. And of course you want to remove the G92 if you revert to the old 1.0.xx firmware where it isn’t needed.

  • OR -

(2) Glue or tape small shim (1-2mm in thickness) on the inside of the top frame, directly above the Z_Max limit switch. This will cause the switch to close 1-2mm sooner, so that the default Z_Max_Pos of 159 will be correct. The advantage of this approach (vs the G92 method) is that it corrects the problem through hardware, so you don’t have to worry about maintaining a script change in future versions. Just be sure to remove that shim if you revert to the older 1.0.xx firmware.

If the nozzle does reach the washers when probing, and the only problem is reaching the wiper, then you could always just change the Z coordinates in the start script lines responsible for the wiping. But this requires changing several lines, and doing it every time you get a new version of Cura with new start scripts – so more work than the G92 method where only one line is needed, and more work than the “shim” method which requires no script changes at all.

Yet another method is grabbing the firmware source, changing the Z_Max_Pos declaration to 160 (or 161), and recompiling. That’s not terribly difficult if you have a little programming background, but the above two options are a lot easier – unless there are other firmware customizations you want to make.

Reporting back with good news (insert Futurama Professor Farnsworth)! Option number 2 works! I tried the G-code fix first, but no luck. Now I will need to make an exact shim and insert it. Thinking I will design something and print it and then attach that to the top with a couple of small hex screws (will drill a couple holes up top too).

Well this has been a frustrating journey.

Thanks a lot for all the awesome responses!! This was my first post and you guys were great. Now I think Lulzbot might still want to get in contact with me and officially see what the heck is going on.

**And a further note, any lowering of the Z-axis I did using via G-code had no affect (such as setting to -5 or setting G92 Z160 or more). I suspect the probe guard software/code, which keeps the probes from going too low and crashing into the bed sensors, overrides the g-code coordinates.

A small piece of cardboard working excellent (for now).

(just realized this images is rotated).

I made an account just to say thank you. The option 2 solution proposed by ScottW above fixed this issue for me.

I cut a slim piece of cardboard to fix just as bal323 showed in their picture, slid it in, and all is well again. The shim is about 3mm thick which is actually probably .5-1mm too thick because the head now pushes a little too far into the wiper pad but at least the auto leveling probe succeeds every time. I think I might have to calibrate my Z offset though because that got wiped during the firmware flash. Oops.

Hi guys
Bought my lulzbot mini 2 a month ago. Great printer but same problem. Used the fix you guys suggested for the nozzle 1cm hover issue which got resolved. Not an ideal fix but works so thank you guys.

I was experiencing a very similar problem. My Mini was missing the leveling washer and wiping pad by a few mm.

ScottW’s option one solved the problem for me. I will also note however that i had to slightly adjust my Z offset after implementing that part of the code, the toolhead was extremely close to the bed and causing filament to bunch up and not stick.