Mini stops after a few layers, regardless of object

My Mini has been working great for a long time. I’ve had to do the usual maintenance, etc. but lately it’s been great.

Today it’s started doing something completely new. It lays down the first few layers, then just stops. The printhead scrolls all the way to the right extreme of the Y axis and retracts up Z a little ways, then just stops moving. The nozzle stays up to temp, the bed stays up to temp, Cura reports nothing. It just stops.

It “feels” like a very intentional action, almost like it believes the print is complete. I’ve tried a variety of print jobs and they all fail the same way, after about the same number of layers.

The Z axis is free to move. The carriage can go all the way up and all the way down, so there’s no mechanical “catches” in the system. The printhead does its four-corner self leveling action just fine. Literally everything works great, except after a few layers it just “homes” to the right side and sits there indefinitely. I can immediately retry and it jumps right into action like nothing is wrong.

I’ve tried power-cycling, not power cycling, restarting Cura, loading different STL files, manually exercising (via Cura) all the different steppers. Everything acts like it works great.

Any ideas?

I’ve heard some users have to remove the printer from cura then recreate it and that might fix this issue. Open up the gcode and give it a sanity check.

I haven’t used Cura for a long time, but that sounds a lot like what a “filament change at Z” type of plugin would do. Do you have any plugins loaded in Cura? Can you save the Gcode from Cura to a file, rather than sending direct to printer, and then inspect the Gcode? Look for an M600, or a move (G0) that matches what you’re seeing.