Misaligned Layers

After roughly 150 hours of use, the prints from my Taz4 have developed misaligned/sheared/lopsided layers. According to my research it may be due to skipping steps, which can be caused by potentiometer settings, belt tension, or loose set screw on the pulley or not on the stepper shaft.

I’ve leveled the x axis from the y aluminum plate under the glass bed. The bed_calibration.gcode file from the SD card prints perfectly. I’ve tighten every screw I can find. The belt tension is ideal. I’m very confused and hoping to find some help here.

To be honest, I have no clue where to start in regards to potentiometers. Are they adjustable via the LCD control settings?

As for the set screw on the X axis motor pulley, without a schematic I can’t be sure if I have tightened it or not. Can anyone include a picture of this set screw, and how it should ideally be tightened to the motor shaft?

Included are pictures of the issue I’m encountering, and orthographic renders of the intended shape:

PearlHalf_Final.stl (59.8 KB)
PearlHalf_Slic3rFinal.gcode (902 KB)
Slic3r_Config_Pearl.ini (2.99 KB)

on your x axis left hand side there is a motor. On that motor is a shaft with a pully that drives the belt for the x drive. That pully has a set screw securing it to the motor shaft. That screw should be aligned to the flat on the motor shaft and tightened down tightly.

The trimmer pots your reading about are implemented in software on the RAMBo board that drives your printer. These are set in the firmware for the printer. WHile there is info available on the net about these settings in Marlin, I suggest contacting customer support (which is fantastic btw) and they can walk you through any changes that may be needed.

Thanks for the reply chiphead.

I had emailed customer support previously and completed their suggestions to no avail, so I came here to see if the forum-goers could help me out.

I’m still confused in regards to the set screw. I’ve only seen it referred to as a single screw, but in the included picture there are pairs and sets of screws that secure the motor/pulley to the shaft.

My best guess is that “D” is the set screw and “A”, “B”, and “C” are tightened in relation to it once it is aligned to the flat of the motor shaft. Is the set screw not in this picture? or is it one of the other lettered screws?

The set-screw is on the pulley.

Thanks Wizard. So that’s where the the set screw is.

So both of the tiny threaded holes on the pulley are supposed to have screws in them for tightening? I don’t seem to have them if that’s the case, so I’m not quite sure how I would tighten it down flat to the motor. Anyone know the size of these screws?

When unscrewing the motor from the frame, I found a build-up of sooty material on the motor shaft, motor, and frame. Should I be worried about this, or is it just simple maintenance like canned air in all the crevices?

Thanks for everyone’s help so far!

by the looks of the shaft, they were there at one time, That soot is probably from them grinding away on the shaft of the motor when they came loose. see that dark line? on the shaft.

That’s is certainly the issue with layer misalignment. Look around, they were there and are probably lating around might be in a channel of the frame.

Sorry, I don’t know their size as they come with the pulleys. But once you do locate them, align one hole along the flat of the shaft. snug it up the tighten the other then tighten it the first one. when snugging up the first one on the shaft, as it get close you can wiggle it back and forth a bit as you tignten it and it should center itself on the flat.]

The set screws are metric M2 studs I believe. You may be better off just ordering a new 18 tooth pulley from the lulzbot store, or getting them to send you one under warranty.

We can certainly send a replacement GT2 pulley. I’m glad to know it was the set screw on the pulley! That will be rather easy to replace. You should be reciving an email soon.



Received the pulley/set screws and it worked like a charm. The replacement m3 screws I tried didn’t work, but I’ll have to try m2’s if the issue comes up again.