Newb getting started

Hello, I am a total newbie to 3D printing and I just purchased a Lulzbot Mini and I am excited to start printing!

I printed out the rocktopus with the standard settings (with green PLA provided) and it turned out pretty nice.

A few things that I noticed were that it had quite a bit of stringing and also it seemed like the nozzle might be too close to the bed. This was evident because the skirting appeared flattened as if the nozzle was spreading it out as it extruded, instead of a nice clean filament trace.

I cleaned the nozzle and made sure there was no fuzz from the felt pad before printing, but after a few other test prints, the skirting still appears flattened.

Wondering if anyone has any suggestions regarding the stringing and flat skirting?

Thank you!

It’s maybe okay for the first layer to be flattened a bit - that’s good for sticking it down - it’s hard to know if it is too much without seeing.

You are correct that one cause could be that the the nozzle isn’t getting clean. (If it isn’t clean it can push down harder on the washers and then it will “think” the bed is lower than it really is. If you watch the washer corners during bed leveling, then you should not see the washers move when the nozzle taps them.)

Of course you can also experiment with some slicer settings. You could try to change “initial layer thickness” and see if it helps - I think the default is to have the first layer thicker than the rest. The tooltip for this setting in cura says having a thicker first layer will help it to stick more, but I usually change it so it matches other layers and that still sticks fine for me. (I’m sure there are other settings to look at also.)

For stringing you might try to lower the temperature slightly (a few degrees)… Retraction settings might be more complicated, but just some ideas if you want to play around and see the effects.

The following may not directly address the issues you mentioned, but another thing to try early on is to calibrate e-steps/mm. Basically you would measure how much filament is extruded when you manually request to extrude a set amount (usually try 100mm.) If it is extruding too much, then you can turn down the esteps/mm by appropriate amount with some console commands from cura (or on the LCD if you have it.) Repeat until it extrudes the amount that is requested and save the setting. There are detailed step by step elsewhere if you search for calibrating esteps. Have fun :slight_smile:

Post a picture of the rocktopus base or any other object you’ve printed. The pattern of the extrusions can help us gauge what “flat” means. In general, you’ll want the first layer to be a bit flatter to help with adhesion.

Thanks for the feedback!

Attached is a 60% rocktopus that I just printed. I lowered the nozzle temperature from 205C to 200C and less stringing was observed.

The nozzle was clean and did not deflect the levelling washers.

Maybe I just don’t know what the bottom layer or skirt should look like, but they seem flat and I would expect it to be thinner and taller for a single layer skirt.

I suppose a brim might be a better choice for future prints to make sure the nozzle has filament before it gets to the object.

Performing an M851 command, I get:

Z Offset : -1.38

I guess this is in millimeters?

Thanks for the idea to print a baby rocktopus… I like it.

I agreed that the skirt in picture looked a little squished, so I decided to print my own 60% rocktopus as comparison. I found it actually looks about the same. Note this was done with aerostruder but I don’t think you have much to worry about. Maybe someone else will have an opinion on both of them. My z offset is apparently -1.377 (aerostruder might be different default because I haven’t messed with it. I might play around with that someday.)

It’s also possible a picture of the bottom of the print would tell more for the other poster…

One thing in the settings you can also set is the number of skirt lines or a minimum amount of skirt to print. If you wanted more skirt instead of brim then it is possible.

I decided to play with the z-offset now. I took the skirt from the bed and measured it was .11 to .15mm thick even though initial layer was set in Cura to .2mm. So I raised the z-offset by .05mm and printed again, but this time I stopped it just after the first layer finished. (See pic)

This time the skirt was as much as .19mm thick. Also the width dropped a bit from 1.43mm to as low as 1.1 in places… (hoped for 1.0mm because 2 perimeters of 0.5)

Anyway, it does seem like this is something to play with if you want to experiment. It might not adhere to the bed as well if you raise it up, but it seemed fine here (at least for PLA) I’ll add a pic of my new first layer, then going to watch some TV and bed time here.

Hi dmds,

Thanks for trying this out and sharing! I tried a z-offset of +0.1 (-1.28) and it was a bit too high. I will try a +0.05 (-1.33) and report back tomorrow.


Just an update…

I changed the Z-offset to +0.05 (M851 Z-1.33) and I think it made a better print.

Two lines of skirt was a good idea - they both printed very cleanly, and the nozzle didn’t seem like it was flattening them as it went along.

A few questions that I have…

  1. Do I need to change the Z-offset (M581 command) between every print?
  2. How does changing the Z-offset affect the four-washer zeroing process?
  3. How can you apply the Z-offset in OctoPi?


Good to hear… I’m a little new to this part too - so hopefully if I say something wrong I’ll be corrected :slight_smile:

  1. I think you can do M500 after the M851 command to save it. Then that value will persist next time the printer is started. I tested this and it seemed to work. (Though last night I was setting it with the LCD add-on accessory, I just now tried it through the Cura console over USB and M500 is the store/save command.)

Also it seems that M501 after restarting the printer will list all of the saved settings so you can confirm it was saved.

  1. I believe it should not affect the leveling process. The leveling process is done to determine where is “0”. It does this by tapping the tops of the washers. Then the z-offset is applied after the fact, based on that 0 level, to locate the real top of the bed. So it is a negative number, meaning lower Z, of around 1.3 which is the washer thickness… because the top of the washer is about 1.3 off of the top of the bed… now it knows it has to go down another 1.3 from there to find the bed.

  2. I’m not sure… I think once saved in firmware with M500 you would not need to set it anywhere else.

M851 will adjust the Z offset, and you can save it with an M500 as dmds had mentioned. This wills store it to your EEPROM, and will remain until the next time you flash the firmware. It may be good to jot this one down for future use!

2.) dmds is spot on again. The offset is based on where the nozzle probes the washers. If you ever notice that one corner of your skirt seems off from the others, chances are the nozzle was somewhat dirty and need to push some plastic off that corner before making the connection. You will only want to make M851 adjustments when the “squish” is uniformly off around the object.

3.) As this is flashed to the EEPROM, this will affect all gcode sent to the printer. No modifications on OctoPi should be required!

Thank you both - this was very informative!