PID autotune fail due to temp spike

Quick backstory:
I was getting MAXTEMP errors pretty frequently while printing, temp was spiking 25 degrees in 1 second so I knew it was a false reading. Figured it was the thermistor. I got a new thermistor installed and went to do PID autotune and it errored out due to a temp spike. The curve looked great up until the spike.

Any thoughts on what else I could look at?

Here is an update:
I tried an older version of the Marlin Lulzbot firmware and can manually take the hot end up to temperature with little, slightly larger and then huge spikes, ultimately resulting in a MAXTEMP error.

Recv: echo:busy: processing
Recv: T:227.00 /245.00 B:109.84 /110.00 @:127 B@:127 W:?
Recv: T:228.00 /245.00 B:109.85 /110.00 @:127 B@:126 W:?
Recv: T:228.19 /245.00 B:109.78 /110.00 @:127 B@:127
Recv: echo:busy: processing
Recv: T:228.81 /245.00 B:109.72 /110.00 @:127 B@:127 W:?
Recv: T:229.69 /245.00 B:109.75 /110.00 @:127 B@:127 W:?
Recv: T:252.29 /245.00 B:110.00 /110.00 @:0 B@:94
Recv: echo:busy: processing
Recv: T:235.39 /245.00 B:110.00 /110.00 @:65 B@:94 W:0
Recv: T:231.25 /245.00 B:109.52 /110.00 @:127 B@:127 W:0
Recv: T:232.81 /245.00 B:110.00 /110.00 @:127 B@:92
Recv: echo:busy: processing
Recv: T:233.36 /245.00 B:110.03 /110.00 @:127 B@:86 W:0
Recv: Error:MAXTEMP triggered, system stopped! Heater_ID: 0
Recv: Error:Printer halted. kill() called!
Changing monitoring state from “Printing” to “Error: MAXTEMP triggered, system stopped! Heater_ID: 0 - Printer halted. kill() called!”

I downloaded the latest Cura version from Lulzbot and had it auto update the firmware to the current version. Same test, I take the temperature up manually with no huge spikes, but as the temp gets higher so do the spikes.

I also noticed that there seems to be some correlation between the erratic bed temp readings and the spikes in the hot end readings. I’m completely lost here. I have no idea what is causing this as everything was fine a few weeks ago and then it got worse and worse.

I’m guessing a broken wire or wires. I was gonna say perhaps you damaged the thermistor, ( I had one last about a month before it started acting up and replaced it again. Now it’s rock solid, very steady temps). But since your bed is acting up too. The wires are always moving and eventually probably break. Gonna be some tough troubleshooting checking the continuity of the wiring harness from end to end but needs to be done. Make a solid connection on both ends and move the wires, uncover the break. I don’t know how it can really be anything else.

1 Like

Ill do some continuity checking today. You still think its wires even though the bed and hot end are having spikes? Seeing as the wires run in different harnesses I had a hard time believing it was a bad connection that happened to both at the same time. Its a cheap solution if it is the case!

My last thought might be the power supply. When I had it apart I did hear a buzzing whenever the heater turned on. As the PID loop tried to regulate the temperature I could hear it oscillating. Not sure if power supplies are supposed to make a buzzing like this when under load.

Hhhmm a failing power supply does make sense as a potential culprit. Does it spike just sitting there? Or only under a load trying to print.

It spikes all the time, when its under load and also when its just sitting there. Here is a recent graph after I replaced the old RAMbo with a new V1.3 one.

Clearly I need to do PID autotune, but the noise on both the bed and the hot end is still there.

Sadly the power supply is backordered everywhere I can find it, so ill have to wait 2 weeks to find out if it solves the problem. At this point, I can’t think of anything else it could be other than the power supply.

Follow up:
I replaced the power supply and it resolved the noise on the bed and hot end thermistor readings. no more temperature spikes on the hot end and wild readings from the bed temp. Problem solved.

I don’t have the appropriate gear to diagnose the power supply to see what actually went wrong or even what was happening. I visually inspected it and couldn’t see any blown out capacitors or any other suspect components. The drivers are enclosed in little silicone envelopes, so I couldn’t check them out without taking them off (and I honestly don’t care about it that much now that I found the problem)

As far as the cause, the only thing I can think of is for a period of time I had an LED light strip piggybacked to one of the 24v outputs and that maybe that caused a problem. During all of my testing I had the light disconnected and it was still noisy so I didn’t think anything of it.