Printed Parts "shifting"???

Ok so i have a lulzbot ao100 printer, works like a charm now except for one thing, if i print out large parts the printer shifts the object over 2/8" on the y axis (see attached file) and it always does this 3/8" up from the build plate, its really confusing on why this is happening, it does not do this on small parts only large ones or many small parts printed out at the same time.
Please help!

I had this problem too a few weeks back. In my experience, it was caused my skipped steps or from the bed being constrained in some way (like a cord being in the way of the endstop). Anyways, the issue was completely resolved when I installed the GT2 16T pulleys. Hope that helps!

Also, maybe try tightening up the timing belts.

i doubt that is the issue because it only shifts at that exact height every time.

When you installed the new pulleys was there anything else you had to change, like programming/software?

The new smaller pulleys on the AO-101 result in far fewer skipped steps than on the AO-100. It is a small upgrade with significant improvement in reliability. We have updated firmware for the AO-100 configured for the smaller pulleys. You’ll need to set your esteps in the firmware (that info shipped with a sheet that shipped with your machine):


So how exactly would one with no programming experience go about that?

There’s more info about upgrading an AO-100 to an AO-101 here:

Here’s a guide on reflashing your firmware: make sure to use this version: and use the “M503” command to view your current ESTEPS. Then follow the guide and transfer them into Configuration.h

We bought a AO-100 before x-mas. And just started to print larger items now (e.g. raspberry PI enclosure). we also had this problem with shifting (step skipping). So we tried to dail in the stepper motor Controllers. But it did not seem to work either.we noticed that the Controllers got quite hot during print.
So we glued heatsinks to the IC on the Controllers and that seamed to take care of the problem with shifting, only tried 5 large prints yet .
hope this helps someone.

  • Fredrik

Fredrik, could you explain a little more detail on what you did to fix the issue, i’m looking into getting the new pulleys, (the problem went away by itself for a while but now it is back)

Please define “IC on the controllers”. What does IC stand for? Do you mean the stepper drivers on top of the RAMPS shield?

Wouldn’t adding a fan on top of the RAMPS shield/stepper drivers would accomplish the same purpose?

Hi gemini64,

Not sure if your question was already answered, but usually IC refers to Integrated Circuit. A fan would for sure cool down the polo’s and should reduce or stop skipping all together if they’re over-heating (Polo’s have a overheat protection where they’ll basically shut down causing missed or 1/2 steps it seems). Generally some little heat sinks on each of the polo’s will do the trick, as the heat sink will draw out the heat, keeping them cool.

Hope that helps!

Nope, my question was never answered, and since a) I have no knowledge in electronics and b) English is my second language, I woulnd’t have guessed by myself what IC standed for.

So thanks! :slight_smile:

Sure thing, glad to help!


Shifting or skipping is unfortunately a pretty common problem in the 3D printing world. More often than not, it’s caused by the x-carriage binding on the rails. This can be caused by worn bushings, dirty rails or bearing misalignment.

I recommend installing our stabilized x-carriage, this upgrade has virtually eliminated skipping problems here at AOHQ (we’re running without heat sinks on our pololus, even in an insulated enclosure). It’s a no vitamin upgrade (all you need is about 4m of filament and 2 hours time) and will clean up any ‘rippling’ you might be seeing on part surfaces. The smaller pulleys are definitely a worthwhile upgrade as well.

Stl, gcode, assembly instructions and FreeCAD source files can be found here: … -carriage/


When printing a similar sized model on my AO-100 I experienced similar shifting. After close inspection, I noticed that the heated bed cable was bunching up and causing enough resistance to skip steps. I massaged (bent) the cable enough that this is no longer an issue and have been printing fine for 8+ months now and well over 40lbs of plastic.

Someone remind me to make a heated bed cable “angle it up out of the way” fitting. I’ve ran into that same issue before. THough with the new bed rail it doesn’t happen as often.