Printer stopped due to Errors, M999 to reset

This may sound common error to Lulzbot gurus- Printer stopped due to Temperature Errors, M999 to reset (cant remember the exact language).

Here is what I have done so far:

  1. Hot end thermister connection checked- both sides well connected.
  2. Hot end thermister resistance checked- shows 86 Ohms.
  3. Replaced a brand new thermister showing 89 Ohm resistance and still gave me the same error.
  4. Replaced all wiring of thermister and still gave the same error.
  5. Changed alternative computer and new USB cable and still gave the same error.

My conclusion is that the issue is with the RAMBo 1.0a board. Do you agree? Should I check anything else? Should I change HEATER_0_MAXTEMP or MINTEMP?

Your help will be greatly appreciated.


You must have the thermistor plugged in when you are measuring it, as it should read around 100,000 Ohms when unplugged.
What model of printer do you have to begin with and what temps does it say it is reading just sitting there powered on.

I have AO101. As its sitting, Prontorface indicates 28 C- a bit hotter than room temperature.

My mistake, it shows 87k Ohms in multimeter not 87 Ohms

You should have 2 temperature readings. One for the extruder and one for the heat bed. Are they both reading 28 C ?

Yes, extrude is reading 28 C and bed is reading 22 C. Bed temperature seems correct to me but 28 C is close

Finally I changed to a new Rambo 1.3 board and tinkered with it the whole day yesterday. Now it works pretty well.

I suspect that I had run a large print without fan on and that may have damaged the board. Usually Ultimachine boards are manufactured high quality and tested with precision. I’m also a bit concerned because new board doesn’t have pins at X30- which I need to install ASAP before running large prints.