Resume after pause at height (plugin) reverses filament, anyway to stop this?

I am using the stop at height plugin to embed items. I am usually not around to catch it the moment it reaches the pause height, so there will be some dripping of filament. I have it hooked up to PC while printing so I use the control to extrude some amount of filament to prime it, but when I hit resume the toolhead reverses about -10 and messes up the next few layers with gap.

Is there a way to remove that retract instruction?

I realize this is an old post but after searching around I didn’t see it answered in any other threads.

I’m having this exact problem. The filament was retracted and the print head just went through the motions without printing anything as the filament slowly fed back into it.

I’m using Cura 21.02 straight form Lulzbot’s download section, the plugin is “pause at height” that came with it.

Any help would be appreciated.

Did you ever find out an answer to this question? I just noticed my Taz 6 was doing the same thing.

Not exactly. I found the section of the script that is controlling it, but I need to give myself a crash course in gcode scripting to understand what’s happening here.

#Push the filament back, and retract again, the properly primes the nozzle when changing filament.
f.write(“G1 E%f F6000\n” % (retractAmount))
f.write(“G1 E-%f F6000\n” % (retractAmount))

Although, since I know I just changed and manually extruded some filament, I don’t really need it primed. I might try just commenting this section out and giving it a shot. I don’t have time now, but once I get to it I’ll reply with the result either way.


Nope, didn’t work. It actually went totally crazy. Definitely need to understand exactly what’s happening here before messing with the scripts.

Update: I wouldn’t say I found the solution, but I found a (potential) work around.

I’ve been messing with Simplify3D, which doesn’t handle this any better than Cura. I realized with S3D that if I paused it and just resumed it, it worked perfectly. But if I extruded to prime the new filament it would rapidly retract when resumed.

Turns out that it (seems to) reverses all the actions you did before it starts printing again. So to make it work, when I removed the filament I retracted 8 times, and when I put in the new one I extruded 8 times. Worked like a charm.

I haven’t tried it with Cura but it’s probably the same thing going on.