Retraction problem. Ideas?

I recently got a Taz 2, and I’m having a wonderful time with it. Most things I print are coming out great, but there’s one small issue that I’m hoping someone can with me with. The issue is with small models with lots of rapid retractions; the filament seems to slip further and further until it eventually backs all the way out of the print head. Here’s a prefect example of one that does it:

The base prints great, but the pins don’t print at all. After the first layer or two of the pins, the filament has backed all the way out.

If I turn retraction off, the problem goes away, but there is lots of stringing. I’ve tried 1.6mm and 1.0mm of retraction, and I suppose I could fix the problem by messing with the “extra length on restart” option in Slic3r, but that seems to be fixing the symptom and not addressing the root problem. I tried tightening the feed tension screws a bit (to about 8mm), but I don’t want to overdo anything. The hobbed bolt is clean, head temp stays at 230C, occasionally dipping to 229C (I’m printing ABS).

I have all of 4 days experience with 3D printing, and I’d love to hear from some of you more seasoned folks about what else I can try.

Would you mind sharing the gcode file you used and the Slic3r config (Slic3r > File > Export config)? I’ve found that when printing small items with a large amount of items within each layer that requires a lot of retractions having a high infill percentage helps, but with this model, that may be moot as there are a lot of thin walls.

How tight is the extruder idler? Measure from the inside of the two washers surrounding the spring on the two extruder idler screws.

gcode is attached. I had been running the idler at about 10mm, tried 8mm, printing right now at 6mm.
loom_c1-8pin.gcode (1.34 MB)

You may want to reslice the model with the following changes:

; layer_height = 0.2 (Slic3r > Print Settings > Layers and Perimeters > Layer height/first layer height)
; perimeters = 1 (Slic3r > Print Settings > Layers and Perimeters > Vertical Shells > Perimeters (minimum))

Once changed, load the model you want to cut in the Plater tab and use the Export G-code button to recut the model and regenerate the new gcode file with the new settings.

Your extruder idler washer measurement is close to mine, I find that I get great/reliable prints at 5.1mm. How does changing those two values in your Slicer configuration change the print? Can you post the Slic3r config you are using (File > Export Config)?

Hi Bob,

Does your extruder head vibrate and make a loud noise when it retracts? I’m just getting used to the printer too and had the same issue.

If so, you’re motor is loosing steps from high acceleration defaults. In the LCD you can navigate to your motion config and lower your retract and extrude accelerations/jerks so the motor can keep up. Save to EEPROM and “Bob is you’re uncle”. :slight_smile:

Off topic, but the default X axis endstop limit is also too high, I split the right Z nut piece with the stepper going too far.

Hope this helps!

What are your the settings you are using currently? How has it impacted print times arcs/etc? Do you need a Z axis nut trap? If so, email us at with your order information and we’ll be happy to see how we can help.

Orias, thanks for the suggestions. I downloaded Slicer 1.0 RC1 and started over with settings. I got the same results - prints ok and stringy with retraction off, doesn’t print pins with retraction on.

So, I made the changes you suggested. I’m trying the print now. Latest gcode file attached as well as the .ini file you requested.
loom.ini (3.21 KB)
loom_c1-8pin4.gcode (2.29 MB)

Frakk, thanks for the idea. I do occasionally hear a loud noise from the head… though not often. I’ll pay attention to what the printer is working on the next time I hear it, and I’ll try your suggestion to see how it changes things. Do these changes remain persistent between power cycles?

Orias, I tried printing with your recommendation, but same result.


I went poking around in the firmware a bit, but I could use some guidance. What parameters and values did you find worked best? I see the following which seem pertinent to this problem.
vmax e: 50
amax e: 10000
a-retract: 3000
esteps/mm: 0851.0

“A-retract” is the actual setting you need to lower to ~900, that’s what I have it set at.

“A-max e” in the safety acceleration limit, this value I would set to 1000-1100, anything above that will be too fast.
“V-max e” is the safety speed limit, I set that to 20, which is plenty fast (1200mm/min).
These will prevent any G-code to set speeds/accelerations higher, not mandatory but it can save you a lot of hair down the road.

“e-steps /mm” I also re-calibrated to ~920, giving me proper filament travel. Extrude 10-30mm from pronterface and see how much you are actually pulling in. This shouldn’t matter for the problems you experience but you’re prints will come out denser/looser if it is not right.

After you’re done changing, you have an option to make it stick after power cycles with Save, or Load, and to reset factory defaults.

Orias: Slowing down the extruder slowed down the print a little bit since these movements take a fraction of a second longer, depending on the print they add up. It made no difference with arcs and X/Y movements, but I adjusted the same settings for XYZ and found significant speed. Between Slic3r profile and hardware changes I saved 10hrs+ in a ~20hr print.

I’m happy to report the problem is fixed!

Changing the A-retract to 900 did the job. Along with the slicer changes suggested by Orias, this thing looks beautiful!

Thanks so much for the help!

This solved my issues that I had with my printer from December! 3 Help support calls couldn’t even think of this! Seriously, I didn’t realize you could change the firmware on the machine so easily(LCD).

Ive been able to pull all my parts a part since the start of my machine… Why did they set “A-retract” to 3000 on my machine in the first place? I could never understand why their slic3r profiles(retraction settings specifically) never worked properly… :unamused:

Thanks lulzbot forums!! :smiley:

Could anybody tell me how to edit these parameters on an AO-101 ?


I have a Lulzbot Mini:

How do I change these settings on a mini? What are the terminal commands to recall a setting, and set such motion control settings?